El comando RSH no acepta la entrada que se canaliza desde un archivo en Windows XP Professional con Service Pack 2 y Windows Server 2003 con Service Pack 1

Seleccione idioma Seleccione idioma
Id. de artículo: 896336 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se utiliza el comando RSH en un equipo que ejecuta Microsoft Windows XP Professional con Service Pack 2 (SP2), el comando RSH no acepta la entrada que se canaliza desde un archivo.

Por ejemplo, este comportamiento se produce cuando se utiliza el comando siguiente para leer la entrada de un archivo de texto en lugar de desde el teclado:
rsh User_Name CommandHostName -l <.txt Input_File_Name
Nota Command especifica el comando que desea ejecutar en el host remoto.

Además, puede recibir un mensaje de error que es similar al siguiente:
Terminal de lectura: el identificador no es válido.

Causa

Este problema se produce porque el comando RSH acepta entrada sólo desde el teclado en Windows XP SP2.

Solución

Windows Server 2003

Información de paquete de servicio de Windows Server 2003

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2003. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión no tiene ningún requisito previo.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Windows Server 2003, versiones basadas en 86 en x
Date         Time   Version         Size    File name 
-------------------------------------------------------------- 
21-Sep-2005  01:09  5.2.3790.2532  13,824   Rexec.exe 
21-Sep-2005  01:09  5.2.3790.2532  14,848   Rsh.exe
Windows Server 2003, versiones basadas en Itanium
Date         Time   Version         Size    File name 
-------------------------------------------------------------- 
20-Sep-2005  11:54  5.2.3790.2532  26,624   Rexec.exe IA-64 
20-Sep-2005  11:54  5.2.3790.2532  28,672   Rsh.exe IA-64 
20-Sep-2005  11:54  5.2.3790.2532  13,824   Wrexec.exe x86 
20-Sep-2005  11:54  5.2.3790.2532  14,848   Wrsh.exe x86
Windows Server 2003, versiones basadas en 64 x
Date         Time   Version          Size   File name 
-------------------------------------------------------------- 
20-Sep-2005  11:54  5.2.3790.2532   18,432  Rsh.exe 
20-Sep-2005  11:54  5.2.3790.2532   13,824  Wrexec.exe 
20-Sep-2005  11:54  5.2.3790.2532   14,848  Wrsh.exe

Windows XP

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión no tiene ningún requisito previo.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Windows XP SP2
Date        Time   Version       Size    File name
----------------------------------------------------
30-Mar-2005 01:01 5.1.2600.2643  13,824  Rexec.exe
30-Mar-2005 01:01 5.1.2600.2643  14,848  Rsh.exe
25-Feb-2005 03:53 6.1.22.4      371,936  Updspapi.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Microsoft Windows Server 2003 Service Pack 2.

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 896336 - Última revisión: sábado, 03 de noviembre de 2007 - Versión: 3.7
La información de este artículo se refiere a:
  • Microsoft Windows XP Service Pack 2 sobre las siguientes plataformas
    • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003 Service Pack 1 sobre las siguientes plataformas
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palabras clave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbfix kbbug KB896336 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 896336

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com