ID do artigo: 896593 - Última revisão: sexta-feira, 7 de abril de 2006 - Revisão: 2.4

Depois de migrar um usuário de um domínio do Active Directory diferente, o usuário não pode acessar o Windows SharePoint Services

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Sintomas

Depois de migrar um usuário de um domínio do Active Directory para outro domínio do Active Directory, o usuário enfrenta um dos seguintes sintomas:
  • O usuário não pode acessar o Microsoft Windows SharePoint Services.
  • O usuário pode acessar o Windows SharePoint Services, mas as configurações do usuário não são mais o mesmo como estavam antes da migração.

Causa

Quando um usuário é migrado no Active Directory, as alterações de SID (identificador de segurança) para o usuário. Além disso, as informações de logon para o usuário podem ser alteradas. Windows SharePoint Services e Microsoft SharePoint Portal Server 2003 armazenam informações de usuário com base no SID de usuário e as informações de logon do usuário. Quando o SID de usuário ou as informações de logon do usuário é alterado no Active Directory, Windows SharePoint Services deve ser atualizado com as novas informações de usuário para que o usuário possa acessar o Windows SharePoint Services com êxito.

Resolução

Como obter o hotfix

Esse problema é corrigido no Microsoft Windows SharePoint Services Service Pack 1 pacote de Hotfix com data 29 de março de 2005. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
896349  (http://support.microsoft.com/kb/896349/ ) Descrição do hotfix do Windows SharePoint Services Service Pack 1: 29 de março de 2005

Informações de API

O Windows SharePoint Services pacote pós-Service Pack 1 hotfix com data de 29 de março de 2005 contém uma API que você pode usar para atualizar o Windows SharePoint Services com as informações de usuário migrada. Essa nova API é composto dos seguintes dados:
  • Namespace: Microsoft.SharePoint.Administration
  • Classe: SPGlobalAdmin
  • Método: MigrateUserAccount

Uso do método

 /// <summary>
  /// Migrate a WSS user to a new login name.
  /// </summary>
  /// <param name="oldLogin">Old login name</param>
  /// <param name="newLogin">New login name</param>
  /// <param name="enforceSidHistory">If true, Active Directory will be
  /// queried to ensure that the specified old login name is contained
  /// within the new login name's SID history.</param>

  public void MigrateUserAccount(string oldLogin,
                                 string newLogin,
                                 bool enforceSidHistory);

Exemplo

 SPGlobalAdmin g = new SPGlobalAdmin();
  string oldLogin = @"DOMAIN\user";
  string newLogin = @"DOMAIN\user2";
  bool enforceSidHistory = true;

  g.MigrateUserAccount(oldLogin, newLogin, enforceSidHistory);

Parâmetros

  • Old login nameSubstitua esse valor pelo nome de usuário pré-migração original do usuário migrado. Esse nome de usuário deve estar no formato DOMÍNIO\nome_de_usuário.
  • New login nameSubstitua esse valor pelo nome novo usuário pós-migração de usuário migrada. Esse nome de usuário deve estar no formato DOMÍNIO\nome_de_usuário.
  • enforceSidHistoryDefina esse valor como True para exigir que o atributo de Histórico SID do nome de usuário que você especificou no valor do New login name contém o SID do nome de usuário especificado no valor do Old login name. Como alternativa, se você não quiser que o atributo de Histórico SID a ser verificada, defina o valor enforceSidHistory como False .
Além disso, o seguinte comando novo é adicionado à ferramenta de linha de comando Stsadm.exe:
stsadm -o migrateuser - oldlogin DOMAIN \ user - DOMAIN newlogin \ user [-ignoresidhistory]
Se você não especificar o -ignoresidhistory parâmetro nesta linha de comando, o comando consulta o Active Directory para o atributo de Histórico SID . Esse atributo é preenchido automaticamente pelo Microsoft Windows quando você migra um usuário para outro domínio.

Mensagens de erro

As seguintes mensagens de erro estão disponíveis:
  • Você recebe uma mensagem de erro "O usuário não existe" se qualquer uma das seguintes condições for verdadeira:
    • As informações de usuário que você especifica no valor do new login name são um grupo de domínio.
    • Os registros não foram atualizados porque as informações de logon do usuário original ou o SID de usuário original não foi encontrado no banco de dados de conteúdo.
  • Se a nova conta de usuário não tiver um campo de Histórico SID , ou se nenhum dos SIDs nesse campo corresponder a um SID no banco de dados de conteúdo, você receberá a seguinte mensagem de erro:
    Não é possível concluir esta ação. Tente novamente
    Observação Você também receber essa mensagem de erro se as informações de usuário que você especifica no valor do old login name estiver corrompidas.
  • Se as informações de usuário que você especifica no valor do new login name estiver corrompidas, você receber a seguinte mensagem de erro:
    O usuário ou grupo ' -newlogin argument ' é desconhecido.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

importante Se você deseja migrar um usuário para o SharePoint Portal Server 2003 usando o procedimento que é descrito no seguinte artigo da Base de dados de Conhecimento Microsoft, você deve primeiro migrar o usuário para o Windows SharePoint Services usando o hotfix mencionado neste artigo:
896161  (http://support.microsoft.com/kb/896161/ ) Um usuário não pode acessar o SharePoint Portal Server 2003 depois de migrar que o usuário de um domínio do Active Directory para outro domínio do Active Directory

A informação contida neste artigo aplica-se a:
  • Microsoft Windows® SharePoint Services
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