Article ID: 897101 - Last Review: September 17, 2009 - Revision: 2.0

Roaming profiles are not saved if you log off a Windows Vista-based, Windows XP-based, or Windows 2000-based computer

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

If you log off a Windows Vista-based, Windows XP-based, or Windows 2000-based computer, you experience the following symptoms:
  • Roaming profiles are not saved to the profile server.
  • Event entries are not added to the Application log.
  • If you are using the Microsoft User Profile Hive Cleanup Service tool, the tool does not log the log-off process.
  • The following messages are listed in the Userenv.log file:
    USERENV(1b0.7f0) 16:37:20:209 UnloadUserProfileP: Wait succeeded. In critical section.
    USERENV(1b0.7f0) 16:37:20:360 UnloadUserProfileP: Didn't unload user profile, Ref Count is 2

CAUSE

This issue may occur with certain versons of the NVIDIA video card driver. The NVIDIA driver loads the profile two times. When the user logs off, the first profile is unloaded. However, the other copy of the profile is still loaded.

RESOLUTION

To resolve this problem, use either of the following methods.

Method 1

Install the latest version of the NVIDIA driver. For information about how to do this, visit the following NVIDIA Web site:
http://www.nvidia.com/Download/index.aspx?lang=en-us (http://www.nvidia.com/Download/index.aspx?lang=en-us)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Method 2

Disable the NVIDIA Display Driver service. To do this, follow these steps:
  1. Click Start, click Run, type services.msc in the Open box, and then click OK.
  2. In the Services management console, double-click NVIDIA Display Driver Service.
  3. Under Startup type, set the type to Disabled, and then click Apply.
  4. Click Stop to stop the service if it is running.
  5. Click OK, and then restart the computer.

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Keywords: 
kbprofiles kberrmsg kbtshoot kbprb KB897101