Help and Support
 

powered byLive Search

You may be prompted to insert a Windows XP Professional CD when you run the System File Checker tool in Windows XP Home Edition

Article ID:897128
Last Review:April 11, 2005
Revision:1.0
On This Page

SYMPTOMS

When you use the System File Checker tool (Sfc.exe) on a Microsoft Windows XP Home Edition-based computer, you may be prompted to insert one of the following:
CD 1 from the Microsoft Windows XP Professional CD package
The Windows XP Service Pack 1 CD
The Windows XP Service Pack 2 CD

Back to the top

CAUSE

This issue occurs when the following .inf files contain an incorrect source media description:
Fp40ext.inf
Ims.inf

Back to the top

WORKAROUND

To work around this issue, you must change the source media description in both the Fp40ext.inf and Ims.inf files. To do this, use the following procedures.

Back to the top

Back up the Fp40ext.inf and Ims.inf files

1.In Windows Explorer, click Folder options on the Tools menu.
2.Click the View tab.
3.Under Hidden files and folders, click Show all files and folders.
4.Open the C:\Windows\Inf folder.
5.Click the Fp40ext.inf file, click Edit, and then click Copy.
6.On the Edit menu, click Paste. This creates a copy of the Fp40ext.inf file that is named Copy of Fp40ext.inf.
7.Repeat steps 5 and 6 for the Ims.inf file.

Back to the top

Modify the Fp40ext.inf and Ims.inf files

1.Open the Fp40ext.inf file in Notepad. The Fp40ext.inf file is located in the C:\Windows\inf folder.
2.Locate the line that contains the following text:
[Strings]
3.Locate each line that contains the word "Professional."
4.Delete each instance of "Professional" and replace each instance with "Home."
5.Save and close the Fp40ext.inf file.
6.Open the Ims.inf file in Notepad. The Ims.inf file is located in the C:\Windows\inf folder.
7.Locate the line that contains the following text:
[Strings]
8.Locate each line that contains the word "Professional."
9.Delete each instance of "Professional" and replace each instance with "Home."
10.Save and close the Ims.inf file.
11.Quit Notepad.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top


APPLIES TO
Microsoft Windows XP Home Edition

Back to the top

Keywords: 
kbtshoot kbprb KB897128

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.