Un file è in potrebbe essere di salvare con un nome file non corretto o con un nome di file troncato in Microsoft Internet Explorer 6

Traduzione articoli Traduzione articoli
Identificativo articolo: 897168 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di salvare un file in Microsoft Internet Explorer 6, è possibile che si verifichi uno dei seguenti problemi:
  • Impossibile salvare il file con il nome di file corretto.
  • Il file potrebbe salvare con un nome di file che è una versione troncata del nome file visualizzato nella finestra di dialogo Salva .
Si nota di questo problema quando sono vere le seguenti condizioni:
  • Il file utilizza il "Content-Disposition: attachment; filename =" intestazione per forzare un'operazione "Salva con nome" da Internet Explorer.
  • Il nome del file all'interno dell'intestazione contiene set di caratteri a byte doppio (DBCS).

Cause

Questo problema si verifica poiché la lunghezza di intestazione è maggiore di 256 byte. Internet Explorer consente una lunghezza di intestazione massima di 256 byte.

Risoluzione

Windows Server 2003

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack più recente per Windows Server 2003. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
889100Come ottenere il service pack più recente per Windows Server 2003

Informazioni sull'hotfix

Prerequisiti
Non è richiesto alcun prerequisito.
Necessità di riavvio
È necessario riavviare il computer dopo avere applicato l'hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
Date         Time   Version            Size    File name    Service pack
------------------------------------------------------------------------
12-May-2005  21:05  6.0.3790.330      627,200  Wininet.dll      
13-Jun-2005  19:03  6.0.3790.2463     662,016  Wininet.dll  SP1 

Windows XP

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), è necessario Windows XP Service Pack 1 o Service Pack 2 (SP2) installato nel computer.
Necessità di riavvio
È necessario riavviare il computer dopo avere applicato l'hotfix.
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
Date         Time   Version            Size    File name   Service pack
-----------------------------------------------------------------------
13-May-2005  06:19  6.0.2800.1508     585,216  Wininet.dll SP1     
23-Apr-2005  00:52  6.0.2900.2661     658,432  Wininet.dll SP2

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema è stato innanzitutto corretto in Windows Server 2003 Service Pack 2.

Informazioni

Dopo aver installato l'hotfix, è ancora presente una limitazione alla lunghezza dei nomi di file in Internet Explorer. Questa limitazione si verifica a causa del modo che opera di logica di cache di Internet Explorer. Dopo aver installato questo aggiornamento rapido (hotfix), un nome di file lungo viene troncato dall'inizio del nome del file. Un nome di file lunghi non viene sostituito con il nome della pagina Web distribuzione.

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 897168 - Ultima modifica: mercoledì 29 agosto 2007 - Revisione: 4.3
Le informazioni in questo articolo si applicano a:
  • Microsoft Internet Explorer 6.0 SP1 alle seguenti piattaforme
    • Microsoft Windows Server 2003 Service Pack 1
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows XP Service Pack 2
    • Microsoft Windows XP Service Pack 1
Chiavi: 
kbmt kbautohotfix kbwinserv2003presp2fix kbwinxpsp2fix kbwinxpsp1fix kbwinserv2003presp1fix kbwinserv2003sp1fix kbbug kbfix kbqfe kbpubtypekc kbhotfixserver KB897168 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 897168
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com