Artikel-ID: 897335 - Geändert am: Donnerstag, 11. Oktober 2007 - Version: 2.8

Möglicherweise Speicher Leistungsprobleme auf einem Windows Server 2003-Computer auftreten, die ein Intel Pentium 4 mit mehreren Prozessoren verwenden

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wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Sollten Sie die Registrierung sichern, bevor Sie Sie ändern. Stellen Sie sicher, dass Sie die Registrierung wiederherstellen kennen, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Beschreibung der Microsoft Windows-Registrierung

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Problembeschreibung

Auf einem Windows Server 2003-Computer, die ein Intel Pentium 4 mit mehreren Prozessoren können die folgenden Probleme auftreten:
  • Eine unerwartet langsam Startzeit.
  • Speicher Leistungsprobleme.
  • CPU Spitzenwerten im Systemprozess, die unmittelbar nach dem Start auftreten.

Ursache

Wenn ein Prozess virtuellen Speicher zuordnet, wird der Windows-Speicher-Manager die virtuellen Speicher-Seiten löschen, bevor der Speicher-Manager den anfordernden Prozess die Seiten zugreifen kann. Diese Schritt stellt sicher, dass ein Prozess Daten im virtuellen Speicher zugreifen kann, der zuvor im Besitz eines anderen Prozesses wurde.

Der Thread, der für die Reinigung verwendet verantwortlich ist NULL Seite Speicherseiten ist für eine der beiden Anweisungssets frühzeitig in des Startvorgangs konfiguriert. Standardmäßig ist die Seite NULL Thread so konfiguriert, nicht mit die Erweiterungsspeicher-Manager-Schnittstelle (XMMI) Anweisung auf Multiprozessorsystemen Pentium 4 festgelegt wird. Diese Einschränkung liegt Hardwareprobleme, die eine Abnahme der Leistung auf vielen Pentium 4-Multiprozessorsystemen verursachen vor. Unter bestimmten Bedingungen wird das XMMI-Anweisungsset falsch ausgewählt. Dieses Problem möglicherweise häufiger auf Prozessor virtuellen Computern sein, die auf Multiprozessor-Hosts benötigen. Ein virtuellen Computer möglicherweise falsch genullt Schleife auswählen, da die Virtual Machine ein einzelnes Prozessors während des Startvorgangs auf Multiprozessor Host erkennt.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Es gelten keine Voraussetzungen.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
Windows Server 2003 x 86-basierte Versionen
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  03:58  5.2.3790.309    2,407,936  Ntkrnlmp.exe
   14-Apr-2005  00:43  5.2.3790.309    2,064,896  Ntkrnlpa.exe     
   14-Apr-2005  00:43  5.2.3790.309    2,110,464  Ntkrpamp.exe
   14-Apr-2005  03:40  5.2.3790.309    2,208,768  Ntoskrnl.exe     
Windows Server 2003 mit Service Pack 1 (SP1) x 86-basierte Versionen
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  03:46  5.2.3790.2421   2,452,480  Ntkrnlmp.exe
   14-Apr-2005  06:52  5.2.3790.2421   2,266,624  Ntkrnlpa.exe     
   14-Apr-2005  03:26  5.2.3790.2421   2,306,560  Ntkrpamp.exe
   14-Apr-2005  03:46  5.2.3790.2421   2,414,592  Ntoskrnl.exe     
Windows Server 2003 Enterprise Edition für Itanium-basierte Versionen
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  06:53  5.2.3790.309    5,607,424  Ntkrnlmp.exe     IA-64
Windows Server 2003 mit SP1, Enterprise Edition für Itanium-basierte Systeme
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  06:53  5.2.3790.2421   6,476,288  Ntkrnlmp.exe     IA-64
Windows Server 2003 x 64-basierte Versionen
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  06:53  5.2.3790.2421   4,416,000  Ntkrnlmp.exe     
   14-Apr-2005  06:53  5.2.3790.2421   4,443,648  Ntoskrnl.exe     

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals im Microsoft Windows Server 2003 Service Pack 2.

Weitere Informationen

Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine Ihr Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.

Nachdem Sie den Hotfix installiert haben, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Suchen, und klicken Sie wird mit den folgenden Unterschlüssel der Registrierung der rechten Maustaste:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Kernel
  3. Klicken Sie mit der rechten Maustaste auf XMMIZeroingEnable , und klicken Sie dann auf Ändern . Wenn Sie das System zwingen, NULL XMMI verwenden möchten, legen Sie den XMMIZeroingEnable Wert auf 1 fest. Wenn Sie das System verwendet nicht XMMI NULL erzwingen möchten, legen Sie den XMMIZeroingEnable Wert auf 2 fest.
  4. Klicken Sie auf OK .
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Technischer Support für Windows X 64-Editionen

Ihr Hardwarehersteller bietet technischen Support und Unterstützung für Microsoft Windows X 64-Editionen. Ihr Hardwarehersteller bietet Support, da eine Windows X 64 Edition zusammen mit Ihrer Hardware geliefert wurde. Ihr Hardwarehersteller möglicherweise hat Windows X 64 Edition-Installation mit eigenen Komponenten verändert. Eindeutige Komponenten gehören bestimmte Gerätetreiber oder gehören optionale Einstellungen, um die Leistung der Hardware zu optimieren. Wenn Sie technische Hilfe zu Ihrer Windows X 64 Edition benötigen, wird Microsoft Unterstützung in angemessenem bietet. Allerdings müssen Sie möglicherweise den Hersteller direkt. Der Hersteller ist am besten ihm, um die Software zu unterstützen, die der Hersteller der Hardware installiert.

Weitere Informationen zu Microsoft Windows XP Professional X 64 Edition die folgende Microsoft-Website:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Weitere Informationen zu Microsoft Windows Server 2003 x 64-Editionen die folgende Microsoft-Website:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)


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Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
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