Help and Support
 

powered byLive Search
Hotfix Download Available

Internet Security and Acceleration Server 2004 stops responding or performs slowly after you configure a Web listener to use OWA forms-based authentication

Article ID:897717
Last Review:December 4, 2007
Revision:4.7
On This Page

SYMPTOMS

Microsoft Internet Security and Acceleration (ISA) Server 2004 may stop responding or may run slowly. This symptom occurs after you configure a Web listener in ISA Server 2004 to use Microsoft Outlook Web Access (OWA) forms-based authentication.

Back to the top

CAUSE

This problem occurs because the OWA forms-based filter leaks handles. Every successful log on the OWA forms-based filter leaks 8 handles. Additionally, the OWA-forms based filter leaks some handles for every subsequent user action. For example, the OWA-forms based filter leaks some handles if a user opens messages and moves between folders.

Back to the top

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024 (http://support.microsoft.com/kb/891024/) How to obtain the latest ISA Server 2004 service pack

Back to the top

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have ISA 2004 Service Pack 1 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the Microsoft Firewall service.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
ISA Server 2004, Enterprise Edition
 Date Time Version Size File name
 ---------------------------------------------------------------
 28-Apr-2005 05:59 4.0.3440.264 147,736 Cookieauthfilter.dll
ISA Server 2004, Standard Edition
 Date Time Version Size File name
 ---------------------------------------------------------------
 21-Apr-2005 09:18 4.0.2163.264 150,288 Cookieauthfilter.dll

Back to the top

WORKAROUND

To work around this problem, use one of the following methods:
Periodically, restart the Microsoft Firewall service.
Do not use OWA forms-based authentication in the Web listener configuration.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

Back to the top

MORE INFORMATION

For more information about how to install ISA Server 2004 hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:
885957 (http://support.microsoft.com/kb/885957/) How to install ISA Server hotfixes and updates

Back to the top


APPLIES TO
Microsoft Internet Security and Acceleration Server 2004 Enterprise Edition
Microsoft Internet Security and Acceleration Server 2004 Standard Edition

Back to the top

Keywords: 
kbautohotfix kbqfe kbhotfixserver kbisaserv2004stdsp1fix kbisaserv2004eepresp1fix kbfix kbbug kbpubtypekc KB897717

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.