Pokud server IAS systémem Windows Server 2003 používá ověřování nezdaří ověřování z klienta se systémem Windows XP

Překlady článku Překlady článku
ID článku: 898061 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Ověření se nezdaří z klienta se systémem Microsoft Windows XP, pokud jsou splněny následující podmínky:
  • Ověřování používá Internet Authentication Service (IAS) v počítači se systémem Microsoft Windows Server 2003.
  • Ověřování používá Extensible Authentication Protocol-Transport Layer Security (EAP-TLS).
  • Klient použije certifikát, který neobsahuje rozšířené použití klíče (EKU).

Příčina

K tomuto problému dochází, protože aktuální implementaci EAP-TLS vyžaduje přítomnost ověřování klienta EKU v certifikátu, který používá klient a server ověřování EKU.

Řešení

Tato oprava hotfix má verze pro systém Windows XP a Windows Server 2003. Při řešení těchto potíží postupujte takto:
  1. Použít verze této opravy hotfix systému Windows XP v počítači klienta.
  2. Použít verzi této opravy hotfix na serveru IAS.
  3. Vytvořit a povolit položku registru TlsServerUseAllPurposeCert na serveru IAS po použití opravy hotfix.

na systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.
Požadavky
Chcete-li použít tuto opravu hotfix, musí mít Windows XP Service Pack 2 v počítači nainstalována. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
322389získání nejnovější aktualizace Service Pack pro systém Windows XP
Požadavek na restartování
Po instalaci této opravy hotfix bude třeba restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.
INFORMACE O SOUBORECH
Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce Datum a čas v ovládacím.
Windows XP, verze x 86
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rastls.dll5.1.2600.2719112,64014. Července 200503: 06X86
Arpidfix.exe5.1.2600.271930,72014. Července 200500: 03X86
Windows XP, verze x 64
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Rastls.dll5.2.3790.2487242,68813. 7. 200512: 28X64SP1SP1QFE
Wrastls.dll5.2.3790.2487184,32013. 7. 200512: 28X86SP1WOW
Arpidfix.exe5.2.3790.248743,00813. 7. 200512: 28X64NONENelze použít

Systém Windows Server 2003

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Vytvořit a povolit položku registru TlsServerUseAllPurposeCert po použití této opravy hotfix. Postupujte takto:
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.
  2. Vyhledejte následující podklíč registru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13
  3. Tento podklíč registru klepněte pravým tlačítkem myši, přejděte na příkaz Nový a potom klepněte na příkaz Hodnota DWORD.
  4. Jako název položky registru zadejte TlsServerUseAllPurposeCert a stiskněte klávesu ENTER.
  5. Poklepejte na položku registru TlsServerUseAllPurposeCert.
  6. V dialogovém okně Upravit hodnotu DWORD klepněte ve skupinovém rámečku BaseDesítková.
  7. V textovém poli Údaj, typ 0 nebo 1 jako vhodné pro danou situaci.

    Poznámka:Pokud tato hodnota nastavena na 1, IAS server pouze odešle klientovi certifikát neobsahuje EKU. Pokud tato hodnota nastavena na 0, IAS server pouze odešle klientovi certifikát, který obsahuje EKU.

Informace o aktualizaci Service Pack

Tento problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Windows Server 2003. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
889100Jak získat nejnovější aktualizaci Service Pack pro systém Windows Server 2003

Informace o opravě hotfix

Požadavky
Chcete-li použít tuto opravu hotfix, musíte mít Windows Server 2003 Service Pack 1 (SP1) v počítači nainstalována. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
889100Jak získat nejnovější aktualizaci Service Pack pro systém Windows Server 2003
Požadavek na restartování
Po instalaci této opravy hotfix bude třeba restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.
INFORMACE O SOUBORECH
Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce Datum a čas v ovládacím.
Windows Server 2003, verze x 86
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rastls.dll5.2.3790.2487184,32014. Července 200502: 49X86
Arpidfix.exe5.2.3790.248732,25614. Července 200501: 05X86
Windows Server 2003, verze pro procesory Itanium
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Rastls.dll5.2.3790.2487437,76013. 7. 200512: 28IA-64SP1SP1QFE
Wrastls.dll5.2.3790.2487184,32013. 7. 200512: 28X86SP1WOW
Arpidfix.exe5.2.3790.248774,75213. 7. 200512: 28IA-64NONENelze použít
Windows Server 2003, verze x 64
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Rastls.dll5.2.3790.2487242,68813. 7. 200512: 28X64SP1SP1QFE
Wrastls.dll5.2.3790.2487184,32013. 7. 200512: 28X86SP1WOW
Arpidfix.exe5.2.3790.248743,00813. 7. 200512: 28X64NONENelze použít

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt. Tento problém byl poprvé opraven v Windows Server 2003 Service Pack 2.

Další informace

Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 898061 - Poslední aktualizace: 11. října 2007 - Revize: 3.3
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional
Klíčová slova: 
kbmt kbautohotfix kbwinserv2003sp2fix kbwinxppresp3fix kbwinserv2003presp2fix kbexpertiseinter kbexpertisebeginner kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB898061 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:898061

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com