Como inserir ou colar uma folha de cálculo Excel 2003 ou uma folha de cálculo Excel 2002 a um desenho no Visio

Traduções de Artigos Traduções de Artigos
Artigo: 898513 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo descreve como inserir ou colar um Microsoft Office Excel 2003 folha de cálculo ou uma folha de cálculo Microsoft Excel 2002 a um desenho no Microsoft Office Visio. Para incorporar ou ligar folha de cálculo do Excel num desenho do Visio, pode utilizar o comando objecto no menu Inserir ou pode utilizar o comando Colar especial no menu Editar . Este artigo também descreve um método que pode utilizar para apresentar uma folha de cálculo do Excel que contém várias colunas e linhas de um desenho do Visio.

INTRODUÇÃO

Este artigo descreve como inserir ou colar uma folha de cálculo Excel 2003 ou uma folha de cálculo Excel 2002 a um desenho no Visio. Pode utilizar o comando objecto no menu Inserir , ou pode utilizar o comando Colar especial no menu Editar para incorporar ou ligar folha de cálculo do Excel num desenho do Visio. Este artigo também descreve um método que pode utilizar para apresentar uma grande folha de cálculo Excel num desenho do Visio.

Quando incorporar uma folha de cálculo do Excel num desenho do Visio, a folha de cálculo do Excel torna-se parte do desenho. O conteúdo da folha de cálculo incorporado do Excel já não fazem parte do ficheiro de origem. Quando faz duplo clique folha de cálculo da Excel incorporada no desenho, o Excel executa no local. Isto é, execute o Excel a partir de no Visio. Aparecem barras de ferramentas do Excel e pode trabalhar directamente na folha de cálculo da Excel.

Quando ligar folha de cálculo do Excel num desenho do Visio, o conteúdo de folha de cálculo do Excel é armazenado no ficheiro de origem. O desenho do Visio armazena apenas a localização da folha de cálculo da Excel. Informações da folha de cálculo do Excel são actualizadas apenas quando actualiza o conteúdo do ficheiro de origem no Excel.

Incorporar ou ligar uma folha de cálculo Excel de um desenho utilizando o comando objecto no menu ' Inserir ' do Visio

Utilize o comando objecto no menu Inserir para inserir uma folha de cálculo do Excel no desenho do Visio. Pode incorporar ou ligar uma folha de cálculo do Excel existente, ou pode incorporar uma nova folha de cálculo do Excel. Para o fazer, utilize um dos seguintes métodos, consoante a situação.

Incorporar ou ligar uma folha de cálculo do Excel existente

  1. Iniciar o Visio e, em seguida, abra o desenho.
  2. Clique em objecto no menu Inserir e, em seguida, clique em criar a partir de ficheiro .
  3. Clique em Procurar . Na caixa de diálogo Procurar , localize a folha de cálculo do Excel que pretende inserir, clique em folha de cálculo da Excel e, em seguida, clique em Abrir .
  4. Clique em OK .
  5. Utilize um dos seguintes passos, consoante a situação:
    • Se pretende incorporar a folha de cálculo do Excel, certifique-se de que a caixa de verificação ligar ao ficheiro não está seleccionada. Se a caixa de verificação ligar ao ficheiro é seleccionada, clique para desmarcar a caixa de verificação ligar ao ficheiro .
    • Se pretender ligar a folha de cálculo do Excel, clique para seleccionar a caixa de verificação ligar ao ficheiro .
  6. Se pretender apresentar a folha de cálculo do Excel como um ícone no desenho, clique para seleccionar a caixa de verificação Mostrar como ícone .

    Nota Quando clica para seleccionar a caixa de verificação Mostrar como ícone , a folha de cálculo Excel é apresentada como um ícone no desenho. Para ver o conteúdo da folha de cálculo Excel, faça duplo clique no ícone.
  7. Clique em OK .

Incorporar uma nova folha de cálculo do Excel

  1. Iniciar o Visio e, em seguida, abra o desenho.
  2. Clique em ' objecto ' no menu Inserir .
  3. Clique em Folha de cálculo do Microsoft Office Excel na lista tipo de objecto , clique em Criar novo e, em seguida, clique em OK .
  4. Faça duplo clique na folha de cálculo incorporada do Excel e, em seguida, adicionar os dados que pretende. Quando terminar de trabalhar na folha de cálculo do Excel, clique numa área da página de desenho está fora da folha de cálculo Excel para apresentar as barras de ferramentas Visio novamente.

Incorporar ou ligar uma folha de cálculo Excel de um desenho utilizando o comando Colar especial no menu Editar do Visio

Utilize o comando Colar especial no menu Editar para colar uma folha de cálculo Excel ao desenho do Visio. Pode utilizar este método para incorporar ou ligar todas as células da folha de cálculo do Excel existente ou para incorporar ou ligar algumas células da folha de cálculo do Excel existente. Para o fazer, siga estes passos:
  1. Iniciar o Excel e, em seguida, abra folha de cálculo que pretende.
  2. Seleccione as células que pretende. Para seleccionar todas as células na folha de cálculo, clique no botão Seleccionar tudo .
  3. No menu Editar , clique em Copiar .
  4. Iniciar o Visio e, em seguida, abra o desenho.
  5. No menu Editar , clique em Colar especial .
  6. Utilize um dos seguintes passos, consoante a situação:
    • Se pretende incorporar a folha de cálculo do Excel, clique em Colar se não estiver já seleccionada e, em seguida, clique em Folha de cálculo do Microsoft Office Excel na lista como .
    • Se pretender ligar a folha de cálculo do Excel, clique em Colar ligação .
  7. Se pretender apresentar a folha de cálculo do Excel como um ícone no desenho, clique para seleccionar a caixa de verificação Mostrar como ícone .

    Nota Quando clica para seleccionar a caixa de verificação Mostrar como ícone , a folha de cálculo Excel é apresentada como um ícone no desenho. Para ver o conteúdo da folha de cálculo Excel, faça duplo clique no ícone.
  8. Clique em OK .

Apresentar uma grande folha de cálculo Excel no desenho do Visio

Quando incorporar uma folha de cálculo Excel grande com muitas colunas e linhas, não poderá ver todas as colunas e linhas da folha de cálculo incorporada no desenho. Tenha em atenção que, se clicar duas vezes a folha de cálculo incorporada Excel, horizontal e barras de deslocamento verticais aparecem na folha de cálculo da Excel. Pode utilizar as barras de deslocamento para ver todas as colunas e linhas na folha de cálculo incorporada.

Para apresentar todas as células de uma grande folha de cálculo Excel num desenho do Visio, utilize o seguinte método como alternativa à incorporar um desenho a folha de cálculo. Em primeiro lugar, copie a folha de cálculo do Excel como uma imagem. Em seguida, cole a imagem ao desenho do Visio. Para o fazer, siga estes passos:
  1. Para copiar o conteúdo da folha de cálculo do Excel como uma imagem, siga estes passos:
    1. Iniciar o Excel e, em seguida, abra folha de cálculo que pretende.
    2. Prima CTRL+END para mover para a última célula na folha de cálculo.
    3. Prima SHIFT + CTRL+HOME para seleccionar todo o intervalo de células.
    4. Prima a tecla SHIFT e, em seguida, clique em Copiar imagem no menu Editar .
    5. Na caixa de diálogo Copiar imagem , verifique se como mostrado no ecrã é seleccionada em aspecto . Em seguida, verifique se imagem está seleccionada em formato .
    6. Clique em OK .
  2. Para colar a imagem ao desenho do Visio, siga estes passos:
    1. Iniciar o Visio e, em seguida, abra o desenho.
    2. No menu Editar , clique em Colar .

Ajustar a folha de cálculo Excel à página de desenho do Visio

Quando inserir ou colar uma folha de cálculo Excel existente grande ao desenho do Visio, partes da folha de cálculo podem aparecer fora da página de desenho do Visio. Para ajustar a folha de cálculo Excel para a página de desenho, utilize um dos seguintes métodos, consoante a situação:
  • Redimensione a página de desenho. Para redimensionar a página de desenho, prima CTRL e, em seguida, arraste a extremidade da página de desenho para que a folha de cálculo se ajusta na página de desenho.
  • Redimensione as colunas na folha de cálculo antes de incorporar a folha de cálculo num desenho do Visio ou antes de copiar a folha de cálculo como uma imagem. Em seguida, cole a imagem para um desenho do Visio. Quando redimensionar as colunas numa folha de cálculo, pode alterar a formatação da folha de cálculo. Por conseguinte, poderá experimentar este método, utilizando uma folha de cálculo teste antes de utilizar este método na folha de cálculo que pretende apresentar num desenho do Visio. Para redimensionar as colunas na folha de cálculo, siga estes passos:
    1. Iniciar o Excel e, em seguida, abra folha de cálculo que pretende.
    2. No menu Formatar , aponte para coluna e, em seguida, clique em Ajustar automaticamente a selecção .

      Nota Se pretender anular a operação de ajuste automático, clique no botão Anular .

Referências

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
296528Como ligar um desenho a uma região específica numa folha de cálculo do Excel do Visio

Propriedades

Artigo: 898513 - Última revisão: 14 de novembro de 2006 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2002 Standard Edition nas seguintes plataformas
    • Microsoft Office Excel 2003
    • Microsoft Excel 2002 Standard Edition
Palavras-chave: 
kbmt kbnewfile kbopenfile kbhowto KB898513 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 898513

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com