Gewusst wie: Kommentare zu drucken, die von einem Bearbeiter eingefügt werden, wenn Sie das Feature Markup nachverfolgen in Visio 2010, Visio 2007 oder Visio 2003 verwenden

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 898514 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

EINFÜHRUNG

In diesem Artikel wird beschrieben, ein Makro, das Sie verwenden können, um Kommentare zu drucken, die von einem Bearbeiter eingefügt werden. Sie können dieses Makro verwenden, wenn Sie das Feature Markup nachverfolgen in Microsoft Visio 2010, Microsoft Office Visio 2007 oder Microsoft Office Visio 2003 verwenden.

Weitere Informationen

Wenn Sie das Feature Markup nachverfolgen in Visio verwenden, können Benutzer, die überprüfen Sie die Zeichnung, vorgeschlagene Änderungen hinzufügen. Vorgeschlagene Änderungen sind auch bekannt als Markup. Markup enthält Shapes, Freihand-Shapes und Kommentare. Wenn Sie eine Zeichnung, die Markup enthält drucken, werden die Kommentare, die von den Bearbeitern eingefügt werden nicht gedruckt. Verwenden Sie das Makro, das in diesem Artikel, um die Kommentare zu drucken, die von den Bearbeitern eingefügt werden beschrieben wird.

Das Makro die Kommentare, die in der Zeichnung werden extrahiert und anschließend die Kommentare in eine neue Form eingefügt. Die neue Form wird außerhalb des Zeichenblattes angezeigt. Ändern Sie die Größe des Shapes, und ziehen Sie das Shape auf das Zeichenblatt. Wenn Sie die Zeichnung drucken, werden die Kommentare angezeigt, in dem neuen Shape, das der Zeichnung hinzugefügt.

Erstellen und das Makro ausgeführt werden soll, gehen Sie folgendermaßen vor.

Microsoft bietet Programmierbeispiele, lediglich zur Veranschaulichung, ohne die Garantie, weder implizit noch explizit. Dies umfasst, ist jedoch nicht beschränkt auf konkludenten Garantien der Handelsüblichkeit oder Eignung für einen bestimmten Zweck. In diesem Artikel wird davon ausgegangen, dass Sie mit der Programmiersprache, die gezeigt wird, ist und mit den Tools, die zum Erstellen und Debuggen von Prozeduren verwendet werden, vertraut sind. Mitarbeiter der Microsoft Product Support Services können bei der Erläuterung der Funktionalität bestimmter Prozeduren helfen, jedoch werden nicht verändern Sie die folgenden Beispiele in Bezug auf eine erweiterte Funktionalität oder Prozeduren entwickeln, die auf Ihre besonderen Bedürfnisse zugeschnitten.
  1. Erstellen Sie das Makro. Gehen Sie hierzu folgendermaßen vor:
    1. Starten Sie Visio und öffnen Sie Ihre Zeichnung.
    2. Drücken Sie [ALT] + [F11], um Microsoft Visual Basic-Editor zu starten.
    3. Klicken Sie im Menü Einfügen auf Modul.
    4. Kopieren Sie den folgenden Code ein, und fügen Sie den Code in der FileName - Fenster Module Number (Code):
      Public Sub GetComments()
      Dim pagMarkup As Visio.Page
      Dim pag As Visio.Page
      Dim shp As Visio.Shape
      Dim sText As String
      Dim iRow As Integer
      
      Set pag = Visio.ActivePage
      sText = "Reviewer" & vbTab & "Date" & vbTab & "Comment"
      
      If pag.PageSheet.SectionExists(Visio.visSectionAnnotation, Visio.visExistsAnywhere) Then
      For iRow = 0 To pag.PageSheet.RowCount(Visio.visSectionAnnotation) - 1
      sText = sText & vbCrLf & pag.Document.DocumentSheet.CellsSRC(Visio.visSectionReviewer, pag.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationReviewerID).ResultIU - 1, Visio.visReviewerInitials).ResultStr("")
      sText = sText & pag.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationMarkerIndex).ResultIU
      sText = sText & vbTab & Format(pag.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationDate).ResultIU, "ddddd")
      sText = sText & vbTab & pag.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationComment).ResultStr("")
      Next iRow
      End If
      
      For Each pagMarkup In pag.Document.Pages
      If pagMarkup.Type = visTypeMarkup Then
      If pagMarkup.OriginalPage = pag Then
      If pagMarkup.PageSheet.SectionExists(Visio.visSectionAnnotation, Visio.visExistsAnywhere) Then
      sText = sText & vbCrLf
      sText = sText & vbCrLf & pag.Document.DocumentSheet.CellsSRC(Visio.visSectionReviewer, pagMarkup.ReviewerID - 1, Visio.visReviewerName).ResultStr("")
      For iRow = 0 To pagMarkup.PageSheet.RowCount(Visio.visSectionAnnotation) - 1
      sText = sText & vbCrLf & pag.Document.DocumentSheet.CellsSRC(Visio.visSectionReviewer, pagMarkup.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationReviewerID).ResultIU - 1, Visio.visReviewerInitials).ResultStr("")
      sText = sText & pagMarkup.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationMarkerIndex).ResultIU
      sText = sText & vbTab & Format(pagMarkup.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationDate).ResultIU, "ddddd")
      sText = sText & vbTab & pagMarkup.PageSheet.CellsSRC(Visio.visSectionAnnotation, iRow, Visio.visAnnotationComment).ResultStr("")
      Next iRow
      End If
      End If
      End If
      Next pagMarkup
      
      Dim iAutoSize as Integer 'new
      iAutoSize = pag.AutoSize 'new
      pag.AutoSize = 0 'new
      Set shp = pag.DrawRectangle(-pag.PageSheet.Cells("PageWidth").ResultIU, 0, 0, pag.PageSheet.Cells("PageHeight").ResultIU)
      pag.AutoSize = iAutoSize 'new
      shp.AddSection visSectionUser 'new
      shp.AddNamedRow visSectionUser, "msvNoAutoSize", visTagDefault 'new
      shp.CellsU("User.msvNoAutoSize").FormulaU = 1 'new
      shp.Cells("Para.HorzAlign").Formula = "0"
      shp.Cells("VerticalAlign").Formula = "0"
      shp.Name = "Reviewers Comments"
      shp.Text = sText
      End Sub
    5. Drücken Sie STRG + S, um die Zeichnung zu speichern.
    6. Klicken Sie im Menü Datei auf Schließen und zurück zu Visio.
  2. Führen Sie das Makro aus. Gehen Sie hierzu folgendermaßen vor:
    1. Im Menü Extras auf Makro zeigen Sie und klicken Sie dann auf Makros.
    2. Klicken Sie auf das Makro, das Sie in Schritt 1 erstellt haben, und klicken Sie dann auf Ausführen, in der Liste Makroname. Der Name des Makros ist FileName .Module Number .GetComments.

      Das Makro fügt die Kommentare in ein neues Shape, das links neben dem Zeichenblatt angezeigt wird.
  3. Ändern Sie die Größe des Shapes, die die Kommentare enthält, und ziehen Sie das Shape auf das Zeichenblatt. Wenn Sie möchten, formatieren Sie den Text im Shape. Wenn Sie Ihre Zeichnung drucken, werden die Kommentare in der Form in der Zeichnung angezeigt.

Eigenschaften

Artikel-ID: 898514 - Geändert am: Donnerstag, 13. Mai 2010 - Version: 5.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Visio Premium 2010
  • Microsoft Visio Standard 2010
  • Microsoft Visio Professional 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
Keywords: 
kbmt kbdisplay kbprint kbinfo kbhowto KB898514 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 898514
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com