Possibile riduzione delle prestazioni in Windows XP SP2 quando si utilizza il menu Preferiti in Internet Explorer o in Windows Explorer

Traduzione articoli Traduzione articoli
Identificativo articolo: 898612 - Visualizza i prodotti a cui si riferisce l?articolo.

Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne una copia di backup e di sapere come ripristinarlo in caso di problemi. Per informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Dopo avere installato Microsoft Windows XP Service Pack 2 (SP2) o l'hotfix descritto nell'articolo 840309 della Microsoft Knowledge Base (KB), è possibile notare una riduzione delle prestazioni. Questo sintomo si verifica quando si utilizza il menu Preferiti in Microsoft Internet Explorer o in Windows Explorer.

Cause

Questo problema può verificarsi nelle seguenti circostanze:
  • La cartella Documenti viene reindirizzata a un nuovo percorso.
  • Dopo avere installato Windows XP SP2 o l'hotfix nell'articolo 840309 della KB, si attiva la cache Desktop.ini.
Il processo della cache Desktop.ini è designato per memorizzare nella cache solo i file Desktop.ini che si trovano nei percorsi delle condivisioni di rete. È tuttavia possibile che con questo processo vengano invece memorizzati nella cache tutti i file aperti tramite la funzione GetPrivateProfileString. Questo aumento del carico della cache provoca la riduzione delle prestazioni.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicarlo solo ai sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguite ulteriori verifiche. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com/contactus/?ws=support
Nota In casi particolari le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Richiesta di riavvio

È necessario riavviare il computer una volta applicato l'hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione in lingua inglese di questo aggiornamento software presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.Windows XP Service Pack 1, versioni a 32 bit
   Data        Ora    Versione       Dimensione  Nome file 
   ---------------------------------------------------------- 
   25/05/2005  17.14  6.0.2800.1692   8.348.160  Shell32.dll
   25/05/2005  00.23  5.1.2600.1692     594.432  Xpsp2res.dll
   20/08/2004  22.01  6.0.2800.1579      82.432  Fldrclnr.dll
   25/05/2005  17.14  6.0.2800.1692     408.576  Shlwapi.dll
   20/08/2004  22.01  5.1.2600.1579     700.928  Sxs.dll
Windows XP Service Pack 1, versione a 64 bit (Itanium)
   Data        Ora    Versione       Dimensione  Nome file 
   ------------------------------------------------------------------
   20/08/2004  06.52  6.0.2800.1579     130.560  Fldrclnr.dll   IA-64
   25/05/2005  02.10  6.0.2800.1692  14.396.928  Shell32.dll    IA-64
   25/05/2005  02.10  6.0.2800.1692   1.117.696  Shlwapi.dll    IA-64
   20/08/2004  06.52  5.1.2600.1579   2.034.176  Sxs.dll        IA-64
   24/05/2005  09.40  5.1.2600.1692     593.920  Xpsp2res.dll   IA-64
   25/05/2005  02.10  6.0.2800.1692   2.649.088  Comctl32.dll   IA-64
   25/05/2005  02.14  6.0.2800.1692     925.184  Comctl32.dll   x86
   20/08/2004  07.01  6.0.2800.1579      82.432  Wfldrclnr.dll  x86
   25/05/2005  02.14  6.0.2800.1692   8.348.160  Wshell32.dll   x86
   25/05/2005  02.14  6.0.2800.1692     408.576  Wshlwapi.dll   x86
   20/08/2004  07.01  5.1.2600.1579     700.928  Wsxs.dll       x86
   24/05/2005  09.23  5.1.2600.1692     594.432  Wxpsp2res.dll  x86
Windows XP Service Pack 2, versioni a 32 bit
   Data        Ora    Versione       Dimensione  Nome file
   ---------------------------------------------------------
   25/05/2005  17.05  6.0.2900.2684   8.452.096  Shell32.dll
   25/05/2005  17.05  6.0.2900.2684     473.600  Shlwapi.dll
   24/05/2005  23.33  5.1.2600.2684      17.920  Xpsp3res.dll

Workaround

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.Per risolvere il problema, utilizzare uno dei metodi descritti di seguito.

Metodo 1: spostare nuovamente la cartella nel computer locale.

Metodo 2: disattivare la cache Desktop.ini. A questo scopo, attenersi alla seguente procedura:
  1. Scegliere Start, quindi Esegui, digitare regedit e scegliere OK.
  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\policies\Explorer
  3. Nel riquadro di destra dell'editor del Registro di sistema fare clic con il pulsante destro del mouse su UseDesktopIniCache, quindi scegliere Modifica.
  4. Nella finestra di dialogo Modifica valore DWORD in Dati valore digitare 0, quindi scegliere OK.
  5. Chiudere l'editor del Registro di sistema.
  6. Riavviare il computer.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Le informazioni in questo articolo si applicano a" di questo articolo.

Informazioni

Per ulteriori informazioni sull'hotfix citato nella sezione "Sintomi", fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
840309 La ricerca nella cartella Documenti presente su un'unità di rete con Esplora risorse da un computer con sistema operativo Windows XP impiega più tempo del previsto

Proprietà

Identificativo articolo: 898612 - Ultima modifica: lunedì 7 maggio 2007 - Revisione: 1.5
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
Chiavi: 
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbpubtypekc kbhotfixserver KB898612
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com