Hay una revisión disponible para un problema del Registro en los servidores Dell PowerEdge que tienen controladores de disco no nativos y versiones instaladas en fábrica de Windows Server 2003

Seleccione idioma Seleccione idioma
Id. de artículo: 898792 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Ciertos servidores Dell PowerEdge pueden tener un problema latente en el Registro. Aunque en este momento este problema del Registro puede no estar ocasionando problemas como el que se describe en este artículo, podría causarlos en el futuro.

Debido a este problema del Registro, puede aparecer un mensaje de error "Stop 0x00000051 (REGISTRY_ERROR)" cuando ejecute el Asistente para instalación de Active Directory para instalar Active Directory en un servidor miembro basado en Microsoft Windows Server 2003. Puede que también aparezca este mensaje después de instalar Windows Server 2003 Service Pack 1 (SP1).

Este problema se produce con ciertos servidores Dell PowerEdge que tienen una versión de Windows Server 2003 instalada de fábrica y usan uno de los siguientes controladores de la controladora de disco:
  • Mraid35x.sys
  • Perc2.sys
  • A320raid.sys
  • Aac.sys
  • Symmpi.sys
  • Cercsr6.sys
  • Aarich.sys
  • Fasttx2k.sys
Para obtener información adicional acerca de los problemas relacionados con éste, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
898767 No está disponible Windows Server 2003 Service Pack 1 para instalarse desde el sitio Web Microsoft Windows Update

Causa

Esto se debe a un problema de discrepancia de un contador de seguridad del Registro ocasionado por la instalación de fábrica original.

El problema puede estar latente. Puede no ocasionar errores hasta que ejecute el Asistente para instalación de Active Directory o Windows Server 2003 Service Pack 1 (SP1). El error del Registro es más probable que ocurra al actualizar un controlador de dominio a Windows Server 2003 SP1.

Si usa un sistema que pueda estar afectado por este problema, se recomienda que instale esta actualización.

Solución

Información del Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows Server 2003. Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100 Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información de la revisión

Para resolver el problema de la discrepancia en el contador de seguridad del Registro y evitarlo, aplique el hotfix que se describe en este artículo. Cuando se reinicie el sistema, este hotfix corregirá de forma preactiva el problema del Registro como parte de las funciones de comprobación de la integridad del Registro típicas del núcleo del sistema. Esta corrección evitará la posibilidad de que se produzcan errores en el futuro que puedan estar ocasionados por este problema concreto.

Si aplica este hotfix en sistemas que no sufran el problema concreto del Registro que se describe en este artículo, el hotfix examinará la integridad del Registro cuando el sistema se reinicie y encontrará que no hay ningún problema. Entonces, el sistema seguirá iniciándose correctamente.

Puede descargar este hotfix desde el vínculo de este artículo. O bien, puede hacer que este hotfix se distribuya automáticamente a los sistemas posiblemente afectados a través de Windows Update o de Actualizaciones automáticas. Si se le ofrece este hotfix a través de Windows Update, se recomienda que lo instale. Microsoft proporciona información de contacto de otros proveedores para ayudarle a encontrar asistencia técnica. Esta información de contacto puede cambiar sin previo aviso. Microsoft no garantiza la precisión de esta información de contacto de otros proveedores.

El siguiente archivo se puede descargar desde el Centro de descarga de Microsoft:


Contraer esta imagenAmpliar esta imagen
Descargar
Descargue ahora el paquete 898792.

Fecha de publicación: 28 de junio de 2005

Para obtener más información acerca de cómo descargar los archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591 Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus con el software de detección de virus más reciente disponible en la fecha de publicación del archivo. Asimismo, el archivo se almacenó en servidores seguros que ayudan a prevenir que se hagan cambios no autorizados.

Nota: el problema de discrepancia del contador de seguridad sólo se produce en las versiones basadas en x86 de Windows Server 2003 que hayan sido instaladas por Dell. Sin embargo, los paquetes de hotfix también están disponibles para las versiones basadas en x64 o en Itanium de Windows Server 2003.

Información de archivos

La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la siguiente tabla (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Windows Server 2003, versiones basadas en x86
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
05-may-200502:545.2.3790.3252.408.960Ntkrnlmp.exe
05-may-200502:245.2.3790.3252.065.920Ntkrnlpa.exe
05-may-200502:245.2.3790.3252.110.976Ntkrpamp.exe
05-may-200502:475.2.3790.3252.208.768Ntoskrnl.exe
04-may-200500:475.2.3790.324355.840Srv.sys
05-may-200503:025.2.3790.24382.454.016Ntkrnlmp.exe
05-may-200502:435.2.3790.24382.267.136Ntkrnlpa.exe
13-may-200522:515.2.3790.24382.308.096Ntkrpamp.exe
05-may-200503:025.2.3790.24382.415.616Ntoskrnl.exe
Windows Server 2003, versiones basadas en x64
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivoPlataforma
13-may-200522:515.2.3790.24384.417.536Ntkrnlmp.exex64
13-may-200522:515.2.3790.24384.444.672Ntoskrnl.exex64
Windows Server 2003, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivoPlataforma
13-may-200522:525.2.3790.3255.609.984Ntkrnlmp.exeIA-64
13-may-200522:525.2.3790.324994.304Srv.sys
13-may-200522:515.2.3790.24386.482.944Ntkrnlmp.exeIA-64

Está previsto que esta revisión se incluya con el Service Pack 2 de Windows Server 2003.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en el Service Pack 2 de Windows Server 2003.

Más información

Este problema se descubrió poco después de que se distribuyera Windows Server 2003 SP1. Microsoft y Dell trabajaron conjuntamente para eliminar la causa raíz del mismo y encontrar las soluciones apropiadas. Microsoft implementó código en Windows Update para lograr los dos objetivos siguientes:
  • Detectar los sistemas posiblemente afectados
  • Impedir que Windows Update ofreciera descargar Windows Server 2003 SP1 a los sistemas vulnerables hasta que una actualización hubiera emprendido acciones correctivas. Los sistemas vulnerables son los que podrían estar afectados por el error del Registro.
Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
898767 No está disponible Windows Server 2003 Service Pack 1 para instalarse desde el sitio Web Microsoft Windows Update
Dell trabajó para proporcionar una utilidad que asegurara los sistemas que no estaban afectados. Dell también trabajó para proporcionar la utilidad Dell RegFix de modo que se pudieran recuperar los sistemas que experimentaban el error. Microsoft publicó información acerca de este problema y un vínculo a los detalles técnicos y soluciones en el sitio Web de descarga de Windows Server 2003 SP1 y en las notas de la versión. Microsoft también trabajó para proporcionar una solución integrada que se pudiera ofrecer a través de Windows Update. Estos esfuerzos resultaron en esta solución de hotfix.

En cuanto aplique el hotfix, Windows Update detectará que el sistema ya no está en peligro. Windows Update ofrecerá entonces SP1.

El hotfix se ofrece automáticamente a través de Windows Update, Microsoft Software Update Services (SUS) y Microsoft Windows Server Update Services (WSUS) a los mismos sistemas que se identifican en el artículo de Dell.

Si se cumplen las condiciones siguientes, Windows Update determina que el sistema está potencialmente en peligro y ofrece el hotfix:
  • El archivo C:\Dell.sdr está presente. La presencia de este archivo indica una versión instalada por Dell de Windows Server 2003.
  • En la carpeta %windir%\System32 se encuentra alguno de los archivos de controlador de disco no originales concretos siguientes:
    • Mraid35x.sys
    • Perc2.sys
    • A320raid.sys
    • Aac.sys
    • Symmpi.sys
    • Cercsr6.sys
    • Aarich.sys
    • Fasttx2k.sys

Soporte técnico para las versiones basadas en x64 de Microsoft Windows

El fabricante del hardware proporciona soporte técnico y ayuda para las versiones basadas en x64 de Windows. El fabricante de hardware le proporciona soporte técnico, ya que incluyó en el hardware una versión basada en x64 de Windows. El fabricante de hardware podría haber personalizado con componentes exclusivos la instalación de Windows. Esos componentes exclusivos podrían incluir controladores de dispositivo específicos o configuraciones opcionales para maximizar el rendimiento del hardware. Microsoft hará un esfuerzo razonable para proporcionarle ayuda si necesita ayuda técnica para su versión basada en x64 de Windows. Sin embargo, es posible que deba ponerse en contacto directamente con el fabricante. El fabricante es el mejor cualificado para proporcionar el soporte técnico del software que él mismo instaló en el hardware.

Para obtener más información acerca de Microsoft Windows XP Professional x64 Edition, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/spain/windowsxp/64bit/default.mspx
Para obtener información de producto acerca de las versiones basadas en x64 de Microsoft Windows Server 2003, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/spain/windowsserver2003/64bit/default.mspx


Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, con respecto al rendimiento o la confiabilidad de estos productos.

Propiedades

Id. de artículo: 898792 - Última revisión: martes, 22 de mayo de 2007 - Versión: 5.4
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003 Service Pack 1 sobre las siguientes plataformas
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
Palabras clave: 
atdownload kbwinserv2003sp2fix kberrmsg kbqfe KB898792

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com