DisponibilitÓ di una correzione per un problema relativo al Registro di sistema su server Dell PowerEdge con specifici controller del disco non nativi e versioni preinstallate di Windows Server 2003

Traduzione articoli Traduzione articoli
Identificativo articolo: 898792 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

╚ possibile che il Registro di sistema di alcuni server Dell PowerEdge sia soggetto a un problema latente che, benchÚ al momento non causi necessariamente problemi analoghi a quello descritto in questo articolo, potrebbe presentarsi in futuro.

A causa di questo problema del Registro di sistema Ŕ possibile che durante l'esecuzione dell'Installazione guidata di Active Directory in un server membro basato su Microsoft Windows Server 2003 venga visualizzato il messaggio di errore "Stop 0x00000051 (REGISTRY_ERROR)". Questo messaggio potrebbe inoltre essere visualizzato dopo l'installazione di Windows Server 2003 Service Pack 1 (SP1).

Il problema si verifica su determinati server Dell PowerEdge con una versione preinstallata di Windows Server 2003 nei quali viene utilizzato uno dei seguenti driver controller del disco:
  • Mraid35x.sys
  • Perc2.sys
  • A320raid.sys
  • Aac.sys
  • Symmpi.sys
  • Cercsr6.sys
  • Aarich.sys
  • Fasttx2k.sys
Per ulteriori informazioni sui problemi correlati a questa situazione, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
898767 Windows Server 2003 Service Pack 1 non Ŕ disponibile per l'installazione dal sito Web Microsoft Windows Update

Cause

Il problema si verifica in conseguenza di un problema relativo alla mancata corrispondenza di un contatore di protezione nel Registro di sistema causato dalla preinstallazione originale.

Il problema potrebbe non essere evidente e non causare errori finchÚ non si esegue l'Installazione guidata di Active Directory o non si installa Windows Server 2003 SP1. L'errore del Registro di sistema si verifica con maggiore probabilitÓ quando si effettua l'aggiornamento di un controller di dominio a Windows Server 2003 SP1.

Se si utilizza un sistema potenzialmente interessato da questo problema, si consiglia di installare l'aggiornamento.

Per ulteriori informazioni sulle configurazioni di sistema specifiche interessate da questo problema, visitare il seguente sito Web Dell (informazioni in lingua inglese):
http://support.dell.com/support/topics/global.aspx/support/kb/en/document?dn=1092292

Risoluzione

Per risolvere il problema relativo alla mancata corrispondenza di un contatore di protezione nel Registro di sistema e per impedire che si verifichi un errore, utilizzare una delle seguenti procedure:
  • Applicare l'aggiornamento rapido (hotfix) descritto in questo articolo. Al riavvio del sistema questo aggiornamento rapido (hotfix) effettua la correzione del problema descritto in precedenza nell'ambito delle normali funzioni di controllo dell'integritÓ del Registro di sistema nel kernel del sistema. Questa correzione consente di eliminare definitivamente la possibilitÓ che si verifichino errori futuri a causa di questo specifico problema.

    Se questo aggiornamento rapido (hotfix) viene applicato a sistemi che non sono interessati dallo specifico problema del Registro di sistema descritto in questo articolo, al riavvio del sistema verrÓ esaminata l'integritÓ del Registro di sistema e non verranno individuati problemi. L'avvio del sistema continuerÓ quindi nel modo corretto.

    L'aggiornamento rapido (hotfix) pu˛ essere scaricato tramite il collegamento contenuto in questo articolo. In alternativa Ŕ possibile ottenere il recapito automatico dell'aggiornamento rapido (hotfix) ai sistemi potenzialmente interessati dal problema tramite Windows Update o la funzionalitÓ Aggiornamenti automatici. Se l'aggiornamento rapido (hotfix) viene proposto per il download dal sito Windows Update, si consiglia di procedere all'installazione.
  • Eseguire l'utilitÓ Dell RegPrep su tutti i server potenzialmente interessati. Per ulteriori informazioni sull'utilitÓ Dell RegPrep, visitare il seguente sito Web Dell (informazioni in lingua inglese):
    http://support.dell.com/support/topics/global.aspx/support/kb/en/document?dn=1092292
Se l'errore del Registro di sistema si Ŕ giÓ verificato, per ripristinare il sistema Ŕ necessario eseguire l'utilitÓ Dell RegFix. Per ulteriori informazioni sull'utilitÓ Dell RegFix, visitare il seguente sito Web Dell (informazioni in lingua inglese):
http://support.dell.com/support/topics/global.aspx/support/kb/en/document?dn=1092326


I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilitÓ di tali prodotti.
Microsoft fornisce informazioni su come contattare altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Queste informazioni sono soggette a modifica senza preavviso. Microsoft non si assume alcuna responsabilitÓ sull'accuratezza delle informazioni relative al contatto con altri produttori.

Il seguente file Ŕ disponibile per il download dall'Area download Microsoft:


Download del pacchetto 898792

Data di rilascio: 28 giugno 2005

Per ulteriori informazioni sul download di file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file Ŕ stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus pi¨ recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata che impedisce modifiche non autorizzate.

Nota Il problema relativo alla mancata corrispondenza di un contatore di protezione riguarda solo le versioni basate su x86 di Windows Server 2003 installate da Dell. Sono tuttavia disponibili anche pacchetti di aggiornamenti rapidi (hotfix) a supporto delle versioni di Windows Server 2003 basate su x64 e Itanium.

Informazioni sui file

La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
Windows Server 2003, versioni basate su x86
   Data        Ora    Versione      Dimensioni  Nome file
   ---------------------------------------------------------
   05/05/2005  02.54  5.2.3790.325   2.408.960  Ntkrnlmp.exe
   05/05/2005  02.24  5.2.3790.325   2.065.920  Ntkrnlpa.exe     
   05/05/2005  02.24  5.2.3790.325   2.110.976  Ntkrpamp.exe     
   05/05/2005  02.47  5.2.3790.325   2.208.768  Ntoskrnl.exe     
   04/05/2005  00.47  5.2.3790.324     355.840  Srv.sys
   05/05/2005  03.02  5.2.3790.2438  2.454.016  Ntkrnlmp.exe
   05/05/2005  02.43  5.2.3790.2438  2.267.136  Ntkrnlmp.exe
   13/05/2005  22.51  5.2.3790.2438  2.308.096  Ntkrpamp.exe
   05/05/2005  03.02  5.2.3790.2438  2.415.616  Ntoskrnl.exe
Windows Server 2003, versioni basate su x64
   Data        Ora    Versione      Dimensioni  Nome file     Piattaforma
   ----------------------------------------------------------------------
   13/05/2005  22.51  5.2.3790.2438  4.417.536  Ntkrnlmp.exe  x64
   13/05/2005  22.51  5.2.3790.2438  4.444.672  Ntoskrnl.exe  x64
Windows Server 2003, versioni basate su Itanium
   Data        Ora    Versione      Dimensioni  Nome file     Piattaforma
   ----------------------------------------------------------------------
   13/05/2005  22.52  5.2.3790.325   5.609.984  Ntkrnlmp.exe  IA-64
   13/05/2005  22.52  5.2.3790.324     994.304  Srv.sys
   13/05/2005  22.51  5.2.3790.2438  6.482.944  Ntkrnlmp.exe  IA-64


Questo aggiornamento rapido (hotfix) verrÓ incluso nel Service Pack 2 per Windows Server 2003.

Informazioni

Questo problema Ŕ stato individuato subito dopo il rilascio di Windows Server 2003 SP1. Microsoft e Dell hanno collaborato attivamente per determinare la causa principale del problema e per creare soluzioni appropriate. Il codice Ŕ stato implementato in Windows Update ai fini dei due obiettivi seguenti:
  • Per rilevare i sistemi potenzialmente interessati
  • Per impedire che sul sito Windows Update venisse offerto Windows Server 2003 SP1 per il download nei sistemi vulnerabili, finchÚ un aggiornamento non avesse consentito l'applicazione delle necessarie azioni correttive. I sistemi vulnerabili sono quelli potenzialmente soggetti all'errore del Registro di sistema.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
898767 Windows Server 2003 Service Pack 1 non Ŕ disponibile per l'installazione dal sito Web Microsoft Windows Update
Dell ha realizzato l'utilitÓ Dell RegPrep per correggere i sistemi che attualmente non sono interessati dal problema e fornisce l'utilitÓ Dell RegFix per consentire il ripristino dei sistemi sui quali si verifica l'errore. Sul sito Web del download e nelle note sulla versione di Windows Server 2003 SP1 Microsoft ha pubblicato informazioni relative al problema e un collegamento per l'accesso a dettagli tecnici e soluzioni. Microsoft fornisce inoltre una soluzione integrata disponibile tramite Windows Update. Il risultato di queste iniziative Ŕ la soluzione di aggiornamento rapido (hotfix) descritta in questo articolo.

Non appena viene applicato l'aggiornamento rapido o eseguita l'utilitÓ Dell RegPrep, Windows Update rileva che il sistema non Ŕ pi¨ soggetto a rischi e quindi viene suggerita l'installazione del Service Pack 1.

L'aggiornamento rapido (hotfix) descritto in questo articolo consente di correggere gli stessi problemi corretti dall'utilitÓ Dell RegPrep. Se si applica questo aggiornamento rapido (hotfix), non sarÓ necessario eseguire l'utilitÓ RegPrep sui sistemi elencati nell'articolo della knowledge base di Dell, nel quale sono tuttavia elencate altre procedure che si consiglia di eseguire prima dell'installazione di Windows Server 2003 SP1.

L'aggiornamento rapido (hotfix) viene presentato automaticamente tramite Windows Update, Microsoft Software Update Services (SUS) e Microsoft Windows Server Update Services (WSUS) per gli stessi sistemi identificati nell'articolo di Dell.

Se tutte le seguenti condizioni risultano vere, Windows Update determina che il sistema Ŕ potenzialmente a rischio e di conseguenza offre l'aggiornamento rapido (hotfix):
  • Nel sistema Ŕ presente il file C:\Dell.sdr. La presenza di questo file indica una versione di Windows Server 2003 preinstallata da Dell.
  • Nella cartella %windir%\System32 Ŕ presente uno dei seguenti file di driver del disco specifici non nativi:
    • Mraid35x.sys
    • Perc2.sys
    • A320raid.sys
    • Aac.sys
    • Symmpi.sys
    • Cercsr6.sys
    • Aarich.sys
    • Fasttx2k.sys

Supporto tecnico per le versioni x64 di Windows

Il fornitore di hardware offre supporto tecnico e assistenza per le versioni x64 di Microsoft Windows, poichÚ il supporto e l'assistenza tecnica per tale software vengono forniti dal produttore dell'hardware. Il produttore dell'hardware potrebbe infatti avere personalizzato l'installazione della versione di Windows basata su x64 con componenti univoci, quali specifici driver di periferica o impostazioni facoltative volte a ottimizzare le prestazioni dell'hardware. Microsoft fornirÓ assistenza solo in termini di "ragionevole sforzo" in caso di problemi con la versione di Windows basata su x64, ma potrebbe essere necessario contattare direttamente il produttore dell'hardware, in quanto soggetto pi¨ qualificato per fornire supporto per il software preinstallato sull'hardware.

Per informazioni di prodotto su Microsoft Windows XP Professional x64 Edition, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/italy/windowsxp/64bit/default.mspx
Per informazioni di prodotto sulle versioni Microsoft Windows Server 2003 x64, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/italy/windowsserver2003/64bit/default.mspx


Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 898792 - Ultima modifica: venerdý 31 marzo 2006 - Revisione: 4.3
Le informazioni in questo articolo si applicano a
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003 Service Pack 1áalle seguenti piattaforme
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
Chiavi:á
atdownload kbqfe kberrmsg KB898792
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com