Article ID: 899095 - Last Review: October 9, 2011 - Revision: 3.0

A "0x8004101D (WBEM_E_UNEXPECTED)" error is generated when you try to run a WMI query on a Windows Server 2003-based multiprocessor computer

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario. You try to run a Windows Management Instrumentation (WMI) query on a Microsoft Windows Server 2003-based high-speed multiprocessor computer. However, the query fails with a "0x8004101D (WBEM_E_UNEXPECTED)" error. When this problem occurs, the Service Host Process (SVCHOST) that is hosting the WINMGMT service consumes excessive memory. This memory is released only after you cancel the WMI query.

CAUSE

This problem occurs if the dataset that results from the WMI query is very large. On a high-speed multiprocessor computer, a WMI provider can return data much faster than the associated WMI client application can consume the data. The data that is generated by the WMI provider resides in the buffer until this data is delivered to the WMI client. If the buffer grows too large, the query fails. Then, a "0x8004101D (WBEM_E_UNEXPECTED)" error is generated.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must be running Windows Server 2003 or Windows Server 2003 Service Pack 1 (SP1).

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Jun-2005  13:09  5.2.3790.344      468,480  Wbemcore.dll     
Windows Server 2003, x86-based versions with Service Pack 1
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Jun-2005  13:18  5.2.3790.2461     509,952  Wbemcore.dll     
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   09-Jun-2005  02:34  5.2.3790.344    1,725,952  Wbemcore.dll     IA-64
Windows Server 2003, Itanium-based versions with Service Pack 1
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   09-Jun-2005  02:33  5.2.3790.2461   2,038,784  Wbemcore.dll     IA-64
Windows Server 2003, x64-based versions with Service Pack 1
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   09-Jun-2005  02:33  5.2.3790.2461   1,299,968  Wbemcore.dll     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
Keywords: 
kbautohotfix kbwinserv2003sp2fix kberrmsg kbbug kbfix kbwinserv2003presp1fix kbhotfixserver kbqfe KB899095