Cómo solucionar problemas de DTS y el tamaño de los problemas de informes de MOM 2005 base de datos

Seleccione idioma Seleccione idioma
Id. de artículo: 899158 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Experimentar uno o varios de los síntomas siguientes después de instalar Reporting Services de Operations Manager (MOM) en MOM 2005:
  • Informes MOM están vacía o incompleta.
  • Cuando intenta ver algunos informes mediante la consola de informes de MOM, puede recibir el siguiente mensaje de error:
    No hay ningún dato disponible para este informe.
  • El tamaño de la base de datos OnePoint repentinamente crece. La base de datos crece, aunque no se han cambiado uno o varios de los servidores administrados o grupos de reglas en el grupo de configuración de MOM. La base de datos OnePoint que supere el límite recomendado de 30-gigabytes (GB).
  • Los sucesos siguientes aparecen en el registro aplicación en el servidor de informes MOM:

    ID. de suceso 1001
    Origen: MOM.Datawarehousing.DTSPackageGenerator.exe
    Descripción: Trabajo de DTS de informes MOM no pudo completar correctamente

    ID. de suceso: 81
    Origen del suceso: DataTransformationServices
    Descripción: Error de la ejecución del paquete DTS siguientes:

ID. de suceso 1001 proporciona una breve descripción de por qué el paquete de servicios de transformación de datos (DTS) produjo un error. ID. de suceso 81 proporciona más detalles sobre la causa del error. La descripción de ambos eventos puede indicar que la base de datos tiene suficiente espacio libre. Ejemplos de algunas descripciones de error típico son:
  • No se pudo asignar espacio para el objeto 'SC_EventFact_Table' en la base de datos 'SystemCenterReporting' porque el grupo de archivos 'PRIMARY' está lleno.
  • El archivo de registro de base de datos 'SystemCenterReporting' está lleno. Copia el registro de transacciones para la base de datos liberar espacio del registro.
  • No se pudo asignar espacio para objeto '(SYSTEM table id:-548802855) ' en base de datos 'TEMPDB' porque el grupo de archivos 'DEFAULT' está lleno.
La regla de evento ? trabajo MOM Reporting DTS que no se pudo completar correctamente ? también puede generar una alerta. Esta alerta indica que falló la tarea que copia los datos de informes de la base de datos OnePoint a la base de datos.

Causa

Estos síntomas aparecen si el paquete DTS no puede copiar los datos de informes desde la base de datos OnePoint a la base de datos servidor de informes MOM. Esto hace que la base de datos OnePoint detener limpieza y seguirá creciendo hasta que el trabajo DTS se ejecuta correctamente.
El paquete DTS puede fallar cuando se cumplen las condiciones siguientes:
  • El paquete DTS intenta copiar muchos datos a la base de datos servidor de informes MOM.
  • La base de datos servidor de informes MOM tiene suficiente espacio libre para completar la tarea de copia.
  • Se ha modificado la tarea programada SystemCenterDTSPackageTask en tareas programadas no se ejecute automáticamente.
La base de datos de servidor de informes MOM o de registro puede quedarse espacio libre cuando intenta el paquete DTS copiar datos de la base de datos OnePoint. Este comportamiento puede producirse si el servidor MOM ya ha recopilado gran cantidad de datos. Por ejemplo, este comportamiento se produce si se cumple una de las condiciones siguientes:
  • El servidor MOM lleva funcionando mucho tiempo antes de instalar MOM Reporting Services.
  • Instalar a demasiados agentes al grupo de servidores MOM al mismo tiempo.
  • Agregar una nueva regla que genera un gran número de eventos o una gran cantidad de datos de rendimiento.
  • Ha instalado módulos de administración que han agregado muchas nuevas reglas.
  • No se ha actualizado su versión de MOM 2005 Reorting a Service Pack 1 (SP1).

Solución

Para resolver este problema, aumente el tamaño de la base de datos SystemCenterReporting y el registro de SystemCenterReporting. Para ello, siga estos pasos en el servidor de informes MOM:
  1. Haga clic en Inicio , seleccione Todos los programas , seleccione Microsoft SQL Server y, a continuación, haga clic en Administrador corporativo .
  2. Expanda los Servidores Microsoft SQL Server \ Grupo de SQL Server \ SQL Instance \ contenedor de bases de datos .

    Nota SQL Instance es la instancia con nombre que contiene la base de datos de servidor de informes MOM.
  3. Haga clic con el botón secundario del mouse en SystemCenterReporting y, a continuación, haga clic en Propiedades .
  4. En la ficha Archivos de datos , haga clic en el valor de espacio asignado (MB) y, a continuación, escriba un tamaño de archivo.
  5. En la ficha Registro de transacciones , haga clic en el valor de espacio asignado (MB) y, a continuación, escriba un tamaño de archivo.
  6. Haga clic en Aceptar para aceptar los cambios.
  7. Asegúrese de que Tempdb no se está ejecutando espacio en disco insuficiente. Tempdb contiene todas las tablas temporales y procedimientos almacenados temporales. Tempdb aumentar y disminuir como el motor de datos realiza acciones automáticamente. Si Tempdb se queda sin espacio, aparece un error en el registro SQLERROR. Puede establecer los archivos de datos y registro de transacciones a crecimiento automático del archivo , o puede expandir los archivos mediante manualmente el Administrador de empresa o Transact-SQL.
    Compruebe que hay suficiente espacio en disco físico en el disco duro donde está almacenado Tempdb. Mover Tempdb en un disco duro mayor si es necesario.
Después de aumentar el tamaño de la base de datos SystemCenterReporting y el registro de SystemCenterReporting o Tempdb, ejecutar manualmente el trabajo DTS de nuevo. Este paso copia los datos de la base de datos OnePoint a la base de datos SystemCenterReporting. Para ejecutar manualmente el trabajo DTS, siga estos pasos.

Compruebe que la tarea programada SystemCenterDTSPackageTask en tareas programadas está programada para ejecutarse automáticamente. Si es así, vaya al siguiente procedimiento.
  1. Utilice el Explorador de Windows para buscar la MOM reporting drive: carpeta de System Center Reporting\Reporting \Archivos de programa\Microsoft.
  2. Haga doble clic en el archivo MOM.Datawarehouse.DTSPackageGenerator.exe.
Nota Puede ejecutar manualmente la tarea programada SystemCenterDTSPackageTask en tareas programadas, que es en el panel de control.

Más información

Mover pequeños de datos mediante el modificador /latency o el modificador /chunksize

Se recomienda mover datos en paquetes más pequeños, si tiene una gran cantidad de datos para mover al mismo tiempo. Esto puede ayudar a evitar tiempos de espera en SQL Server. También, esto puede evitar poner demasiado una carga en el equipo que ejecuta SQL Server.

El modificador /latency

El archivo MOM.Datawarehouse.DTSPackageGenerator.exe admite un parámetro de latencia que permite especificar la antigüedad de los datos para transferir a la base de datos SystemCenterReporting. Puede utilizar el parámetro de latencia para determinar cuántos datos se copian en la base de datos SystemCenterReporting. El parámetro de latencia utiliza la sintaxis siguiente:
MOM.Datawarehousing.DTSPackageGenerator.exe /latency: number of days
Recomendamos que utilice el parámetro de latencia si falló el trabajo DTS para más de tres o cuatro días.

Para ver cuando la última vez el trabajo DTS se ejecutó correctamente, examine la tabla de ReportingSettings de la base de datos OnePoint para el valor de TimeDTSLastRan. Se muestra en hora de universal coordinada (hora media de Greenwich).

En este ejemplo, el trabajo DTS no se ha ejecutado en 30 días. Por lo tanto, puede utilizar el modificador de latencia con un valor de 20 y el trabajo migrará todos los datos más de 20 días en la base de datos de informes MOM. La próxima vez que se ejecuta el trabajo, especifique un of10 de valor para migrar nada es anterior a 10 días. Quitar la última vez que se ejecuta el trabajo, el / latencia cambiar desde el MOM.Datawarehousing.DTSPackageGenerator.exe para migrar los datos restantes. Al hacerlo, se pueden mover los datos a través sin abrumar el sistema.

Nota Este ejemplo se supone que tiene 30 días de datos en la base de datos OnePoint.
  1. Inicie sesión en el servidor de informes MOM mediante una cuenta que tenga derechos administrativos.
  2. Haga clic en Inicio , haga clic en Ejecutar , escriba cmd y, a continuación, haga clic en Aceptar .
  3. En el símbolo del sistema, copiar los parámetros de línea de comandos de SystemCenterDTSPackageTask, tipo / latencia: 20 , y, a continuación, presione ENTRAR .

    ? 20 ? Representa 20 días en este ejemplo.
  4. Repita el paso 3 utilizando marcos de tiempo menor latencia.
  5. Quitar el / latencia modificador la última vez se ejecutó el trabajo. El valor de latencia de predeterminado es 5 minutos. En este momento, se han movido todos los datos anteriores a 5 minutos.
Nota Después de que ha movido todos los datos al servidor de informes, debe quitar el parámetro de latencia en el trabajo programado.

El modificador /chunksize

Un nuevo parámetro de tamaño se ha agregado en MOM 2005 SP1 para su uso cuando ejecuta el trabajo DTS desde la línea de comandos:
  • /chunksize: fragmentar tamaño en días. Datos de gran volumen se transferirá en incrementos de tamaño del fragmento. Esto permite a la transferencia de datos de gran volumen con espacio limitado de registro. Si especifica un valor de 0 (cero), esto no fragmentar los datos. (Predeterminado = 1 día).
  • /maxchunks: número máximo de fragmentos para crear cuando está habilitada la fragmentación. (Predeterminado = 10 fragmentos).

Trabajo DTS sigue sin funcionar y recibirá un error en tiempo de espera

El trabajo DTS todavía puede fallar y generar un error en tiempo de espera si la cantidad de datos que se copiarán es muy grande.

El texto de descripción de eventos 1001, evento 81 o la salida de un comando DTS que tiene el modificador /Silent quitado puede incluir un mensaje de error que es similar al siguiente:
Tiempo de espera agotado.
El período de tiempo de espera caducó antes de completar la operación o el servidor no responde.
Terminado por el proveedor porque se alcanzó un límite de recursos de ejecución
Si los detalles en el correspondiente evento 81 no indican un error sobre el registro de base de datos o de transacción está completa, ésta es probablemente debido a problemas de conectividad o problemas de red. Por lo tanto, utilice uno de los métodos siguientes:
  • Vuelva a ejecutar el trabajo DTS.
  • Si el trabajo DTS no es correcta, cambie el valor de tiempo de espera de consulta.

Se puede aumentar el tiempo de consulta remota espera el valor predeterminado de 600 a 1200 segundos o más, o es posible establecer el tiempo de consulta remota espera en 0 (sin límite) para ver si el trabajo se completará. Para cambiar el tiempo de consulta remota espera, siga estos pasos:

Nota El valor de tiempo de espera de consulta remota debe cambiarse en el SQL Server que aloja la base de datos informes y el servidor SQL que aloja la base de datos OnePoint.
  1. En el Administrador corporativo de abrir, haga clic con el botón secundario en la base de datos SQL Server de informes y, a continuación, haga clic en Propiedades , ficha conexiones.
  2. En la página Propiedades de, haga clic en la ficha conexiones .
  3. En la sección conexiones de servidor remoto, escriba 1200 en el cuadro valor de tiempo de espera de consulta .
  4. Repita los pasos 1 a 3 en la base de datos OnePoint SQL Server.
  5. Iniciar el trabajo DTS.
    notas
    • Si el trabajo DTS agota todavía, repita los pasos 1 a 6. Sin embargo, aumentar la entrada en el paso 3 para 2400 3600 o 0.
    • Una vez resuelto el problema, restablece el valor de tiempo de espera de consulta a 600 o cualquier valor es necesario para que los trabajos posteriores para que se ejecuten correctamente.
ID. de suceso 1001 puede contener información similar al siguiente: error
Step StepInvokeInnerPackage failed. Step Error Source: Microsoft OLE DB Provider for SQL Server Step Error Description: (1:SC_Inner_DTS_Package) SubStep 'DTSStep_ExecuteSQLTask_SC_SampledNumericDataFact_View_1_Insert' failed with the following error: OLE DB provider 'SQLOLEDB' reported an error. Execution terminated by the provider because a resource limit was reached. (Microsoft OLE DB Provider for SQL Server (80040e14): OLE DB error trace [OLE/DB Provider 'SQLOLEDB' ICommandText::Execute returned 0x80040e31: Execution terminated by the provider because a resource limit was reached.].) (Microsoft OLE DB Provider for SQL Server (80040e14): [OLE/DB provider returned message: Timeout expired]) Execution was canceled by user. Step Error Code: -2147220441 Step Error Help File: Step Error Help Context ID:0

Información de solución de problemas adicional

  • Revise los registros aplicación y del sistema en SQL Server donde se ejecuta el paquete DTS.
  • Revise los registros SQL Server en SQL Server donde se ejecuta el paquete DTS.
  • Asegúrese de que las bases de datos OnePoint y SystemCenterReporting están establecidos a modo de recuperación simple. Esto se configura en la ficha Opciones de propiedades de base de datos.
  • Para obtener la información de error salida directamente desde el programa, copie la línea de comandos DTS desde la tarea programada en un símbolo del sistema.

    Por ejemplo, c:\Archivos programa\Microsoft System Center Reporting\Reporting>MOM.Datawarehousing.DTSPackageGenerator.exe /silent /srcserver:servername /srcdb:OnePoint /dwserver:servername /dwdb:SystemCenterReporting /product: "Microsoft Operations Manager"

    Quitar el /silent cambiar. Ejecute el comando desde el símbolo del sistema. Si el trabajo falla, la información de error será resultado de la pantalla. Puede copiarse a un archivo de texto para futuras referencias.
    Se realiza correctamente el trabajo DTS no se muestra ningún resultado y se mostrará un símbolo del sistema.

    Si no hay más espacio de disco disponible

    Si la base de datos SystemCenterReporting ha alcanzado el límite de la capacidad de disco duro físico, se debe agregarse más espacio en disco del mismo o la base de datos intervalo de limpieza deberán configurarse para ser más agresivo. De forma predeterminada, el período para conservar datos en la base de datos SystemCenterReporting es 395 días. Cuando instala el componente de informes de MOM 2005, se crea un procedimiento almacenado p_updategroomdays en la base de datos SystemCenterReporting. Puede utilizar este procedimiento almacenado para configurar el número de días que se conservan los datos en la base de datos SystemCenterReporting. Para obtener más información acerca de cómo cambiar el intervalo de limpieza, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    887016Cómo modificar el número de días para conservar datos en la base de datos SystemCenterReporting en Microsoft Operations Manager 2005
Para obtener más información, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
873235Cómo detener el registro de transacciones de una base de datos SQL Server desde crece inesperadamente
317375Un registro de transacciones crece inesperadamente o se completa en un equipo que ejecuta SQL Server

Propiedades

Id. de artículo: 899158 - Última revisión: martes, 09 de enero de 2007 - Versión: 9.0
La información de este artículo se refiere a:
  • Microsoft Operations Manager 2005 Enterprise Edition
Palabras clave: 
kbmt kbopmanreporting kbopmaneventmgmt kbopmanalerts kbtshoot kbdatabase kberrmsg kbevent KB899158 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 899158

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com