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文書番号: 899416 - 最終更新日: 2007年6月14日 - リビジョン: 2.1

Windows Server 2003 SP1、x64 ベースの Windows Server 2003 または Windows XP Professional x64 Edition を実行するコンピュータで、エラー メッセージ "イベント ログ ファイルが壊れています" が表示される

目次

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現象

Microsoft Windows Server 2003 Service Pack 1 (SP1) のインストール後、次のようなエラー メッセージがシステム イベント ログに記録されることがあります。
イベント ログ ファイルが壊れています。
システム イベント ログが破損して、他のメッセージを見ることができません。ログを消去してからコンピュータを再起動しても、ログが再び破損します。

この問題は、次のオペレーティング システムをインストールしている場合にも発生します。
  • x64 ベースの Windows Server 2003
  • Microsoft Windows XP Professional x64 Edition
  • Windows Server 2003 SP1 のコード ベースでビルドされたバージョンの Windows XP Professional x64 Edition
: Windows Server 2003 SP1 がインストールされていない Windows Server 2003 ベースのコンピュータから、破損したシステム イベント ログをリモートで参照することはできます。

原因

この問題は、ネットワーク アダプタのドライバがカスタマ ビット (customer bit) を正しく設定していないために発生します。ネットワーク アダプタのドライバがイベントにログを記録するときに、システム イベント ログで破損が発生することがあります。

カスタマ ビットの設定方法の詳細については、次の MSDN Web サイトを参照してください。
http://msdn2.microsoft.com/en-us/library/aa363651.aspx (http://msdn2.microsoft.com/en-us/library/aa363651.aspx)

解決方法

Windows Server 2003

Service Pack の情報

この問題を解決するには、Windows Server 2003 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
889100? (http://support.microsoft.com/kb/889100/ ) Windows Server 2003 の最新の Service Pack を入手する方法

修正プログラムの情報

必要条件
必要条件はありません。
再起動の必要性
この修正プログラムの適用後、コンピュータを再起動する必要があります。
修正プログラムの置き換えに関する情報
この更新プログラムを適用しても、他の修正プログラムが置き換えられることはありません。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。

Windows Server 2003 Service Pack 1 (SP1) (x86 ベース)
   日付            時刻    バージョン         サイズ     ファイル名

   --------------------------------------------------------------
   12-May-2005  03:14  5.2.3790.2443    69,120  Eventlog.dll     
Windows Server 2003 SP1 Enterprise Edition (Itanium ベースのシステム)
   日付            時刻    バージョン         サイズ     ファイル名

   --------------------------------------------------------------
   11-May-2005  12:51  5.2.3790.2443   184,832  Eventlog.dll  IA-64
Windows Server 2003 (x64 ベース)
   日付            時刻    バージョン         サイズ     ファイル名

   --------------------------------------------------------------
   11-May-2005  12:50  5.2.3790.2443   130,560  Eventlog.dll     

: 破損したログの消去は、修正プログラムを適用した状態で実行する必要があります。

Windows XP

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows XP Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。
必要条件
必要条件はありません。
再起動の必要性
この修正プログラムの適用後、コンピュータを再起動する必要があります。
修正プログラムの置き換えに関する情報
この更新プログラムを適用しても、他の修正プログラムが置き換えられることはありません。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
Windows XP Professional x64 Edition
   日付            時刻    バージョン         サイズ     ファイル名

   --------------------------------------------------------------
   11-May-2005  12:50  5.2.3790.2443   130,560  Eventlog.dll     

: 破損したログの消去は、修正プログラムを適用した状態で実行する必要があります。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。 この問題は Windows Server 2003 Service Pack 2 で最初に修正されました。

詳細

この修正プログラムを適用すると、Eventlog.dll ファイルに検証コードが追加されます。このコードにより、システム イベント ログが破損しないようになります。

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
824684? (http://support.microsoft.com/kb/824684/ ) マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

Windows x64 エディションのテクニカル サポート

Microsoft Windows x64 エディションはハードウェアにインストールされて提供されるため、その技術サポートと支援はハードウェアの製造元から提供されます。ハードウェアの製造元は、ハードウェアの性能を最大限に活用するために、固有のデバイス ドライバやオプション設定など、独自のコンポーネントを使用してインストール環境をカスタマイズしている場合があります。Windows x64 エディションに関する技術サポートが必要な場合、マイクロソフトではできる限りの支援を行います。しかし、製造元がハードウェアにインストールして提供するソフトウェアについては製造元によるサポートが最適であるため、ハードウェアの製造元に直接お問い合わせいただくことが必要な場合があります。

Microsoft Windows XP Professional x64 Edition の製品情報については、以下のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/windowsxp/64bit/default.mspx (http://www.microsoft.com/japan/windowsxp/64bit/default.mspx)
Microsoft Windows Server 2003 x64 Editions の製品情報については、以下のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/windowsserver2003/64bit/x64/default.mspx (http://www.microsoft.com/japan/windowsserver2003/64bit/x64/default.mspx)

関連情報

Microsoft Windows XP Professional x64 Edition の製品情報については、以下のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/windowsxp/64bit/default.mspx (http://www.microsoft.com/japan/windowsxp/64bit/default.mspx)

この資料は以下の製品について記述したものです。
  • Microsoft Windows Server 2003 Service Pack 1?を以下の環境でお使いの場合
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional x64 Edition
キーワード:?
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