ID do artigo: 899416 - Última revisão: segunda-feira, 23 de abril de 2007 - Revisão: 2.1

Uma mensagem de erro "O arquivo de log de eventos está corrompido" é exibida em um computador executando o Windows Server 2003 SP1, uma versão com base em x64 do Windows Server 2003 ou o Windows XP Professional x64 Edition

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Após a instalação do Microsoft Windows Server 2003 Service Pack 1 (SP1), uma mensagem de erro semelhante à seguinte pode ser registrada no log de eventos do Sistema:
O arquivo de log de eventos está corrompido.
O log de eventos do Sistema está corrompido e não é possível exibir outras mensagens. Se você limpar o log e reiniciar o computador, o log novamente se corrompe.

Este problema também ocorre ao instalar os seguintes sistemas operacionais:
  • Versões com base em x64 do Windows Server 2003
  • Microsoft Windows XP Professional x64 Edition
  • Uma versão do Windows XP Professional x64 Edition construída sobre a base de código do Windows Server 2003 SP1
Observação É possível exibir remotamente o log de eventos do Sistema corrompido por um computador com o Windows Server 2003 que não tem o Windows Server 2003 SP1 instalado.

Causa

Este problema ocorre porque os drivers do adaptador de rede não definem corretamente o bit de cliente. Quando os drivers do adaptador de rede tentam registrar seus próprios eventos, pode ocorrer uma corrupção no log de eventos do Sistema.

Para obter mais informações sobre como definir o bit de cliente, visite o seguinte site do MSDN (em inglês):
http://msdn2.microsoft.com/en-us/library/aa363651.aspx (http://msdn2.microsoft.com/en-us/library/aa363651.aspx)

Resolução

Servidor Windows 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para Windows Server 2003

Informações sobre o hotfix

Pré-requisitos
Não há pré-requisitos.
Requisito de reinicialização
É necessário reiniciar o computador após aplicar este hotfix.
Informações sobre a substituição do hotfix
Este hotfix não substitui nenhum outro.
Informações sobre o arquivo
A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.Windows Server 2003 com Service Pack 1 (SP1), versões com base em x86
Data         Hora   Versão            Tamanho    Nome do arquivo --------------------------------------------------------------12-mai-2005  03:14:00  5.2.3790.2443     69.120  Eventlog.dll
Windows Server 2003 com SP1, Enterprise Edition para sistemas com base em processadores Itanium
Data         Hora   Versão            Tamanho    Nome do arquivo --------------------------------------------------------------11-maio-2005  12:51:00  5.2.3790.2443     184.832  Eventlog.dll  IA-64
Windows Server 2003, sistemas com base em x64
   Data         Hora   Versão      Tamanho    Nome do Arquivo-------------------------------------------------------- 11-maio-2005  12:50  5.2.3790.24431 130,560 Eventlog.dll

Observação É necessário limpar o log corrompido com o hotfix aplicado.

Windows XP

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft, porém destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem este problema específico. Testes adicionais poderão ser realizados no hotfix. Portanto, se este problema não o prejudicar, a Microsoft aconselha aguardar o novo service pack do Windows XP que contenha este hotfix.

Para resolver esse problema imediatamente, contate o Atendimento Microsoft para obter o hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e informações sobre os custos de suporte, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação Em alguns casos, as taxas cobradas pelas ligações de suporte podem ser canceladas se uma equipe de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem à atualização específica em questão.
Pré-requisitos
Não há pré-requisitos.
Requisito de reinicialização
É necessário reiniciar o computador após aplicar este hotfix.
Informações sobre a substituição do hotfix
Este hotfix não substitui nenhum outro.
Informações sobre o arquivo
A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
Windows XP Professional x64 Edition
Data         Hora   Versão            Tamanho    Nome do arquivo -------------------------------------------------------------- 11-mai-2005  12:50  5.2.3790.2443     130.560  Eventlog.dll

Observação É necessário limpar o log corrompido com o hotfix aplicado.

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a". Esse problema foi corrigido pela primeira vez no Windows Server 2003 Service Pack 2 (SP2).

Mais Informações

Este hotfix adiciona um código de validação ao arquivo Eventlog.dll. Este código impede que o log de eventos do Sistema se corrompa.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Suporte técnico para as edições X64 do Windows

O fabricante do hardware fornece assistência técnica e suporte para as versões com base em x64 do Microsoft Windows. Ele fornece suporte porque uma edição do Windows com base em x64 foi incluída com o hardware. Também pode ter personalizado a instalação da edição x64 do Windows com componentes exclusivos. O fabricante pode incluir drivers de dispositivos específicos ou configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisar de ajuda técnica com a edição do Windows com base em x64. No entanto, pode ser necessário contatar diretamente o fabricante. O fabricante é o mais qualificado para dar suporte ao software instalado no hardware.

Para obter informações sobre o produto Microsoft Windows XP Professional x64 Edition, visite o seguinte site da Microsoft:
http://www.microsoft.com/brasil/windowsxp/64bit/default.mspx (http://www.microsoft.com/brasil/windowsxp/64bit/default.mspx)
Para obter informações sobre o produto Microsoft Windows Server 2003 edições x64, visite o seguinte site da Microsoft:
http://www.microsoft.com/brasil/windowsserver2003/64bit/x64/default.mspx (http://www.microsoft.com/brasil/windowsserver2003/64bit/x64/default.mspx)

Referências

Para obter informações sobre o produto Microsoft Windows XP Professional x64 Edition, visite o seguinte site da Microsoft:
http://www.microsoft.com/brasil/windowsxp/64bit/default.mspx (http://www.microsoft.com/brasil/windowsxp/64bit/default.mspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Service Pack 1 nas seguintes plataformas
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbbug kbfix kbqfe kbpubtypekc kbwinserv2003presp1fix kbhotfixserver kbwinserv2003sp2fix KB899416