Möglicherweise eine "Zugriff verweigert" Fehlermeldung verwenden Sie die WWW-Authenticate: Negotiate-Methode des HTTP-Authentifizierung eine Verbindung zu einem Webserver herzustellen

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 899417 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Beim Verwenden der WWW-Authenticate: Negotiate-Methode des HTTP-Authentifizierung eine Verbindung mit einem Webserver herzustellen möglicherweise sinngemäß eine Fehlermeldung, ähnelt der folgenden DNS-Cache-Eintrag der Internet Explorer-Client abläuft:
HTTP-Fehler 401 - nicht autorisiert: Zugriff wurde verweigert.

Ursache

Dieses Problem tritt auf, wenn folgenden Bedingungen erfüllt sind:
  • Der Internet Explorer erweiterte Option Aktivieren integrierte Windows-Authentifizierung ist aktiviert.
  • Sie den NetBIOS-Namen verwenden, um die Website zuzugreifen, und der Name über Domain Name System (DNS) als vollqualifizierter Domänenname (FQDN) aufgelöst wird.
  • Die Website Dienstprinzipalnamen (SPN) ist nur als einen FQDN im Active Directory-Verzeichnisdienst vorhanden.
  • Der Wert für die DNS-Cache-Timeouteinstellung ist niedriger als die DNS-Time to Live (TTL) Einstellung.
Beim Verwenden der WWW-Authenticate: Negotiate-Methode des HTTP-Authentifizierung, der Internet Explorer-Client-DNS-Cache-Eintrag möglicherweise ablaufen. Wenn dieser Eintrag abläuft, verwendet die Wininet.DLL Datei auf dem Client-Computer dem Hostnamen-Eintrag in den Uniform Resource Identifier der HTTP-Anforderung auf Anforderung ein neues SPNEGO-Token vom Domänencontroller. Datei "Wininet.dll" verwendet dieser Eintrag Hostnamen anstelle den FQDN, die von der ursprünglichen DNS-Resolver-Abfrage zurückgegeben wurde.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.

Internet Explorer 6 Service Pack 1 für Windows 98, Internet Explorer 6 Service Pack 1 für Windows Millennium Edition, Internet Explorer 6 Service Pack 1 für Windows 2000 und Internet Explorer 6 Service Pack 1 für Windows XP

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   10-Jun-2005  18:53  6.0.2800.1510     585,728  Wininet.dll   

Internet Explorer 6 für Windows XP Service Pack 2

   Date         Time   Version           Size     File name
   --------------------------------------------------------
   11-Jun-2005  02:42  6.0.2900.2696     659,456  Wininet.dll  

Microsoft Windows Server 2003, Enterprise Edition für Itanium-basierte Systeme und Microsoft Windows Server 2003, Datacenter Edition für Itanium-basierte Systeme

   Date         Time   Version         Size       File name    Platform
   ---------------------------------------------------------------------
   14-Jun-2005  03:15  6.0.3790.347    1,509,888  Wininet.dll   IA-64
   14-Jun-2005  03:15  6.0.3790.347      627,712  Wwininet.dll  x86   

x 86-basierten Versionen von Windows Server 2003

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   14-Jun-2005  03:15  6.0.3790.347      627,712  Wininet.dll  

Windows Server 2003 Service Pack 1

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   14-Jun-2005  19:14  6.0.3790.2464     662,528  Wininet.dll

Windows XP

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   11-Jun-2005  02:42  6.0.2900.2696     659,456  Wininet.dll  

Internet Explorer 7 für Windows XP Service Pack 2

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   15-May-2008  15:40  7.0.6000.20833    827,904  Wininet.dll  

Internet Explorer 7 für Windows Server 2003

   Date         Time   Version           Size       File name    Platform
   ---------------------------------------------------------------------
   16-May-2008  10:38  7.0.6000.20833    827,904    Wininet.dll  x86
   16-May-2008  08:28  7.0.6000.20833    1,024,000  Wininet.dll  x64
   16-May-2008  08:25  7.0.6000.20833    1,887,744  Wininet.dll  IA-64   

Abhilfe

Setzen Sie den Internet Explorer DNS-Cache-Zeitlimit-Wert um dieses Problem zu umgehen und reduziert die Häufigkeit dieser Fehler, auf den gleichen Wert wie der DNS-TTL-Wert in der Enterprise. Zum Festlegen von Internet Explorer DNS-Cache Timeout-Wert, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Um Internet Explorer DNS-Cache Timeoutwert pro Benutzer festzulegen, zu suchen Sie, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\Current Version\Internet Settings
  3. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  4. Geben Sie DNSCacheTimeout , und drücken Sie dann die EINGABETASTE.
  5. Klicken Sie auf DNSCacheTimeout , klicken Sie auf Bearbeiten, und klicken Sie dann auf Ändern .
  6. Geben Sie im Wert den Wert, der in Sekunden, und klicken Sie dann auf OK .

    Hinweis: Der Standardwert für die DNS-Gültigkeitsdauer ist 1800 Sekunden.
  7. Beenden Sie den Registrierungseditor.

Weitere Informationen

Gehen Sie folgendermaßen vor um diesen Hotfix zu aktivieren:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. So aktivieren diesen Hotfix pro Benutzer, suchen, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    So aktivieren diesen Hotfix pro Computer, suchen, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  4. Typ FEATURE_ENSURE_FQDN_FOR_NEGOTIATE_KB899417 , und drücken Sie dann die EINGABETASTE.
  5. Klicken Sie auf FEATURE_ENSURE_FQDN_FOR_NEGOTIATE_KB899417 .
  6. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  7. Geben Sie Iexplore.exe und dann die EINGABETASTE.
  8. Klicken Sie auf Iexplore.exe .
  9. Klicken Sie im Menü Bearbeiten auf Ändern .
  10. Geben Sie in das Feld Wertdaten 1 ein, und klicken Sie dann auf OK .

    Hinweis: Die gültigen Werte für den Unterschlüssel Iexplore.exe sind 0 und 1. Der Wert 1 aktiviert den Hotfix. Mit dem Wert 0 wird den Hotfix deaktiviert.
  11. Klicken Sie auf FEATURE_ENSURE_FQDN_FOR_NEGOTIATE_KB899417 .
  12. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  13. Geben Sie Explorer.exe ein, und drücken Sie dann die EINGABETASTE.
  14. Klicken Sie auf "Explorer.exe" .
  15. Klicken Sie im Menü Bearbeiten auf Ändern .
  16. Geben Sie in das Feld Wertdaten 1 ein, und klicken Sie dann auf OK .

    Hinweis: Die gültigen Werte für den Explorer.exe-Unterschlüssel sind 0 und 1. Der Wert 1 aktiviert den Hotfix. Mit dem Wert 0 wird den Hotfix deaktiviert.
  17. Beenden Sie den Registrierungseditor.
Weitere Informationen zu SPNEGO und Authentifizierung die folgenden Microsoft-Website:
http://msdn2.microsoft.com/en-us/library/ms995330.aspx

Status

Microsoft hat bestätigt, dass dies einen Fehler in der Microsoft ist Produkte, die im Abschnitt "Gilt für" aufgelistet sind.

Dieses Problem wurde erstmals in Windows Server 2003 Service Pack 2.

Eigenschaften

Artikel-ID: 899417 - Geändert am: Donnerstag, 15. November 2007 - Version: 2.8
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Explorer 6.0 SP1, wenn verwendet mit:
    • Microsoft Windows XP Service Pack 1
    • Microsoft Windows 2000 Professional SP4
    • Microsoft Windows 2000 Server SP4
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003 Service Pack 1
Keywords: 
kbmt kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbauthentication kbfix kbbug kbpubtypekc KB899417 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 899417
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com