WINS Manager returns only records that have a "1B" suffix in Windows Server 2003 with Service Pack 1

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Article ID: 899479 - View products that this article applies to.
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SYMPTOMS

You upgrade a system to Microsoft Windows Server 2003 Service Pack 1 (SP1). When you use Windows Internet Name Service (WINS) Manager to search records by using the Filter records matching this Name pattern setting, WINS Manager returns only records that have a "1B" suffix.

Notes
  • This problem also occurs on systems where you have installed the Windows Server 2003 Service Pack 1 Administration Tools Pack.
  • A record that has a 1B suffix contains the address of the primary domain controller (PDC).

CAUSE

This problem occurs because the query incorrectly ends. For performance reasons, WINS Manager first queries all 1B records in chunks of 500 records. Instead of looping back to look for non-1B records that match the name pattern, a flag is incorrectly set to end the query. This behavior occurs if the following conditions are true:
  • The database has over 500 WINS entries.
  • The last entry in the previous chunk of 500 does not match the name pattern of the query.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix has no prerequisites.

Restart requirement

If you close all instances of WINS Manager before you apply the hotfix, you may not have to restart the computer. If WINS Manager is running when you apply the hotfix, you must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x86-based versions with SP1
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-May-2005  20:35  5.2.3790.2455     651,776  Winssnap.dll     
Windows Server 2003, Itanium-based versions with SP1
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   31-May-2005  02:07  5.2.3790.2455   2,041,856  Winssnap.dll     IA-64
   31-May-2005  02:07  5.2.3790.2455     651,776  Wwinssnap.dll    x86
Windows Server 2003, x64-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   31-May-2005  02:07  5.2.3790.2455   1,151,488  Winssnap.dll     
   31-May-2005  02:07  5.2.3790.2455     651,776  Wwinssnap.dll    

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

Steps to reproduce the problem
  1. Install Windows Server 2003 SP1 on a WINS server that has a large database of relatively unique records.
  2. Search for records that have 1B suffixes and non-1B suffixes.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 899479 - Last Review: October 9, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 1, when used with:
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbfix kbhotfixserver kbqfe KB899479

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