Eine BizTalk Server-Hostinstanz fehlschlägt und eine Fehlermeldung "Allgemeine Netzwerk" wird in das Anwendungsprotokoll geschrieben, wenn der BizTalk Server-basierten Server eine große Anzahl von Dokumenten verarbeitet

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Problembeschreibung

Eine Instanz von Microsoft BizTalk Server-Hosts schlägt fehl, und anschließend selbst neu gestartet und Fehler, die den folgenden ähneln werden im BizTalk Server-Anwendungsprotokoll geschrieben:
Ereignistyp: Fehler
Ereignisquelle: BizTalk Server 2004
Ereigniskategorie: (1)
Ereignis-ID: 6913
Computer: BizTalkServer
Beschreibung: SQLServer, BizTalkMsgBoxDb, [DBNETLIB] [ConnectionWrite (send()).]Allgemeiner Netzwerkfehler. Weitere Informationen finden Sie in der Dokumentation..
Ereignistyp: Warnung
Ereignisquelle: BizTalk Server 2004
Ereigniskategorie: (1)
Ereignis-ID: 5410
Computer: BizTalkServer
Beschreibung: Ein Fehler aufgetreten, die der BizTalk-Dienst beenden benötigt. Die häufigsten Ursachen sind eine unerwartete außerhalb des Arbeitsspeicher und ein nicht möglich eine Verbindung herstellen oder einen Verlust der Konnektivität zu einem der BizTalk-Datenbanken. Der Dienst wird heruntergefahren und automatischer Neustart in 1 Minute. Wenn die problematische Datenbank nicht verfügbar bleibt, wird dieser Zyklus wiederholt.

Fehlermeldung: [DBNETLIB] [ConnectionWrite (send()).]Allgemeiner Netzwerkfehler. Weitere Informationen finden Sie in der Dokumentation.

Fehlerquelle:
BizTalk-Host-Name: BizTalkHost
BizTalk Windows-Dienstname: BTSSvc $ BizTalkHost.
Dieses Problem tritt normalerweise auf, wenn der BizTalk Server-basierten Server eine große Anzahl von Dokumenten verarbeitet.

Ursache

Dieses Problem tritt auf, da Windows Server 2003 und höheren Versionen implementiert eine Sicherheitsfunktion, die Größe der Warteschlange für gleichzeitige TCP/IP-Verbindungen zum Server reduziert wird. Dieses Feature unterstützt Denial-of-Service-Angriffe zu verhindern. Unter starker Auslastungsbedingungen kann das TCP/IP-Protokoll falsch eine gültige TCP/IP-Verbindungen als ein Dienstverweigerungsangriff identifizieren. Dieses Verhalten kann zu dem Problem führen, das im Abschnitt "Problembeschreibung" beschrieben wird.

Lösung

wichtig In diesem Abschnitt, Methode oder Aufgabe enthält Hinweise zum Ändern der Registrierung. Allerdings können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie daher sicher, dass Sie diese Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie der Registrierung, bevor Sie ihn ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756Zum Sichern und Wiederherstellen der Registrierung in Windows


Um dieses Problem zu beheben, deaktivieren Sie, indem den SynAttackProtect -Eintrag den folgenden Registrierungsschlüssel auf dem Computer, Microsoft SQL Server ausgeführt wird, die BizTalk Server-Datenbanken befinden sich, auf dem Hinzufügen dieser neuen Funktionalität.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Legen Sie den
SynAttackProtect
-Eintrag auf den DWORD-Wert 00000000 . Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Suchen Sie und klicken Sie auf den folgenden Registrierungsschlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  4. Geben Sie SynAttackProtect , und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie im Menü Bearbeiten auf Ändern .
  6. Geben Sie im Feld Datenwerte 00000000 . Klicken Sie auf OK .
  7. Beenden Sie den Registrierungseditor.
Hinweis: Um diese Änderung der Registrierung abzuschließen, müssen Sie den Computer neu starten, auf dem SQL Server ausgeführt wird.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.

Eigenschaften

Artikel-ID: 899599 - Geändert am: Donnerstag, 7. Juni 2007 - Version: 4.5
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Server 2006 Standard Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft SQL Server 2000 Service Pack 4
Keywords: 
kbmt kbprb KB899599 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 899599
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