Une instance de BizTalk Server hôte échoue et une erreur « grand réseau » est écrites dans le journal des applications lorsque le serveur BizTalk Server traite un volume élevé de documents

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Symptômes

Une instance hôte Microsoft BizTalk Server échoue et puis redémarre de lui-même et erreurs semblables aux suivants sont écrits dans le journal Application de serveur BizTalk :
Type d'événement : Erreur
Source de l'événement : BizTalk Server 2004
Catégorie de l'événement: (1)
L'ID d'événement : 6913
Ordinateur : BizTalkServer
Description : SQLServer, BizTalkMsgBoxDb, [DBNETLIB] [ConnectionWrite (send()).]Erreur de réseau générale. Consultez la documentation de votre réseau
Type d'événement : avertissement
Source de l'événement : BizTalk Server 2004
Catégorie de l'événement: (1)
L'ID d'événement : 5410
Ordinateur : BizTalkServer
Description : une erreur s'est produite qui nécessite le service BizTalk pour terminer. Les causes les plus courantes présentent un inattendu un de l'erreur de mémoire et une incapacité à se connecter ou une perte de connectivité à une des bases de données BizTalk. Le service est arrêté et le redémarrage automatique dans 1 minute. Si la base de données problématique demeure indisponible, ce cycle se répétera.

Message d'erreur: [DBNETLIB] [ConnectionWrite (send()).]Erreur de réseau générale. Consultez la documentation de votre réseau.

Erreur lors de la source :
Nom ordinateur hôte BizTalk : BizTalkHost
Nom du service Windows BizTalk : BTSSvc $ BizTalkHost.
Ce problème se produit généralement lorsque le serveur BizTalk Server traite un volume élevé de documents.

Cause

Ce problème se produit parce que Windows Server 2003 et versions ultérieures implémentent une fonctionnalité de sécurité qui réduit la taille de la file d'attente des connexions TCP/IP simultanées au serveur. Cette fonctionnalité empêche les attaques par déni de service. Dans des conditions surcharge, le protocole TCP/IP peut identifier incorrectement un connexions TCP/IP valide comme une attaque par déni de service. Ce comportement peut entraîner le problème décrit dans la section « Symptômes ».

Résolution

important Cette section, la méthode ou la tâche, contient des étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si modification incorrecte du Registre. Par conséquent, assurez-vous que ces étapes avec soin. Pour la protection supplémentaire, sauvegarder le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows


Pour résoudre ce problème, désactivez cette nouvelle fonctionnalité en ajoutant l'entrée SynAttackProtect à la clé de Registre suivante sur l'ordinateur qui exécute Microsoft SQL Server qui héberge vos bases de données BizTalk Server.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Définissez l'entrée
SynAttackProtect
sur une valeur DWORD de 00000000 . Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  2. Recherchez et cliquez ensuite la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  4. Tapez SynAttackProtect et puis appuyez sur ENTRÉE.
  5. Dans le menu Edition , cliquez sur Modifier .
  6. Dans la zone données de la valeur , tapez 00000000 . Cliquez sur OK .
  7. Quittez l'Éditeur du Registre.
note Pour effectuer cette modification du Registre, vous devez redémarrer l'ordinateur qui exécute SQL Server.

Statut

Ce comportement est voulu par la conception même du produit.

Propriétés

Numéro d'article: 899599 - Dernière mise à jour: jeudi 7 juin 2007 - Version: 4.5
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Server 2006 Standard Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft SQL Server 2000 Service Pack 4
Mots-clés : 
kbmt kbprb KB899599 KbMtfr
Traduction automatique
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