Můžete obdržet chybu "paměti nelze přečíst" zpráva po klepnutí na některé odkazy webu v aplikaci Internet Explorer 6

Překlady článku Překlady článku
ID článku: 899811 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Používáte aplikaci Microsoft Internet Explorer 6 v počítači, který je spuštěn jeden z následujících operačních systémů:
  • Microsoft Windows Server 2003
  • Systém Microsoft Windows XP Service Pack 1 (SP1)
  • Systém Microsoft Windows XP Service Pack 2 (SP2)
Když klepnete na určité odkazy webu, můžete obdržet následující chybovou zprávu:
Instrukce na adrese paměti 0x7777f3d9 odkaz na 0x0c73a8bb. Paměť nelze číst. Klepněte na tlačítko OK ukončete program.

Příčina

Tento problém se odkazy webu pomocí dlouhých řetězců URL, které jsou volány z skriptů. Tomuto problému dochází, protože Další informace, které souvisí s URL webu není správně uložen v souboru Index.dat. Soubor Index.dat udržuje odkaz na všechny adresy URL webu, které navštívíte. Po klepnutí na odkaz na webu v aplikaci Internet Explorer aktualizace aplikace Internet Explorer historie aplikace Internet Explorer informace, adresu URL webu. V některých případech ukládá aplikace Internet Explorer Další informace, které souvisí s adresou URL v souboru Index.dat. Pokud tyto dodatečné informace je velmi dlouhý, obdržíte chybovou zprávu.

Poznámka: Soubor Index.dat je umístěn ve složce %userprofile%\Local Settings\History.

Řešení

Systém Windows XP

Informace o opravě hotfix

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.
Požadavky
Chcete-li nainstalovat tuto opravu hotfix, je nutné systém Windows XP SP1 nebo Windows XP s aktualizací SP2 v počítači nainstalována.
Požadavek na restartování
Po instalaci této opravy hotfix, je nutné restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje žádné další opravy hotfix.
Informace o souboru
Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo Karta v nástroji datum a čas v okně Ovládací panely.
Date         Time   Version            Size    File name    Service Pack
------------------------------------------------------------------------
07-Sep-2005  02:14  6.0.2900.2754   1,485,824  Shdocvw.dll  SP2    
07-Sep-2005  00:09  5.1.2600.2754      30,720  Arpidfix.exe SP2
06-Sep-2005  10:48  6.0.2800.1740   1,338,880  Shdocvw.dll  SP1

Systém Windows Server 2003

Informace o aktualizaci Service pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Windows Server 2003. Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
889100 Jak získat nejnovější aktualizaci service pack pro systém Windows Server 2003

Informace o opravě hotfix

Požadavky
Neexistují žádné požadavky.
Požadavek na restartování
Po instalaci této opravy hotfix, je nutné restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje žádné další opravy hotfix.
Informace o souboru
Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo Karta v položce Datum a čas v okně Ovládací panely.
Date         Time   Version            Size    File name     Service Pack
-------------------------------------------------------------------------
03-Jul-2005  02:19  6.0.3790.363    1,058,304  Browseui.dll     
07-Sep-2005  02:10  6.0.3790.404    1,398,272  Shdocvw.dll      
07-Sep-2005  02:33  6.0.3790.2524   1,503,744  Shdocvw.dll   SP1   
07-Sep-2005  00:29  5.2.3790.2524      32,256  Arpidfix.exe  SP1

Jak potíže obejít

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1: Vymazání dočasných souborů Internetu a historie mezipaměti

  1. Spusťte aplikaci Internet Explorer.
  2. V Nástroje nabídky, klepněte na tlačítko Možnosti Internetu.
  3. Ve skupinovém rámečku Dočasné soubory Internetu, klepněte na tlačítko Odstranit soubory, zaškrtněte Odstranit veškerý obsah offline Zaškrtněte políčko a klepněte na tlačítko OK.
  4. Ve skupinovém rámečku Historie, klepněte na tlačítko Vymazat historiia klepněte na tlačítko OK.
  5. Vymažte dočasné soubory Internetu a historie mezipaměti. Chcete-li to provést, klepněte na tlačítko Vymazat historii ve skupinovém rámečku Historie, klepněte na tlačítko Anoa klepněte na tlačítko OK.
  6. Restartujte aplikaci Internet Explorer.

Metoda 2: Odebrat složku historie

  1. Restartujte počítač.
  2. Přihlaste se k počítači pomocí pověření pro správu.
  3. Spusťte Průzkumníka Windows.
  4. Vyhledejte složku Settings\History umístění uživatele dochází k potížím.

    Poznámka: Na Místní nastavení složka je skrytá složka. Chcete-li zobrazit tuto složku, povolit Zobrazit skryté soubory a složky možnost v programu Průzkumník Windows. Chcete-li to provést, klepněte v nabídce Nástroje v programu Průzkumník Windows, klepněte na tlačítko Možnosti složky, klepněte Zobrazení karta, povolit Zobrazit skryté soubory a složky možnost.
  5. Klepněte pravým tlačítkem myši Historie složku a potom klepněte na tlačítko Odstranit.
  6. Jakmile se zobrazí výzva k potvrzení odebrání složky, klepněte na tlačítko Ano.
  7. Ukončete program Průzkumník Windows.
  8. Restartujte počítač.
  9. Přihlaste se k počítači jako uživatel, který dojde k problému.
  10. Spusťte aplikaci Internet Explorer.
  11. V Nástroje nabídky, klepněte na tlačítko Možnosti Internetu.
  12. Ve skupinovém rámečku Dočasné soubory Internetu, klepněte na tlačítko Odstranit soubory, zaškrtněte Odstranit veškerý obsah offline Zaškrtněte políčko a klepněte na tlačítko OK.
  13. Restartujte aplikaci Internet Explorer.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro". Tento problém byl poprvé opraven v aktualizaci Windows Server 2003 Service Pack 2.

Další informace

Další informace o standardní terminologii používané při popisu aktualizací softwaru společnosti Microsoft klepněte na následující číslo článku databáze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 899811 - Poslední aktualizace: 22. května 2011 - Revize: 5.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 6.0 na těchto platformách
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Klíčová slova: 
kbautohotfix kbwinserv2003presp2fix kbwinserv2003sp1fix kbwinxppresp3fix kbie600fix kbqfe kbfix kbbug kbhotfixserver kbmt KB899811 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:899811

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com