Internet Explorer 6 で特定の Web サイトのリンクをクリックすると "メモリが "read" になることはできませんでした" というエラー メッセージが表示される

文書翻訳 文書翻訳
文書番号: 899811 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

以下のオペレーティング システムを実行しているコンピュータで Microsoft Internet Explorer 6 を使用しています。
  • Microsoft Windows Server 2003
  • Microsoft Windows XP Service Pack 1 (SP1)
  • Microsoft Windows XP Service Pack 2 (SP2)
特定の Web サイトのリンクをクリックすると、以下のエラー メッセージが表示されることがあります。
"0x7777f3d9" の命令が "0x0c73a8bb" のメモリを参照しました。メモリが "read" になることはできませんでした。
プログラムを終了するには [OK] をクリックしてください。

原因

この問題は、スクリプトから呼び出された長い URL 文字列を使用する Web サイトのリンクで発生します。この問題は、Web サイトに関連付けられる付加的な情報が Index.dat ファイルに正しく保存されないために発生します。Index.dat ファイルは、アクセスするすべての Web サイトの URL の参照を保持します。Internet Explorer で Web サイトのリンクをクリックすると、Web サイトの URL 情報で Internet Explorer の履歴が更新されます。Internet Explorer では、URL に関連付けられた付加的な情報を Index.dat ファイルに保存する場合があります。この付加的な情報が長いと、このエラー メッセージが表示されます。

: Index.dat ファイルは、%userprofile%\Local Settings\History フォルダにあります。

解決方法

Windows XP

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows XP Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。
必要条件
この修正プログラムを適用するには、Windows XP SP1 または Windows XP SP2 がコンピュータにインストールされている必要があります。
再起動の必要性
この修正プログラムの適用後、コンピュータを再起動する必要があります。
修正プログラムの置き換えに関する情報
この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻     バージョン        サイズ       ファイル名     Service Pack
   ------------------------------------------------------------------------
   07-Sep-2005  02:14  6.0.2900.2754   1,485,824  Shdocvw.dll  SP2
   07-Sep-2005  00:09  5.1.2600.2754      30,720  Arpidfix.exe SP2
   06-Sep-2005  10:48  6.0.2800.1740   1,338,880  Shdocvw.dll  SP1

Windows Server 2003

Service Pack の情報

この問題を解決するには、Windows Server 2003 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
889100 Windows Server 2003 の最新の Service Pack を入手する方法

修正プログラムの情報

必要条件
必要条件はありません。
再起動の必要性
この修正プログラムの適用後、コンピュータを再起動する必要があります。
修正プログラムの置き換えに関する情報
この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻     バージョン        サイズ       ファイル名     Service Pack
   -------------------------------------------------------------------------
   03-Jul-2005  02:19  6.0.3790.363    1,058,304  Browseui.dll
   07-Sep-2005  02:10  6.0.3790.404    1,398,272  Shdocvw.dll
   07-Sep-2005  02:33  6.0.3790.2524   1,503,744  Shdocvw.dll   SP1
   07-Sep-2005  00:29  5.2.3790.2524      32,256  Arpidfix.exe  SP1

回避策

この問題を回避するには、次のいずれかの方法を実行します。

方法 1 : インターネット一時ファイルと履歴のキャッシュをクリアする

  1. Internet Explorer を起動します。
  2. [ツール] メニューの [インターネット オプション] をクリックします。
  3. [インターネット一時ファイル] の [ファイルの削除] をクリックし、[すべてのオフライン コンテンツを削除する] チェック ボックスをオンにして、[OK] をクリックします。
  4. [履歴] の [履歴のクリア] をクリックし、[はい] をクリックします。
  5. インターネット一時ファイルおよび履歴のキャッシュをクリアするには、手順 4. で [履歴] の [履歴のクリア] をクリックし、[はい] をクリックしてから、次に [OK] をクリックして、[インターネット オプション] ダイアログ ボックスを閉じます。
  6. Internet Explorer を再起動します。

方法 2 : [History] フォルダを削除する

  1. コンピュータを再起動します。
  2. 管理者権限を使用してコンピュータにログオンします。
  3. エクスプローラを起動します。
  4. 問題が発生しているユーザーの %userprofile%\Local Settings\History フォルダを探します。

    : Local Settings フォルダは隠しフォルダです。このフォルダを表示するには、エクスプローラの [すべてのファイルとフォルダを表示する] オプションを有効にします。これを行うには、エクスプローラで [ツール] メニューをクリックし、[フォルダのオプション] をクリックし、[表示] タブをクリックして [すべてのファイルとフォルダを表示する] をクリックします。
  5. [History] フォルダを右クリックし、[削除] をクリックします。
  6. フォルダを削除するかどうかを確認するメッセージが表示されたら、[はい] をクリックします。
  7. エクスプローラを閉じます。
  8. コンピュータを再起動します。
  9. この問題が発生したユーザーとしてコンピュータにログオンします。
  10. Internet Explorer を起動します。
  11. [ツール] メニューの [インターネット オプション] をクリックします。
  12. [インターネット一時ファイル] の [ファイルの削除] をクリックし、[すべてのオフライン コンテンツを削除する] チェック ボックスをオンにして、[OK] をクリックします。
  13. Internet Explorer を再起動します。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。 この問題は Windows Server 2003 Service Pack 2 で最初に修正されました。

詳細

マイクロソフトのソフトウェア更新プログラムの説明に使用される標準的な用語の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

プロパティ

文書番号: 899811 - 最終更新日: 2007年5月21日 - リビジョン: 3.1
この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 6.0?を以下の環境でお使いの場合
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
キーワード:?
kbbug kbfix kbqfe kbie600fix kbpubtypekc kbwinserv2003sp1fix kbwinxppresp3fix kbhotfixserver kbwinserv2003presp2fix KB899811
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com