При щелчке ссылок на некоторые веб-узлы в обозревателе Internet Explorer 6 появляется сообщение об ошибке «Не удается прочитать память»

Переводы статьи Переводы статьи
Код статьи: 899811 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

Веб-обозреватель Microsoft Internet Explorer 6 используется на компьютере под управлением одной из следующих операционных систем:
  • Microsoft Windows Server 2003
  • Windows XP с пакетом обновления 1 (SP1)
  • Microsoft Windows XP с пакетом обновления 2 (SP2)
При щелчке ссылки на какой-либо веб-узел появляется следующее сообщение об ошибке:
Инструкция по адресу 0x7777f3d9 обратилась к памяти по адресу 0x0c73a8bb. Не удается прочитать память. Нажмите кнопку «OК» для завершения работы приложения.

Причина

Данная проблема возникает, если ссылки используют длинные адреса URL, вызываемые из сценариев. Причиной данной проблемы является неправильное сохранение дополнительных сведений, связанных с URL-адресом веб-узла, в файле Index.dat. В файле Index.dat регистрируются все адреса URL посещенных веб-узлов. При щелчке ссылки на веб-узел в обозревателе Internet Explorer в журнал обозревателя заносятся сведения об адресе URL веб-узла. Иногда в файле Index.dat также сохраняются дополнительные сведения об URL-адресе. Если эти сведения слишком длинные, появится сообщение об ошибке.

Примечание. Файл Index.dat находится в папке %userprofile%\Local Settings\History.

Решение

Windows XP

Сведения об исправлении

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема. Исправление может проходить дополнительное тестирование. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, в верхей части статьи базы знаний отображается раздел «Исправление доступно для загрузки». Если этот раздел не отображается, обратитесь в службу поддержки пользователей Майкрософт, чтобы получить данное исправление.

Примечание. Если возникли другие проблемы или необходимо устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы получить полный список телефонных номеров службы поддержки пользователей корпорации Майкрософт или создать отдельный запрос, посетите веб-узел корпорации Майкрософт по следующему адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это означает, что исправление для данного языка отсутствует.
Необходимые условия
Данное исправление предназначено для установки на компьютерах под управлением Windows XP с пакетом обновления 1 (SP1) или 2 (SP2).
Необходимость перезагрузки
После установки обновления компьютер необходимо перезагрузить.
Сведения о замене обновлений
Это обновление не заменяет других обновлений.
Сведения о файлах
Английская версия исправления содержит атрибуты файлов, приведенные в следующей таблице, или более поздние. Дата и время для файлов указаны в формате UTC. При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента «Дата и время» на панели управления.
Дата         Время Версия      Размер  Имя файла Пакет обновления
------------------------------------------------------------------------
07-сен-2005  02:14  6.0.2900.2754   1 485 824  Shdocvw.dll  SP2    
07-сен-2005  00:09  5.1.2600.2754      30 720  Arpidfix.exe SP2
06-сен-2005  10:48  6.0.2800.1740   1 338 880  Shdocvw.dll  SP1

Windows Server 2003

Сведения о пакете обновления

Чтобы решить эту проблему, установите последний пакет обновления для Windows Server 2003. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
889100 Получение последнего пакета обновления для Windows Server 2003

Сведения об исправлении

Необходимые условия
Отсутствуют.
Необходимость перезагрузки
После установки исправления компьютер необходимо перезагрузить.
Сведения о замене исправлений
Это исправление не заменяет других исправлений.
Сведения о файлах
Английская версия исправления содержит атрибуты файлов, приведенные в следующей таблице, или более поздние. Дата и время для файлов указаны в формате UTC. При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы выяснить разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента «Дата и время» панели управления.
Дата         Время Версия      Размер  Имя файла Пакет обновления
-------------------------------------------------------------------------
03-июл-2005  02:19  6.0.3790.363    1 058 304  Browseui.dll     
07-сен-2005  02:10  6.0.3790.404    1 398 272  Shdocvw.dll      
07-сен-2005  02:33  6.0.3790.2524   1 503 744  Shdocvw.dll   SP1   
07-сен-2005  00:29  5.2.3790.2524      32 256  Arpidfix.exe  SP1

Временное решение

Для обхода проблемы используйте один из следующих способов.

Способ 1. Удаление временных файлов Интернета и кэша журнала

  1. Запустите обозреватель Internet Explorer.
  2. В меню Сервис выберите команду Свойства обозревателя.
  3. В группе Временные файлы Интернета нажмите кнопку Удалить файлы, установите флажок Удалить это содержимое и нажмите кнопку .
  4. В группе Журнал нажмите кнопку Очистить. В появившемся окне нажмите кнопку ОК.
  5. Удаление временных файлов Интернета и кэша журнала. Для этого в группе Журнал нажмите кнопку Очистить, щелкните Да, затем нажмите кнопку ОК.
  6. Перезапустите Internet Explorer.

Способ 2. Удаление папки History

  1. Перезагрузите компьютер.
  2. Используйте привилегии администратора для входа в систему.
  3. Запустите проводник.
  4. Найдите папку %userprofile%\Local Settings\History для пользователя, у которого возникла рассматриваемая проблема.

    Примечание. Папка Local Settings является скрытой. Для просмотра этой папки включите в проводнике параметр Показывать скрытые файлы и папки. Для этого в проводнике Windows щелкните меню «Сервис», выберите пункт Свойства папки, перейдите на вкладку Вид и установите флажок Показывать скрытые файлы и папки.
  5. Щелкните правой кнопкой мыши на папке History и выберите команду Удалить.
  6. Нажмите кнопку Да, чтобы подтвердить удаление.
  7. Закройте проводник.
  8. Перезагрузите компьютер.
  9. Войдите в систему с помощью учетной записи пользователя, у которого возникла рассматриваемая проблема.
  10. Запустите Internet Explorer.
  11. В меню Сервис выберите команду Свойства обозревателя.
  12. В группе Временные файлы Интернета нажмите кнопку Удалить файлы, установите флажок Удалить это содержимое и нажмите кнопку .
  13. Перезапустите Internet Explorer.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Информация в данной статье применима к». Первое исправление этой проблемы появилось в пакете обновления 2 (SP2) для Windows Server 2003.

Дополнительная информация

Дополнительные сведения о стандартной терминологии, которую корпорация Майкрософт использует для описания обновлений программного обеспечения, см. в следующей статье базы знаний Майкрософт:
824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Свойства

Код статьи: 899811 - Последний отзыв: 11 сентября 2008 г. - Revision: 3.5
Информация в данной статье относится к следующим продуктам.
  • Microsoft Internet Explorer 6.0 на следующих платформах
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Ключевые слова: 
kbautohotfix kbwinserv2003presp2fix kbwinserv2003sp1fix kbwinxppresp3fix kbie600fix kbqfe kbfix kbbug kbpubtypekc kbhotfixserver KB899811

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com