A program that is configured to run during the terminal server session startup does not start if you remotely log on to a computer that is running Windows XP Tablet PC Edition

Article translations Article translations
Article ID: 899867 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  1. You log on to a terminal server session. The terminal server is a computer that is running Microsoft Windows XP Tablet PC Edition.
  2. The terminal server session starts a program during the terminal server session startup.
  3. The program that starts during the terminal server session startup starts the Wisptis.exe process.
  4. You log off the terminal server session.
After you log off the terminal server session, the Wisptis.exe process stays resident in memory. If you try to log back on to the terminal server session, the program that starts during the terminal server session startup cannot start any more.

Note The Wisptis.exe process is a pen input device utility for the Microsoft Tablet PC.

CAUSE

This issue occurs because the Wisptis.exe process stays resident in memory after the last terminal server session ends. Therefore, the program that starts during the terminal server session startup cannot start the next time that you log on.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To resolve this issue and make sure that the Wisptis.exe process is closed after each terminal server session, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\SysProcs
  3. Right-click the SysProcs key, point to New, and then click DWORD Value.
  4. Type wisptis.exe in the Name box, and then press ENTER.
  5. Double-click wisptis.exe to open the Edit DWORD Value box.
  6. If the DWORD value is anything other than 0, change the value to 0, and then click OK. If the DWORD value is 0, click Cancel.
  7. Quit Registry Editor.

Properties

Article ID: 899867 - Last Review: September 23, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kblogin kbtshoot kbprb KB899867

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com