Auf einem Windows XP Professional x64 Edition-Computer wird möglicherweise im Systemprotokoll das Ereignis 10016 verzeichnet

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Problembeschreibung

Auf einem Microsoft Windows XP Professional x64 Edition-Computer werden im Systemprotokoll möglicherweise Ereignisse etwa folgenden Inhalts verzeichnet:

Typ: Fehler
Ereignisquelle: DCOM
Ereigniskategorie: Keine
Ereignis-ID: 10016
Datum: Datum
Uhrzeit: Uhrzeit
Benutzer: NT AUTHORITY\LOCAL SERVICE

Beschreibung: Durch die anwendungsspezifischen Berechtigungseinstellungen wird dem Benutzer Benutzername SID Benutzer_SID keine Berechtigung zum lokalen Starten für die COM-Serveranwendung mit CLSID {AppGUID} gewährt. Diese Sicherheitsberechtigung kann mit dem Verwaltungsprogramm für Komponentendienste geändert werden.

Ereignistyp: Fehler
Ereignisquelle: DCOM
Ereigniskategorie: Keine
Ereignis-ID: 10016
Datum: Datum
Uhrzeit: Uhrzeit
Benutzer: Netzwerkdienste

Beschreibung: Durch die anwendungsspezifischen Berechtigungseinstellungen wird dem Benutzer Benutzername SID Benutzer_SID keine Berechtigung zum lokalen Starten für die COM-Serveranwendung mit CLSID {AppGUID} gewährt. Diese Sicherheitsberechtigung kann mit dem Verwaltungsprogramm für Komponentendienste geändert werden.

Ursache

Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen erfüllt ist:
  • Ein Programm mit der Klassenkennung (CLSID), die in der Meldung angezeigt wird, versucht die COM-Komponente mithilfe der DCOM-Infrastruktur zu starten. Der Benutzer verfügt jedoch nicht über die erforderlichen Berechtigungen, die COM-Komponente zu starten.
  • Das Netzwerkdienstkonto verfügt nicht über die korrekten Berechtigungen.

Lösung

Wichtig Dieser Abschnitt bzw. die Methoden- oder Aufgabenbeschreibung enthält Hinweise zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Als Schutzmaßnahme sollten Sie eine Sicherungskopie der Registrierung erstellen, bevor Sie sie bearbeiten. So ist gewährleistet, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756 Sichern und Wiederherstellen der Registrierung in Windows


Wenden Sie je nach der Ursache des Problems eine der folgenden Methoden an, um dieses Problem zu beheben.

Dem Benutzer die Berechtigungen zum Starten der COM-Komponente erteilen

Erteilen Sie dem Benutzer die Berechtigungen, die COM-Komponente zu starten. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie im Feld Öffnen den Befehl regedit ein, und klicken Sie auf OK.
  2. Klicken Sie auf den folgenden Registrierungsteilschlüssel:
    HKEY_CLASSES_ROOT\CLSID\CLSID value
    Hinweis In diesem Unterschlüssel steht "CLSID value" für die CLSID-Informationen, die in der Meldung angezeigt werden.
  3. Doppelklicken Sie im rechten Fensterbereich auf AppID.

    Das Dialogfeld Zeichenfolge bearbeiten wird angezeigt. Lassen Sie das Dialogfeld geöffnet, und fahren Sie mit dem nächsten Schritt fort.
  4. Klicken Sie auf Start und dann auf Ausführen, geben Sie dcomcnfg in das Feld Öffnen ein, und klicken Sie anschließend auf OK.

    Wenn Sie eine Windows-Sicherheitsmeldung mit der Frage erhalten, ob das Programm Microsoft Management Console weiterhin geblockt werden soll, klicken Sie auf die Option zum Entsperren des Programms.
  5. Doppelklicken Sie in den Komponentendiensten auf Komponentendienste, doppelklicken Sie auf Computer, doppelklicken Sie auf Arbeitsplatz, und klicken Sie danach auf DCOM-Konfiguration.
  6. Suchen Sie im Detailfenster das Programm unter dem Anzeigenamen.

    Wenn anstelle des Anzeigenamens die AppGUID-Kennung aufgeführt ist, suchen Sie das Programm unter dieser Kennung.
  7. Klicken Sie mit der rechten Maustaste auf das Programm, und klicken Sie danach mit der linken Maustaste auf Eigenschaften.
  8. Klicken Sie auf die Registerkarte Sicherheit.
  9. Klicken Sie im Bereich Start- und Aktivierungsberechtigungen auf Anpassen, und klicken Sie dann auf Bearbeiten.
  10. Klicken Sie auf Hinzufügen, geben Sie den Kontonamen des Benutzers ein, und klicken Sie anschließend auf OK.
  11. Wenn der Benutzer ausgewählt ist, aktivieren Sie für die folgenden Elemente die Kontrollkästchen Zulassen (Allow):
    • Lokaler Start
    • Remotestart
    • Lokale Aktivierung
    • Remoteaktivierung
  12. Klicken Sie zweimal auf OK.
  13. Beenden Sie den Registrierungseditor.

Dem Netzwerkdienstkonto die korrekten Berechtigungen erteilen

Gehen Sie wie folgt vor, um dem Netzwerkdienstkonto die korrekten Berechtigungen zu erteilen:
  1. Klicken Sie auf Start und dann auf Ausführen, geben Sie dcomcnfg in das Feld Öffnen ein, und klicken Sie anschließend auf OK.
  2. Doppelklicken Sie in den Komponentendiensten auf Komponentendienste, und doppelklicken Sie danach auf Computer.
  3. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie anschließend auf Eigenschaften.
  4. Klicken Sie auf die Registerkarte COM-Sicherheit.
  5. Klicken Sie im Bereich Start- und Aktivierungsberechtigungen auf Standard bearbeiten.
  6. Klicken Sie auf Hinzufügen, geben Sie Netzwerkdienst ein, und klicken Sie anschließend auf OK.
  7. Wenn der Netzwerkdienst ausgewählt ist, aktivieren Sie für die folgenden Elemente die Kontrollkästchen Zulassen:
    • Lokaler Start
    • Remotestart
    • Lokale Aktivierung
    • Remoteaktivierung
    Klicken Sie zweimal auf OK.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen über die x64-Versionen von Windows Server 2003 sowie über Windows XP Professional x64 Edition finden Sie im folgenden Artikel der Microsoft Knowledge Base:
888733 Beschreibung der x64-Versionen von Windows Server 2003 und Windows XP Professional x64 Edition
Hinweis Dies ist ein Artikel, der im Schnellverfahren direkt von der Microsoft-Supportorganisation erstellt wurde. Die hierin enthaltenen Informationen werden als Reaktion auf neue Probleme wie besehen bereitgestellt. Da dieser Artikel im Schnellverfahren erstellt wurde, kann er Tippfehler enthalten und zu einem späteren Zeitpunkt ohne vorherige Ankündigung überarbeitet werden. Weitere zu berücksichtigende Informationen finden Sie in den Nutzungsbedingungen.

Eigenschaften

Artikel-ID: 899965 - Geändert am: Freitag, 31. Januar 2014 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbtshoot KB899965
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