В системном журнале компьютера под управлением Windows XP Professional x64 Edition регистрируется событие 10016

Переводы статьи Переводы статьи
Код статьи: 899965 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

В системном журнале компьютера под управлением Microsoft Windows XP Professional x64 Edition регистрируется событие приблизительно следующего вида:

Тип события: Ошибка
Источник события: DCOM
Категория события: Отсутствует
Код события: 10016
Дата: дата
Время: время
Пользователь: NT AUTHORITY\LOCAL SERVICE

Описание: Параметры прав доступа приложения не включают разрешение на локальный запуск приложения COM Server с CLSID {AppGUID} для пользователя имя_пользователя код_безопасности код_безопасности_пользователя. Это разрешение можно изменить с помощью административного средства «Службы компонентов».

Тип события: Ошибка
Источник события: DCOM
Категория события: Отсутствует
Код события: 10016
Дата: Дата
Время: Время
Пользователь: Сетевые службы

Описание: Параметры прав доступа приложения не включают разрешение на локальный запуск приложения COM Server с CLSID {AppGUID} для пользователя имя_пользователя код_безопасности код_безопасности_пользователя. Это разрешение можно изменить с помощью административного средства «Службы компонентов».

Причина

Подобное поведение наблюдается в следующих случаях.
  • Программа с кодом класса (CLSID), отображаемым в сообщении, пытается запустить компонент COM с помощью инфраструктуры DCOM. При этом пользователь не имеет необходимых полномочий на запуск компонента COM.
  • Учетная запись сетевой службы не имеет соответствующих прав доступа.

Решение

Важно! В данный раздел, описание метода или задачи включены сведения об изменении параметров реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем, поэтому при выполнении этих действий строго соблюдайте инструкции. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. В этом случае при возникновении неполадок реестр можно будет восстановить. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
322756 Создание резервной копии и восстановление реестра Windows


Для решения этой проблемы воспользуйтесь одним из перечисленных ниже способов в зависимости от причины проблемы.

Предоставление пользователю разрешений на запуск компонента COM

Предоставьте пользователю разрешения на запуск компонента COM. Для этого выполните указанные ниже действия.
  1. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду regedit и нажмите кнопку ОК.
  2. Найдите и выделите следующий подраздел реестра:
    HKEY_CLASSES_ROOT\CLSID\CLSID value
    Примечание. В этом подразделе реестра вместо «CLSID value» используется код класса, отображаемый в сообщении.
  3. Дважды щелкните на правой панели AppID.

    Появится диалоговое окно «Изменение строкового параметра». Переходите к следующему действию, не закрывая это окно.
  4. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду dcomcnfg и нажмите кнопку ОК.

    В случае появления сообщения системы безопасности Windows с предложением сохранить блокировку программы консоли управления отмените блокировку.
  5. В окне служб компонентов дважды щелкните Службы компонентов, дважды щелкните Компьютеры, дважды щелкните Мой компьютер, а затем выберите Настройка DCOM.
  6. В области сведений найдите программу с помощью понятного имени.

    Если вместо понятного имени программы отображается код AppGUID, воспользуйтесь им.
  7. Щелкните программу правой кнопкой мыши и выберите команду Свойства.
  8. Перейдите на вкладку Безопасность.
  9. В разделе Разрешения на запуск и активацию выберите вариант Настроить и нажмите кнопку Изменить.
  10. Нажмите кнопку Добавить, введите имя учетной записи пользователя и нажмите кнопку ОК.
  11. Выберите пользователя и установите флажки Разрешить для следующих компонентов:
    • Локальный запуск
    • Удаленный запуск
    • Локальная активация
    • Удаленная активация
  12. Нажмите кнопку ОК два раза.
  13. Закройте редактор реестра.

Предоставление соответствующих прав доступа учетной записи сетевой службы

Чтобы предоставить соответствующие права доступа учетной записи сетевой службы, выполните следующие действия.
  1. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду dcomcnfg и нажмите кнопку ОК.
  2. В окне служб компонентов дважды щелкните Службы компонентов и Компьютеры.
  3. Щелкните правой кнопкой мыши значок Мой компьютер и выберите пункт Свойства.
  4. Перейдите на вкладку Безопасность COM.
  5. В разделе Разрешения на запуск и активацию нажмите Изменить значения по умолчанию.
  6. Нажмите кнопку Добавить, введите имя_сетевой_службы и нажмите кнопку OK.
  7. Выберите элемент Сетевая служба и установите флажки Разрешить для следующих компонентов:
    • Локальный запуск
    • Удаленный запуск
    • Локальная активация
    • Удаленная активация
    Нажмите кнопку ОК два раза.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Информация в данной статье применима к».

Дополнительная информация

Дополнительные сведения о 64-разрядных версиях Windows Server 2003 и Windows XP Professional x64 Edition смотрите в следующей статье базы знаний Майкрософт:
888733 Описание 64-разрядных версий Windows Server 2003 и Windows XP Professional
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 899965 - Последний отзыв: 31 января 2014 г. - Revision: 1.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional x64 Edition
Ключевые слова: 
kbtshoot KB899965

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com