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The body of an e-mail message is garbled when the header field and body field are set to different character sets in Exchange Server 2003

Article ID:900087
Last Review:October 25, 2007
Revision:3.3

Notice
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry
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SYMPTOMS

Consider the following scenario.
An e-mail message has the header field and the body field set to different character sets.
The two different character sets do not belong to the same language group.
When you try to view the message by using Microsoft Outlook, the body of the message is garbled.

For example, a message has UTF-8 specified in the From field or in the To field. Additionally, the body of the message is encoded as ISO-8859-1. When you try to view it by using Outlook, the body of the message contains garbled characters.

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CAUSE

This problem occurs because Microsoft Exchange Server 2003 sets the PR_INTERNET_CPID property to the UTF-8 character set. The PR_INTERNET_CPID property is a superset for any header field character set and body field character set. When a message uses two different language groups, Outlook tries to display the body of the message in UTF-8. Therefore, the body of the message is garbled.

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 (http://support.microsoft.com/kb/836993/) How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version       Size        File name
   ----------------------------------------------------------
   25-Aug-2005   01:55   6.5.7233.45   3,270,144   Mdbmsg.dll       
   04-Jun-2005   01:56                     3,304   Redir.asp
   25-Aug-2005   02:29   6.5.7233.45   5,177,856   Store.exe        

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
After you install this hotfix, you must create the following registry key. To do this, follow these steps:
1.Click Start, click Run, type Regedit, and then click OK.
2.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\MSExchangeIS\PARAMETERSSYSTEM\InternetContent
3.On the Edit menu, point to New, and then click DWORD Value.
4.In the details pane, input the new value PreserveISO-8859CPIDBody, and then press Enter.
5.Right-click PreserveISO-8859CPIDBody, and then click Modify.
6.Under Base in the Edit DWORD Value dialog box, click Decimal.
7.In the Value data box, type the value 1, and then click OK.
8.Close Registry Editor.
This problem occurs only in Microsoft Exchange Server 2003 and only when the header field and the body field are set to different character sets.

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APPLIES TO
Microsoft Exchange Server 2003 Standard Edition
Microsoft Exchange Server 2003 Enterprise Edition

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Keywords: 
kbautohotfix kbqfe kbhotfixserver kbexchstore kbfix kbbug kbpubtypekc KB900087

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