Artikel-ID: 900256 - Geändert am: Dienstag, 4. Dezember 2007 - Version: 3.8

Fehlermeldung, wenn ISA Server 2004-Webproxy-Clientbenutzer versuchen auf eine externe FTP-Site mithilfe von passiven FTP-Funktionalität: "Fehler Code: 502 Proxy Error"

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wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Sollten Sie die Registrierung sichern, bevor Sie Sie ändern. Stellen Sie sicher, dass Sie die Registrierung wiederherstellen kennen, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Beschreibung der Microsoft Windows-Registrierung

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Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Sie konfigurieren Microsoft Internet Security and Acceleration (ISA) Server 2004, um ausgehende passiven FTP-Datenverkehr zu aktivieren.
  • Sie konfigurieren mehrere interne Clientcomputer als ISA Server 2004-Webproxy-Clients.
In diesem Szenario können die internen Webproxyclients am ersten Zugriff externe FTP-Sites und externen Websites. Sie erhalten jedoch nach mehrere Tage oder mehr Benutzer die folgenden Fehlermeldung, wenn Sie als Webproxyclient, verwenden um eine externe FTP-Site oder eine externe Website zuzugreifen:
Fehlercode: 502 Proxy Error. Kein Pufferraum wird unterstützt.
Die WinSock-Implementierung konnte zusätzlichen Arbeitsspeicher für die Funktionsanforderung zuweisen. (10055)
Hinweis: Dieses Problem kann auftreten, nur, wenn die Werte für den Registrierungsunterschlüssel
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W3Proxy/Parameters
wie folgt auf dem Computer festgelegt sind, auf dem ISA Server 2004 ausgeführt wird:
Wertname: NonPassiveFTPTransfer
Wert: 0 x 0

Ursache

Wenn ISA Server 2004 auf die Art und Weise konfiguriert ist, das im Abschnitt "Problembeschreibung" beschrieben wird, verliert ISA Server 2004 Sockethandles Endpunkt. Insbesondere Speicherverluste ISA Server 2004 einen Handle immer eine Datei von einem externen FTP-Server gedownloadet wird.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Internet Security and Acceleration Server 2004, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
891024  (http://support.microsoft.com/kb/891024/ ) Wie Sie das neueste ISA Server 2004 Servicepack erhalten

Hotfix-Informationen

ISA Server 2004 Standard Edition

Informationen zu Service Packs

Um dieses Problem zu beheben, besorgen Sie ISA Server 2004 Standard Edition Service Pack 2 (SP2). Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
891024  (http://support.microsoft.com/kb/891024/ ) Wie Sie das neueste ISA Server 2004 Servicepack erhalten

ISA Server 2004 Enterprise Edition

Informationen zu Service Packs

Um dieses Problem zu beheben, besorgen Sie ISA Server 2004 Enterprise Edition Service Pack 2 (SP2). Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
891024  (http://support.microsoft.com/kb/891024/ ) Wie Sie das neueste ISA Server 2004 Servicepack erhalten

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Sie müssen ISA Server 2004 Enterprise Edition, um diesen Hotfix installieren ausführen. Sie können nicht diesen Hotfix auf einem Computer installieren, auf dem ISA Server 2004 Standard Edition ausgeführt wird.
Neustartanforderung
Sie müssen Ihren Computer nicht neu starten, nachdem Sie diesen Hotfix installiert haben. ISA Server 2004-bezogenen Dienste werden jedoch automatisch beendet und neu gestartet, wenn Sie diesen Hotfix anwenden.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
W3pinet.dll4.0.3440.27525,36803-Aug 200521: 36X 86

Abhilfe

Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine Ihr Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.Um dieses Problem zu umgehen, deaktivieren Sie passiven FTP-Funktionalität in ISA Server 2004. Legen Sie hierzu die folgenden Werte auf den Unterschlüssel
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W3Proxy/Parameters
:
Wertname: NonPassiveFTPTransfer
Werttyp: REG_DWORD
Wert: 0 x 1
Hinweis: Nachdem Sie diesen Registrierungseintrag konfiguriert haben, müssen Sie den ISA Server 2004-Firewalldienst damit diese Änderung wirksam neu starten.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals im ISA Server 2004 Service Pack 2. Dieses Problem wurde erstmals in Internet Security and Acceleration Server 2004 Service Pack 2 behoben.

Weitere Informationen

Weitere Informationen zum Installieren von ISA Server 2004-Hotfixes und Updates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
885957  (http://support.microsoft.com/kb/885957/ ) Zum Installieren von ISA Server-Hotfixes und updates
Weitere Informationen zu den Bedingungen, die in diesem Artikel verwendet werden, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Security and Acceleration Server 2004 Enterprise Edition
  • Microsoft Internet Security and Acceleration Server 2004 Standard Edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 900256  (http://support.microsoft.com/kb/900256/en-us/ )
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