Article ID: 900613 - Last Review: October 9, 2011 - Revision: 3.0

Event ID: 1517 occurs when users who use roaming profiles encrypt files on a Windows Server 2003-based file server

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SYMPTOMS

Consider the following scenario. A user uses a roaming profile to log on to a domain. Then, the user accesses shared folders on a Microsoft Windows Server 2003-based file server. When this user encrypts a file on the file server, a miniprofile is created for the user on the file server. However, this miniprofile is not deleted as expected. And, the following event is logged in the Application log on the file server:

Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1517
Date: Date
Time: Time
User: NT AUTHORITY\SYSTEM
Computer: Computer name
Description: Windows saved user domain_name\user registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. This is often caused by services running as a user account, try configuring the services to run in the local system account.

This behavior occurs if the following conditions are true:
  • The Delete cached copies of roaming profiles Group Policy setting is enabled on the file server.
  • The roaming profile for the user does not have an Encrypting File System (EFS) key. A roaming profile may not have an EFS key if the user has never encrypted a file.

CAUSE

This problem occurs because EFS does not release the certificate chain cache. Therefore, the roaming profile cannot be unloaded.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Eventlog.dll5.2.3790.21264,00018-Oct-200414:12x86NoneRTMQFE
Lsasrv.dll5.2.3790.478753,15204-Feb-200603:19x86NoneRTMQFE
Lsasrv.dll5.2.3790.2633822,27204-Feb-200604:01x86SP1SP1QFE

Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Eventlog.dll5.2.3790.212167,93603-Feb-200612:48IA-64NoneRTMQFE
Lsasrv.dll5.2.3790.4782,038,78403-Feb-200612:48IA-64NoneRTMQFE
Lsasrv.dll5.2.3790.26332,165,76003-Feb-200612:55IA-64SP1SP1QFE

Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.26331,565,69603-Feb-200612:55x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

The miniprofile that is described in the "Symptoms" section is used to store EFS keys on the file server. This miniprofile is located in the following path:
%Systemdrive%\Documents and Settings\username\Application Data\Microsoft\Crypto\RSA
You expect this miniprofile to be deleted after the EFS key is created and used. If the miniprofile is not deleted, an event ID 1517 message will be logged frequently on the file server. If lots of users encrypt files on the file server, the miniprofiles that are not deleted will use disk space.

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbwinserv2003presp2fix kbexpertiseinter kbbug kbfix kbqfe KB900613