Article ID: 900630 - Last Review: October 9, 2011 - Revision: 2.0

The SMS 2003 Operating System Deployment Feature Pack may take longer than you expect to install an operating system image in SMS 2003 with SP1

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

The Microsoft Systems Management Server (SMS) 2003 Operating System Deployment Feature Pack may take longer than you expect to install or to upgrade an operating system image.

When this problem occurs, the OSDSWDProgramExec.log file contains entries that are similar to the following:
Connecting to \\SERVER1\SMSPACKAGES\PACKAGE1
Failed to connect to \\SERVER1\SMSPACKAGES\PACKAGE1 (1219). Retry in 10 seconds.
Connecting to \\SERVER1\SMSPACKAGES\PACKAGE1
Failed to connect to \\SERVER1\SMSPACKAGES\PACKAGE1 (1219). Retry in 20 seconds.
Connecting to \\SERVER1\SMSPACKAGES\PACKAGE1
Failed to connect to \\SERVER1\SMSPACKAGES\PACKAGE1 (1219). Retry in 30 seconds.
Connecting to \\SERVER1\SMSPACKAGES\PACKAGE1
Failed to connect to \\SERVER1\SMSPACKAGES\PACKAGE1 (1219). Retry in 40 seconds.
Connecting to \\SERVER1\SMSPACKAGES\PACKAGE1
Connection to \\SERVER1\SMSPACKAGES\PACKAGE1 failed with credential conflict. Using existing connection.

CAUSE

This problem occurs because the OSDSWDExec.exe process prematurely disconnects the network connection to the SMS distribution point where the image package is stored.

This problem may occur when the State Restore phase of the installation includes an action of the Run Software Distribution Program type.

RESOLUTION

Apply this hotfix on any primary site server that is intended to provide operating system deployment functionality. Or, apply this hotfix on any Administrator console computer that is used to view and configure operating system deployment packages.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Systems Management Server 2003 Service Pack 1 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name
   -----------------------------------------------------------
   09-Aug-2005  17:49  2.50.3658.1104  209,408  Osdlaunch.exe
   17-Aug-2005  20:49  2.50.3658.1107  175,616  Osdswdexec.exe

WORKAROUND

To work around this problem, use one of the following methods.

Method 1

Make sure that the packages that are used by the Run Software Distribution Program action in the State Restore phase are on a different distribution point than the distribution point where the image package is located.

Method 2

If you can only use only one distribution point, configure the package properties to use a common SMS package share for the image package and for the packages that are used in the State Restore phase. To do this, follow these steps:
  1. Right-click the package, and then select Properties.
  2. On the Data Access tab, select Access distribution folder through common SMS package share.
  3. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003 Service Pack 1
Keywords: 
kbautohotfix kbqfe kbHotfixServer kbfix kbbug KB900630