ACC: Mensaje de error "No se pudo encontrar ISAM instalable"

Seleccione idioma Seleccione idioma
Id. de artículo: 90111 - Ver los productos a los que se aplica este artículo
Moderada: Requiere macro básico, codificación y las capacidades de interoperabilidad.
Expandir todo | Contraer todo

En esta página

Síntomas

Si intenta importar, exportar o vincular (asociar) un archivo utilizando un controlador de acceso secuencial indizado (ISAM) método, puede recibir un mensaje de error si Microsoft Access no encuentra el controlador ISAM.

Causa

Microsoft Access utilizan controladores ISAM para actualizar los formatos de archivo distinto de su propio.

En Microsoft Access 2.0, si la ruta de acceso al controlador ISAM en el archivo Msacc20.ini no es válida, o si el controlador ISAM no existe, puede recibir el siguiente mensaje de error:
No se pudo encontrar ISAM instalable.

Microsoft Access 7.0 y 97 no tiene un archivo. ini. Ahora se almacena la información anteriormente almacenada en los archivos .ini en el registro de Microsoft Windows. En Microsoft Access 7.0 y 97, si la ruta de acceso al controlador ISAM en el registro de Windows no es válida, o si el controlador ISAM no existe, puede recibir el siguiente mensaje de error:
No se pudo encontrar ISAM instalable.

Este error también puede producirse si escribe un nombre de base de datos no válido para una base de datos SQL cuando se utiliza la acción TransferirBaseDatos en una macro. Cuando se utiliza una cadena de conexión no válido, Microsoft Access busca un ISAM instalable para la base de datos SQL. Si no se encuentra un ISAM instalable, se produce un error.

Solución

En Microsoft Access 2.0, edite el archivo .ini para especificar la ruta correcta en la sección [ISAM instalables] o volver a instalar Microsoft Access mediante la opción personalizada. Para solucionar problemas relacionados con este mensaje de error en Microsoft Access 2.0 de sugerencias, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:

150494ACC2: Solución de problemas recibe el error "No se encuentra el ISAM instalable"

En Microsoft Access 7.0 o 97, puede editar el registro de Windows. Para obtener más información sobre los cambios del registro, busque "Del registro", y "Configuración de registro de personalizar Windows utilizada por Microsoft Access" utilizando el índice de Ayuda de Microsoft Access 97. Para solucionar problemas relacionados con este mensaje de error en Microsoft Access 7.0 de sugerencias, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:

155666ACC95: Solucionar error "No se pudo encontrar ISAM instalable"

Para obtener información sobre los controladores ISAM en Microsoft Access 97, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:

159322ACC97: Paradox, Lotus & ISAM de Microsoft Exchange u Outlook en ValuPack

Estado

Este comportamiento es por diseño.

Más información

Pasos para reproducir este comportamiento


  1. Inicie Microsoft Access y abra cualquier base de datos.
  2. Cree una nueva macro llamada TestError:
          Macro Name Condition  Action
          --------------------------------------
          TestError             TransferDatabase
    
          TestError Actions
          ----------------------------------------------------------------
          TransferDatabase
             Transfer Type: Link (or Attach in version 2.0)
             Database Type: ODBC Database (or SQL Database in version 2.0)
             Database Name: pubs
             Object Type: Table
             Source: dbo.authors
             Destination: Test
             Structure Only: No
    						
  3. Guarde y ejecute la macro. Tenga en cuenta que recibirá la mensaje de error. En este ejemplo, el argumento de nombre de base de datos no válido para una base de datos SQL produce el error. Para que el nombre de base de datos sea válido, debe incluir la cadena de conexión de ODBC completa de la tabla SQL asociada.

Referencias

Para obtener más información acerca de la acción TransferirBaseDatos, escriba TransferirBaseDatos en el Ayudante de Office, haga clic en Buscar y, a continuación, haga clic para ver "Acción TransferirBaseDatos."

Propiedades

Id. de artículo: 90111 - Última revisión: jueves, 18 de enero de 2007 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Palabras clave: 
kbmt kberrmsg kbprb kbusage KB90111 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 90111
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com