Niektóre produkty firmy Internet Security Systems nie działają na komputerze z systemem Windows 2000 po zainstalowaniu poprawionej wersji aktualizacji zabezpieczeń MS05-019 lub pakietu zbiorczego aktualizacji 1 dla systemu Windows 2000 z dodatkiem SP4

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 901159 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Po zainstalowaniu na komputerze z systemem Windows 2000 poprawionej wersji aktualizacji zabezpieczeń MS05-019 wydanej 14 czerwca 2005 lub pakietu zbiorczego aktualizacji 1 dla systemu Windows 2000 z dodatkiem Service Pack 4 (SP4), który został wydany 28 czerwca 2005, przestają działać następujące produkty firmy Internet Security Systems (ISS), co pozbawia komputer dodatkowej ochrony zapewnianej przez te produkty:
  • RealSecure Desktop 3,6 z aktualizacją XPU w wersji ENO, ENP i ENQ
  • RealSecure Desktop 7.0 z aktualizacją XPU w wersji ENO, ENP i ENQ
  • BlackICE Agent for Server 3.6 z aktualizacją XPU w wersji ENO, ENP i ENQ
  • BlackICE PC Protection 3.6 z aktualizacją XPU w wersji CNO, CNP i CNQ
  • BlackICE Server Protection 3.6 z aktualizacją XPU w wersji CNO, CNP i CNQ
Zagrożone produkty ISS zazwyczaj przestają działać po upływie jednej lub dwóch minut po uruchomieniu komputera.

Uwaga Aktualizacje X-Press Updates (XPU) produktów ISS zapewniają dostępność aktualnych sygnatur i sterowników gwarantujących prawidłowe funkcjonowanie zabezpieczeń. Wersje XPU podane w tym artykule są znacznie starsze niż aktualne wersje XPU. Aby zapobiec występowaniu problemów, witryna Windows Update nie oferuje poprawionej aktualizacji zabezpieczeń MS05-019 dla komputerów, na których są uruchomione te programy, aż do chwili, kiedy zostanie zainstalowana nowsza aktualizacja XPU. Ponadto, jeśli są zainstalowane następujące programy firmy ISS, użytkownicy komputera, na którym występuje ten problem, mogą nie otrzymać powiadomienia o konieczności zainstalowania poprawionej wersji aktualizacji zabezpieczeń MS05-019. Zachowanie to jest spowodowane tym, że następujące programy również mogą zawierać nieprawidłowo działającą wersję pliku. Poza tym jednak programy te działają poprawnie. W związku z tym można ręcznie zainstalować poprawioną wersję aktualizacji zabezpieczeń MS05-019 lub pakiet zbiorczy 1 aktualizacji dla systemu Windows 2000 z dodatkiem SP4.
  • Server Sensor 7.0
  • Server Sensor 7.0 SR 4.1
  • Server Sensor 7.0 z aktualizacją XPU w wersji 20.18 - 20.19, 21.1, 21.3, 22.3 - 22.4, 22.5 - 22.19, 22.20 - 22.37
  • RealSecure Guard 3.6
  • Internet Scanner 7.0
  • Internet Scanner 7.0 z dodatkiem SP1
Uwaga Ten problem nie dotyczy produktów BlackICE Defender, BlackICE Defender for Server lub Proventia Desktop.

Przyczyna

Problem ten występuje dlatego, że produkty firmy ISS, których on dotyczy, nie wykrywają poprawnie zmian wprowadzonych w protokole TCP/IP przez poprawioną wersję aktualizacji zabezpieczeń MS05-019 lub pakiet zbiorczy aktualizacji 1 dla systemu Windows 2000 z dodatkiem SP4. Zagrożone produkty ISS zawierają jedną z następujących wersji pliku Blackdrv.sys:
  • Wersje nowsze niż 3.6.0.0 i starsze niż 3.6.319.0
  • Wersje nowsze niż 7.0.0.0 i starsze niż 7.0.319.0

Rozwiązanie

Aby rozwiązać ten problem, należy uaktualnić zagrożone produkty ISS przy użyciu bieżących wersji aktualizacji XPU. W przypadku aktualizacji XPU w wersjach ENR lub nowszych problem ten nie występuje. Aby uzyskać więcej informacji, odwiedź następujące witryny ISS w sieci Web:Informacje i rozwiązania zamieszczone w tym dokumencie odzwierciedlają aktualne stanowisko firmy Microsoft Corporation dotyczące tych zagadnień, obowiązujące w dniu publikacji. To rozwiązanie jest udostępniane za pośrednictwem firmy Microsoft lub innego dostawcy. Firma Microsoft nie poleca żadnego dostawcy lub rozwiązania opracowanego przez inną firmę, opisanego w tym artykule. Dostępni mogą być również inni dostawcy lub rozwiązania innych firm, które nie zostały opisane w tym artykule. Firma Microsoft musi reagować na zmiany warunków rynkowych, dlatego te informacje powinny być interpretowane jako potwierdzenie zaangażowania firmy Microsoft. Firma Microsoft nie może zagwarantować lub potwierdzić precyzji informacji lub rozwiązań przedstawionych przez firmę Microsoft lub przez innego wspomnianego dostawcę.

Firma Microsoft nie udziela żadnych gwarancji i nie formułuje żadnych oświadczeń, zapewnień i zastrzeżeń oficjalnych, domniemanych lub ustawowych. Przykładem mogą być oświadczenia, zapewnienia lub zastrzeżenia dotyczące prawa własności, ochrony praw stron trzecich, wymaganego stanu, przydatności handlowej i przydatności do określonego celu, formułowane w odniesieniu do jakiejkolwiek usługi, rozwiązania, produktu albo innych materiałów lub informacji. W żadnych okolicznościach firma Microsoft nie ponosi odpowiedzialności za rozwiązania opracowane przez inne firmy, wspomniane w tym artykule.

Więcej informacji

Aby uzyskać więcej informacji, kliknij numery artykułów poniżej w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
900345 Fixes that are included in Update Rollup 1 for Microsoft Windows 2000 Service Pack 4 that is dated June 28, 2005
891861 Pakiet zbiorczy aktualizacji 1 dla systemu Windows 2000 z dodatkiem SP4 i opis znanych problemów

Właściwości

Numer ID artykułu: 901159 - Ostatnia weryfikacja: 10 października 2005 - Weryfikacja: 8.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows 2000 Service Pack 3
Słowa kluczowe: 
kbtshoot kbsecurity kb3rdparty KB901159

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com