После установки исправленной версии обновления безопасности MS05-019 на компьютерах под управлением Windows 2000 перестают работать некоторые продукты компании Internet Security Systems

Переводы статьи Переводы статьи
Код статьи: 901159 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

На компьютерах под управлением Microsoft Windows 2000 после установки исправленной версии обновления безопасности MS05-019, выпущенной 14 июня 2005 г., или после установки набора обновлений 1 для пакета обновления 4 (SP4) для операционной системы Windows 2000, выпущенного 28 июня 2005 г., перестают работать перечисленные ниже программы компании Internet Security Systems (ISS), и отключается дополнительная защита, которая обеспечивается этими программами.
  • RealSecure Desktop 3.6 с XPU версий ENO, ENP и ENQ.
  • RealSecure Desktop 7.0 с XPU версий ENO, ENP и ENQ.
  • BlackICE Agent для Server 3.6 с XPU версий ENO, ENP и ENQ.
  • BlackICE PC Protection 3.6 с XPU версий CNO, CNP и CNQ.
  • BlackICE Server Protection 3.6 XPU версий CNO, CNP и CNQ.
Как правило, продукты компании ISS, подверженные указанной проблеме, прекращают работу через одну-две минуты после загрузки компьютера.

Примечание. Обновления ISS X-Press Updates (XPU) — это наборы данных и обновления драйверов, необходимые для обеспечения должного уровня защиты. Версии обновлений XPU, перечисленные в данной статье, являются устаревшими (по сравнению с текущими версиями XPU). Чтобы предотвратить рассматриваемую проблему, служба Windows Update не предлагает устанавливать исправленную версию обновления безопасности MS05-019, если на компьютере установлены устаревшие версии обновлений XPU. Если установлены следующие программы ISS, пользователи компьютеров, подверженных проблеме, могут не получить уведомление о необходимости установки исправленной версии обновления безопасности MS05-019. Это происходит, потому что эти программы также могут содержать версию файла, подверженную этой проблеме. Тем не менее, эта проблема не проявляется в следующих программах. Поэтому можно вручную установить исправленную версию обновления безопасности MS05-019 или набор обновлений 1 для пакета обновления 4 (SP4) для Windows 2000.
  • Server Sensor 7.0
  • Server Sensor 7.0 SR 4.1
  • Server Sensor 7.0 XPU версий 20.18 - 20.19, 21.1, 21.3, 22.3 - 22.4, 22.5 - 22.19, 22.20 - 22.37
  • RealSecure Guard 3.6
  • Internet Scanner 7.0
  • Internet Scanner 7.0 с пакетом обновления 1 (SP1)
Примечание. Продукты BlackICE Defender, BlackICE Defender for Server и Proventia Desktop не подвержены данной проблеме.

Причина

Данная проблема возникает из-за того, что перечисленные выше продукты не могут распознать изменения, вносимые в протокол TCP/IP исправленной версией обновления безопасности MS05-019. Продукты ISS, подверженные данной проблеме, содержат одну из следующих версий файла Blackdrv.sys:
  • версии более поздние, чем 3.6.0.0, но более ранние, чем 3.6.319.0;
  • версии более поздние, чем 7.0.0.0, но более ранние, чем 7.0.319.0.

Решение

Чтобы устранить данную проблему, установите для подверженных проблеме продуктов ISS последние версии обновлений XPU. Обновления XPU версии ENR и более поздней версии не подвержены рассматриваемой проблеме. Дополнительные сведения см. на веб-узле ISS по следующим адресам:Содержащиеся в документе сведения и рассмотренные решения отражают позицию корпорации Майкрософт в отношении обсуждаемых вопросов на момент публикации. Для получения данного решения необходимо обратиться в корпорацию Майкрософт или к сторонним поставщикам. Ни один из независимых поставщиков и ни одно из решений сторонних разработчиков, описываемых в данной статье, не являются предпочтительными с точки зрения корпорации Майкрософт. Кроме независимых поставщиков и решений сторонних разработчиков, упомянутых в данной статье, могут существовать и другие поставщики и решения. В условиях меняющейся рыночной конъюнктуры эту информацию не следует рассматривать в качестве какого бы то ни было обязательства со стороны корпорации Майкрософт. Корпорация Майкрософт не подтверждает и не гарантирует точность сведений и решений, предоставленных корпорацией Майкрософт или упомянутыми сторонними разработчиками.

Корпорация Майкрософт не предоставляет никаких гарантий и отказывается от явных, подразумеваемых или предусмотренных законодательством гарантий, заверений и условий, включая (но не ограничиваясь только ими) отказ от обязательств, условий или гарантий прав собственности, ненарушения прав интеллектуальной собственности, пригодности для продажи и применимости для определенной цели, гарантии качества в связи с использованием продукта, решения, услуг или других материалов или данных. Корпорация Майкрософт не несет ответственности за решения сторонних разработчиков, упомянутые в данной статье.

Дополнительная информация

Дополнительные сведения см. в следующих статьях базы знаний Майкрософт.
900345 Исправления, включенные в набор обновлений 1 для Microsoft Windows 2000 с пакетом обновления 4 (SP4), от 28 июня 2005 г. (эта ссылка может указывать на содержимое полностью или частично на английском языке)
891861 Набор обновлений 1 для Windows 2000 с пакетом обновления 4 (SP4) и известные проблемы

Свойства

Код статьи: 901159 - Последний отзыв: 10 октября 2005 г. - Revision: 8.0
Информация в данной статье применима к:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Service Pack 3
  • Операционная система Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows 2000 Service Pack 3
Ключевые слова: 
kbtshoot kbsecurity kb3rdparty KB901159

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com