U kunt geen HTML Help-bestanden openen vanuit Internet Explorer nadat u beveiligingsupdate 896358 of Windows Server 2003 Service Pack 1 hebt geïnstalleerd

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 902225 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Nadat u beveiligingsupdate 896358 of Microsoft Windows Server 2003 Service Pack 1 (SP1) hebt geïnstalleerd, treden de beide volgende problemen op (of een van beide) nadat u op een koppeling naar een HTML Help CHM-bestand in Internet Explorer hebt geklikt:
  • U kunt onderwerpen in het CHM-bestand niet weergeven wanneer u klikt op Openen in plaats van Opslaan in het dialoogvenster Bestand downloaden.
  • U kunt onderwerpen in het CHM-bestand niet weergeven wanneer u klikt op Opslaan in het dialoogvenster Bestand downloaden en vervolgens het bestand probeert te openen.
Opmerking Dit artikel bevat informatie die een aanvulling vormt op de volgende artikelen in de Microsoft Knowledge Base:
232077 Bestanden uitvoeren via een hyperlink en het dialoogvenster Bestand downloaden
896054 U kunt externe inhoud niet openen met het InfoTech-protocol na installatie van beveiligingsupdate 896358, beveiligingsupdate 840315 of Windows Server 2003 Service Pack 1
896358 MS05-026: Beveiligingsprobleem in HTML Help kan leiden tot uitvoering van externe code

Oorzaak

Beveiligingsupdate 896358 en Windows Server 2003 SP1 bevatten wijzigingen in het InfoTech-protocol waardoor de externe inhoud niet meer kan worden weergegeven. Deze wijzigingen zijn aangebracht om beveiligingsproblemen in HTML Help op te lossen. Nadat u 896358 of Windows Server 2003 SP1 hebt geïnstalleerd, worden bestanden in de map Tijdelijke Internet-bestanden beschouwd als inhoud van de zone Internet. Daardoor kunnen bestanden geblokkeerd zijn als u klikt op Openen in het dialoogvenster Bestand downloaden. Het is ook mogelijk dat na installatie van 896358 of Windows Server 2003 SP1 een gedownload CHM-bestand als onbetrouwbaar wordt beschouwd. Het is mogelijk dat dit bestand dan niet kan worden geopend. Dit zijn normale en bedoelde effecten na installatie van de beveiligingsupdate en na installatie van Windows Server 2003 SP1.

Oplossing

Oplossing voor eindgebruikers

Waarschuwing Als u wordt gevraagd een CHM-bestand van een website te openen of op te slaan, moet u dit alleen doen als u het bestand nodig hebt en als u de website vertrouwt waarop het bestand wordt aangeboden.

Klik in het dialoogvenster Bestand downloaden op Opslaan en geef op waar u het CHM-bestand wilt opslaan. U kunt vervolgens een van de volgende methoden gebruiken:

Methode 1

  1. Dubbelklik op het CHM-bestand.
  2. Schakel in het dialoogvenster Bestand openen-Beveiligingswaarschuwing het selectievakje Altijd waarschuwen alvorens bestanden van dit type te openen uit.
  3. Klik op Openen.

Methode 2

  1. Klik met de rechtermuisknop op het CHM-bestand en klik op Eigenschappen.
  2. Klik op Blokkering opheffen.
  3. Dubbelklik op het CHM-bestand om het te openen.

Oplossing voor systeembeheerders

U kunt dit probleem op een van de volgende manieren oplossen.

UNC-bestandspaden en bestandsshares gebruiken om een koppeling te maken naar CHM-bestanden

Als de webpagina op uw intranet het HTTP URL-schema gebruikt om een koppeling te maken naar CHM-bestanden, kunnen gebruikers als gevolg van beveiligingsupdate 896358 geen onderwerpen meer zien in het CHM-bestand. Als u een HTTP-pad vervangt door een UNC-pad, kunnen de CHM-bestanden op de webpagina weer worden geopend.

Ga als volgt te werk om een UNC-pad te gebruiken in plaats van een HTTP URL:
  1. Zet de CHM-bestanden op een bestandsshareserver die via een UNC-pad kan worden benaderd.

    Een UNC-pad ziet er ongeveer zo uit:
    \\productmanuals\helpfiles
  2. Gebruik de waarde ItssRestrictions\UrlAllowList om de systemen in het intranet in staat te stellen de CHM-bestanden vanaf die bestandsshare te openen.

    Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
    896054 U kunt externe inhoud niet openen met het InfoTech-protocol na installatie van beveiligingsupdate 896358, beveiligingsupdate 840315 of Windows Server 2003 Service Pack 1
  3. Werk de koppelingen op de webpagina op uw intranet bij zodat UNC-paden worden gebruikt in de URL's die een koppeling vormen naar de CHM-bestanden.
Opmerking Deze methode werkt alleen voor pagina's die vanaf de zone Intranet bereikbaar zijn. Deze methode werkt niet voor pagina's die vanaf de zone Internet bereikbaar zijn.

Webtoepassingen instellen voor het downloaden van CHM-bestanden

Voeg op de webpagina met de koppeling naar CHM-bestanden instructies toe om de gebruiker het bestand te laten opslaan in plaats van het rechtstreeks te openen. Zie de sectie 'Oplossing voor eindgebruikers' voor meer informatie.

U kunt ook de DownloadOptions-code <META> gebruiken om de knop Openen te verwijderen uit het dialoogvenster Bestand downloaden dat wordt weergegeven nadat een gebruiker op een koppeling naar het CHM-bestand heeft geklikt. Zet deze code binnen de code <head> van de HTML-pagina. Dit wordt geïllustreerd in het volgende voorbeeld.
<head>
<META name="DownloadOptions" content="noopen">
</head>
Ga naar de volgende Microsoft-website voor meer informatie:
http://msdn.microsoft.com/nl-nl/library/ms534184.aspx
Opmerking Gebruik van het <META>-label DownloadOptions wordt alleen ondersteund in Microsoft Windows XP met Service Pack 2 en in Windows Server 2003 met Service Pack 1.

Meer informatie

Overzicht en voorbeelden voor systeembeheerders

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over beveiligingsupdate 896358 en voor informatie over het opnieuw inschakelen van webtoepassingen waarop deze update van toepassing is:
896358 MS05-026: Een beveiligingsprobleem in 'HTML Help' kan leiden tot uitvoering van externe code

Internet Explorer

Voor meer informatie over het openen van bestanden via hyperlinks in Internet Explorer klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
232077 Bestanden uitvoeren via een hyperlink en het dialoogvenster Bestand downloaden
Voor meer informatie over het gebruiken van beveiligingszones in Internet Explorer klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
174360 Beveiligingszones gebruiken in Internet Explorer

Technische ondersteuning voor x64-versies van Microsoft Windows

Op computers met een x64-versie van Microsoft Windows moet u de instructies voor het wijzigen van het register in de sectie 'Oplossing' wellicht aanpassen. Misschien moet u een ander deel van het register wijzigen, afhankelijk van de vraag of u de 32-bits of de 64-bits functionaliteit wilt aanpassen. Klik voor meer informatie op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:
896459 Registerwijzigingen bij systemen met het besturingssysteem Windows x64 Edition
De fabrikant van uw hardware biedt technische ondersteuning en assistentie voor x64-versies van Microsoft Windows. De fabrikant is hier verantwoordelijk voor omdat een x64-versie van Windows bij de hardware is meegeleverd. Mogelijk heeft de fabrikant de geïnstalleerde Windows-editie met unieke onderdelen aangepast. Unieke onderdelen zijn bijvoorbeeld specifieke apparaatstuurprogramma's of optionele instellingen om de prestaties van de hardware op te voeren. Microsoft biedt assistentie in alle redelijkheid als u technische hulp nodig hebt bij uw x64-versie van Windows. Wellicht moet u de fabrikant echter rechtstreeks benaderen. De fabrikant kan de beste ondersteuning bieden voor de software die vooraf op de hardware is geïnstalleerd.

Voor productinformatie over de x64-editie van Microsoft Windows XP Professional gaat u naar de volgende Microsoft-website:
http://windows.microsoft.com/nl-nl/windows/help/windows-xp
Voor productinformatie over x64-versies van Microsoft Windows Server 2003 gaat u naar de volgende Microsoft-website:
http://technet.microsoft.com/nl-nl/windowsserver/bb430829.aspx

Eigenschappen

Artikel ID: 902225 - Laatste beoordeling: donderdag 7 november 2013 - Wijziging: 5.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows Server 2003 Service Pack 1 op de volgende platformen
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
Trefwoorden: 
kbsecurity kbexpertiseinter kbexpertiseadvanced kbtshoot kbprb KB902225

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com