คุณไม่สามารถเปิดแฟ้มวิธีใช้ HTML จาก Internet Explorer หลังจากที่คุณติดตั้งการปรับปรุงการรักษาความปลอดภัย 896358 หรือ Windows Server 2003 Service Pack 1

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 902225 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

หลังจากที่คุณติดตั้งการปรับปรุงการรักษาความปลอดภัย 896358 หรือ Microsoft Windows Server 2003 Service Pack 1 (SP1), คุณอาจพบหนึ่งหรือทั้งสองอาการต่อไปนี้หลังจากที่คุณคลิกการเชื่อมโยงไปยังแฟ้มวิธีใช้ HTML .chm ใน Internet Explorer:
  • ไม่สามารถดูหัวข้อในแฟ้ม.chm เมื่อคุณคลิกOPENแทนบันทึกในการดาวน์โหลดแฟ้มกล่องโต้ตอบ
  • ไม่สามารถดูหัวข้อในแฟ้ม.chm เมื่อคุณคลิกบันทึกในการดาวน์โหลดแฟ้มกล่องโต้ตอบ และคุณลองเปิดแฟ้ม
หมายเหตุ:บทความนี้ประกอบด้วยข้อมูลที่อยู่เพิ่มเติมไปยังบทความฐานความรู้ของ Microsoft:
232077การดำเนินการแฟ้ม ด้วยการเชื่อมโยงหลายมิติและกล่องโต้ตอบการดาวน์โหลดแฟ้ม
896054คุณไม่สามารถเปิดเนื้อหาระยะไกล โดยใช้โพรโทคอล InfoTech หลังจากที่คุณติดตั้งการปรับปรุงการรักษาความปลอดภัย 896358 การปรับปรุงการรักษาความปลอดภัย 840315 หรือ Windows Server 2003 Service Pack 1
896358ms05-026: มีช่องโหว่ในวิธีใช้ HTML อาจทำให้โค้ดจากระยะไกล

สาเหตุ

การปรับปรุงการรักษาความปลอดภัย 896358 และ Windows Server 2003 SP1 รวมการเปลี่ยนแปลงกับโพรโทคอล InfoTech ที่บล็อกความสามารถในการดูเนื้อหาที่ระยะไกล การเปลี่ยนแปลงเหล่านี้ได้ถูกนำมาใช้เพื่อลดความปลอดภัยช่องโหว่ในวิธีใช้ HTML หลังจากที่คุณติดตั้ง 896358 หรือ Windows Server 2003 SP1 แฟ้มในโฟลเดอร์แฟ้มอินเทอร์เน็ตชั่วคราวจะถูกจัดการเหมือนเป็นเนื้อหาจากโซนอินเทอร์เน็ต ดังนั้น แฟ้มอาจจะถูกบล็อกเมื่อคุณคลิกOPENในการดาวน์โหลดแฟ้มกล่องโต้ตอบ นอกจากนี้ หลังจากที่คุณติดตั้ง 896358 หรือ Windows Server 2003 SP1 ตัวจัดการสิ่งที่แนบมาอาจถือ.chm ดาวน์โหลดแฟ้มเป็นแฟ้มไม่น่าเชื่อถือ ดังนั้น คุณอาจไม่สามารถเปิดแฟ้ม ลักษณะพิเศษเหล่านี้ได้ที่คาดไว้ และวัตถุประสงค์ลักษณะพิเศษ ของการติดตั้งการปรับปรุงการรักษาความปลอดภัย และ การติดตั้ง Windows Server 2003 SP1

การแก้ไข

ความละเอียดของผู้ใช้ปลายทาง

คำเตือนถ้าคุณได้รับพร้อมท์ เพื่อเปิด หรือบันทึกแฟ้ม.chm จากเว็บไซต์ คุณควรทำเฉพาะในกรณีที่คุณต้องการให้แฟ้มและ หากคุณเชื่อถือเว็บไซต์ที่นำเสนอแฟ้ม

ในการดาวน์โหลดแฟ้มกล่องโต้ตอบ คลิกบันทึกจากนั้น เลือกที่คุณต้องการบันทึกแฟ้ม.chm จากนั้น ใช้หนึ่งในวิธีการต่อไปนี้:

วิธีที่ 1:

  1. คลิกสองครั้งที่แฟ้ม.chm
  2. ในการเปิดคำเตือนเกี่ยวกับการรักษาความปลอดภัยแฟ้มกล่องโต้ตอบ คลิกเพื่อยกเลิกเลือกนั้นถามทุกครั้งก่อนที่จะเปิดแฟ้มนี้กล่องกาเครื่องหมาย
  3. คลิกOPEN.

วิธีที่ 2

  1. คลิกขวาแฟ้ม CHM และจากนั้น คลิกคุณสมบัติ.
  2. คลิกยกเลิกบล็อก.
  3. คลิกสองครั้งที่แฟ้ม.chm เพื่อเปิดแฟ้ม

ความละเอียดสำหรับผู้ดูแลระบบ

เมื่อต้องการแก้ไขปัญหานี้ ให้ใช้วิธีการอย่างใดอย่างหนึ่งต่อไปนี้

ใช้เส้นทางของแฟ้ม UNC และแฟ้มการเชื่อมโยงไปยังแฟ้ม.chm ที่ใช้ร่วมกัน

หากอินทราเน็ตของเว็บเพจที่ใช้ชุดรูปแบบ HTTP URL เชื่อมโยงไปยังแฟ้ม.chm การปรับปรุงการรักษาความปลอดภัย 896358 อาจป้องกันไม่ให้ผู้ใช้เห็นหัวข้อในแฟ้ม.chm การแทนเส้นทางของแฟ้ม HTTP ด้วยเส้นทางของแฟ้ม UNC สามารถให้เป็นไปได้อีกครั้งเพื่อเปิดแฟ้ม.chm จากเว็บเพ

เมื่อต้องการใช้เส้นทางของแฟ้ม UNC แทน URL HTTP ดำเนินการดังต่อไปนี้:
  1. ย้ายแฟ้ม.chm บนเซิร์ฟเวอร์ที่ใช้ร่วมกันแฟ้มที่ระบุ โดยใช้เส้นทางของแฟ้ม UNC

    เส้นทางของแฟ้ม UNC มีลักษณะคล้ายกับเส้นทางต่อไปนี้:
    \\productmanuals\helpfiles
  2. ใช้ค่า ItssRestrictions\UrlAllowList เพื่อเปิดใช้งานระบบในอินทราเน็ตของคุณในการเข้าถึงแฟ้ม.chm จากแฟ้มที่ใช้ร่วมกัน

    สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
    896054คุณไม่สามารถเปิดเนื้อหาระยะไกล โดยใช้โพรโทคอล InfoTech หลังจากที่คุณติดตั้งการปรับปรุงการรักษาความปลอดภัย 896358 การปรับปรุงการรักษาความปลอดภัย 840315 หรือ Windows Server 2003 Service Pack 1
  3. การปรับปรุงการเชื่อมโยงต่าง ๆ บนหน้าเว็บอินทราเน็ตของคุณใช้เส้นทางของแฟ้ม UNC ใน url ที่เชื่อมโยงไปยังแฟ้ม.chm
หมายเหตุ:วิธีนี้ทำงานได้สำหรับเพจที่เกี่ยวข้องจากเขตอินทราเน็ตเท่านั้น วิธีการนี้ไม่ได้ผลสำหรับเพจที่เกี่ยวข้องจากโซนอินเทอร์เน็ต

ตั้งค่าโปรแกรมประยุกต์เว็บให้ดาวน์โหลดแฟ้ม.chm

บนหน้าเว็บที่เชื่อมโยงไปยังแฟ้ม.chm เพิ่มคำแนะนำที่แนะนำผู้ใช้จะบันทึกแฟ้มแทนที่การเปิดแฟ้มนั้นโดยตรง สำหรับข้อมูลเพิ่มเติม ให้ดูที่ส่วน "การแก้ปัญหาสำหรับผู้ใช้ปลายทาง"

คุณยังสามารถใช้ DownloadOptions <meta>แท็กเพื่อเอาปุ่ม'เปิด'ออกจากการดาวน์โหลดแฟ้มกล่องโต้ตอบที่ปรากฏขึ้นหลังจากที่ผู้ใช้คลิกการเชื่อมโยงไปยังแฟ้ม.chm ได้ Put this tag inside the<head> tag of your HTML page.This usage is illustrated in the following example.</head>
<head>
<META name="DownloadOptions" content="noopen">
</head>
สำหรับข้อมูลเพิ่มเติม โปรดเยี่ยมชมเว็บไซต์ต่อไปนี้ของ Microsoft::
http://msdn2.microsoft.com/library/ms534184.aspx
หมายเหตุ:The use of the DownloadOptions <meta> tag is supported only in Microsoft Windows XP with Service Pack 2 and in Windows Server 2003 with Service Pack 1.

ข้อมูลเพิ่มเติม

ภาพรวมและตัวอย่างสำหรับผู้ดูแลระบบ

For more information about security update 896358 and how you can re-enable Web applications that are affected by this update, click the following article number to view the article in the Microsoft Knowledge Base:
896358ms05-026: ช่องโหว่ในวิธีใช้ HTML อาจทำให้โค้ดจากระยะไกล

Internet Explorer

For more information about opening files by hyperlink in Internet Explorer, click the following article number to view the article in the Microsoft Knowledge Base:
232077Executing files by hyperlink and the File Download dialog box
For more information about how to use security zones in Internet Explorer, click the following article number to view the article in the Microsoft Knowledge Base:
174360วิธีการใช้โซนความปลอดภัยใน Internet Explorer

ฝ่ายสนับสนุนด้านเทคนิคสำหรับ x 64-รุ่นที่ใช้ Microsoft Windows

On computers that are running x64-based versions of Microsoft Windows, you may have to adapt the instructions in the "Resolution" section about how to modify the registry. For example, you might have to modify a different part of the registry, depending on whether you want to modify the 32-bit or the 64-bit functionality.สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
896459Registry changes in Windows x64 Edition-based operating systems
Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site:
http://www.microsoft.com/windowsxp/64bit/default.mspx
For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:
http://technet.microsoft.com/windowsserver/bb430829.aspx

คุณสมบัติ

หมายเลขบทความ (Article ID): 902225 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 4.0
ใช้กับ
  • Microsoft Windows Server 2003 Service Pack 1 เมื่อใช้กับ:
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
Keywords: 
kbsecurity kbexpertiseinter kbexpertiseadvanced kbtshoot kbprb kbmt KB902225 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:902225

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com