Error: Diagrama de base de datos de SQL Server aparecerá en blanco después de instalar Service Pack 6 de Visual Studio 6 o Visual Studio .NET 2003

Seleccione idioma Seleccione idioma
Id. de artículo: 902245 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

en este artículo describe un problema que se produce después de instalar Microsoft Visual Studio 6 Service Pack 6 (SP6) o Visual Studio .NET 2003. Diagramas de base de datos parecen ser en blanco al abrirlos. Este problema se produce porque están instalados los archivos .DLL incorrecta en el Service Pack 6 de Visual Studio 6 y Visual Studio .NET 2003. Debe reinstalar la versión de Visual Studio 6 SP5 de esos archivos para resolver el problema.

Síntomas

Al abrir un diagrama de base de datos de Microsoft SQL Server, el diagrama parece estar en blanco y no contiene ningún contenido. Sin embargo, no recibirá mensaje de error.

Este problema se produce después de instalar Visual Studio 6 SP6 o Visual Studio .NET 2003.

Causa

Este problema se produce porque algunos archivos .DLL incorrecta están incluidos en Service Pack 6 de Visual Studio 6 y en Visual Studio .NET 2003. Estos archivos incluyen archivos de .dll que normalmente se encuentran en la carpeta siguiente:
C:\Archivos de programa\Archivos comunes\Microsoft Shared\MSDesigners98

Solución

Para resolver este problema, reemplazar todos los archivos en la carpeta MSDesigners98 mediante los archivos en la misma carpeta de Service Pack 6 de Visual Studio 6. Para ello, siga estos pasos:
  1. Descargar Visual Studio 6 SP6.

    El archivo siguiente está disponible para descargarlo del Centro de descarga de Microsoft:

    Contraer esta imagenAmpliar esta imagen
    Download
    Download the Vs6sp5vb.exe package now.Fecha de lanzamiento: 21 de febrero de 2001

    Para obtener información adicional acerca de cómo descargar los archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    119591Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
    Microsoft exploró este archivo en busca de virus. con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a prevenir que se hagan cambios no autorizados.
  2. En el cuadro de diálogo Descarga de archivos , haga clic en Guardar .
  3. En el cuadro de diálogo haga clic en escritorio en el panel izquierdo y, a continuación, haga clic en Guardar .
  4. En el escritorio, haga doble clic en Vs6sp5vb.exe para extraer el archivo.
  5. En el cuadro de diálogo Abrir archivo , haga clic en Ejecutar .
  6. Escriba la ubicación donde desea guardar los archivos extraídos y, a continuación, haga clic en Aceptar . Por ejemplo, escriba C:\ Vs6sp5 y, a continuación, haga clic en Aceptar . Si no existe la carpeta que especifique, haga clic en para crear la carpeta.
  7. Expandir archivos a c:\Archivos de programa\Archivos comunes\Microsoft Shared\MSDesigners98 carpeta. Para ello, siga estos pasos:
    1. Haga clic en Inicio , haga clic en Ejecutar , escriba cmd y, a continuación, haga clic en Aceptar .
    2. Para cambiar el directorio a la carpeta donde extrajo el archivo .cab archivos en el paso 6, escriba el comando siguiente y, a continuación, presione ENTRAR:
      CD c: Vs6sp6
      Nota Reemplazar c:\ Vs6sp6 por la ruta que utilizó en el paso 6.
    3. Para expandir los archivos desde el archivo .cab en la carpeta apropiada, escriba el comando siguiente y, a continuación, presione ENTRAR:
      expanda F Vs6sp6b2.cab: msdesign * .dll c:\Archivos de programa\Archivos comunes\Microsoft Shared\MSDesigners98

Estado

Microsoft ha confirmado que se trata de un error de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Cualquier diagrama de base de datos que creó en Visual Studio 6 SP6 o en Visual Studio .NET 2003 funcionará después de instalar los archivos .dll de SP5 de Visual Studio 6.

Pasos para reproducir el comportamiento

  1. Instalar cualquier versión de Microsoft SQL Server 2000.
  2. En el Administrador corporativo de SQL, crear un nuevo diagrama de base de datos que se denomina DD1 y, a continuación, guarde el diagrama.
  3. Instala la versión original de Visual Studio 6.
  4. En el Administrador corporativo de SQL, crear un nuevo diagrama de base de datos que se denomina DD2 y, a continuación, guarde el diagrama.
  5. Instalar Visual Studio 6, SP5.
  6. En el Administrador corporativo de SQL, crear un nuevo diagrama de base de datos que se denomina DD3 y, a continuación, guarde el diagrama.

    Observe que las tres bases de datos diagramas se puede modificar en este momento.
  7. Instalar Visual Studio 6 SP6 o Visual Studio .NET 2003.
  8. Intente modificar los diagramas de base de datos que creó en los pasos 1 a 6.

    Observe que los diagramas de aparecer en blanco.

Propiedades

Id. de artículo: 902245 - Última revisión: martes, 7 de marzo de 2006 - Versión: 1.4
La información de este artículo se refiere a:
  • Microsoft Visual Studio .NET 2003 Professional
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio 6.0 Service Pack 6
Palabras clave: 
kbmt kbvs2005swept kbvs2005doesnotapply kbfix kbtshoot kbbug KB902245 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 902245

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com