Um formulário da Web não envia um nome de usuário e uma senha para um servidor Web no Internet Explorer 6

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importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
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Neste artigo

Sintomas

Considere o seguinte cenário:
  • O servidor Web utiliza o cabeçalho HTTP Negotiate Authorization para autenticar clientes em um site da Web.
  • Você usar o Microsoft Internet Explorer 6 para acessar este site da Web de um computador cliente.
  • Você será solicitado a digite o nome de usuário e a senha.
  • Após você insere o nome de usuário e a senha e, em seguida, clique em OK , você recebe uma página HTML de autenticação com base em formulários que inclui um formulário da Web. Esse formulário da Web contém um campo de nome de usuário e um campo de senha. A página da Web também inclui uma mensagem informando que o servidor Web nega a autenticação NTLM.
  • Você insere o nome de usuário e a senha no formulário da Web e, em seguida, enviar o formulário da Web.
Nesse cenário, o formulário da Web não envio o nome de usuário e a senha para o servidor Web.

Causa

Esse problema ocorre porque o arquivo Wininet.dll não impede que os dados que está sendo enviada quando o cliente usa a autenticação NTLM e o servidor Web espera uma resposta simples e mecanismo de negociação GSSAPI protegido (SPNEGO).

Quando você envia o nome de usuário e senha pela primeira vez, o arquivo Wininet.dll no computador cliente adiciona uma resposta NTLM para o cabeçalho negociação autorização. Se o servidor Web espera uma resposta SPNEGO, o servidor Web pode enviar uma resposta que não seja "401 acesso negado." Como a resposta não é "401 acesso negado", o Wininet.dll incorretamente pressupõe que a autenticação foi bem-sucedida. Quando Wininet.dll pressupõe que uma autenticação bem-sucedida ocorreu, o Wininet.dll remove os dados de autenticação que salvo e envie novamente os dados.

Resolução

Windows XP

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 1 (SP1) ou Windows XP Service Pack 2 (SP2) instalado.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:02  6.0.2900.2754  660,480  Wininet.dll         SP2
   07-Sep-2005  00:09  5.1.2600.2754   30,720  Arpidfix.exe        SP2
   06-Sep-2005  10:36  6.0.2800.1521  585,728  Wininet.dll         SP1

Windows Server 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Pré-requisitos
Não pré-requisitos são necessários.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:29  6.0.3790.404   628,224  Wininet.dll
   07-Sep-2005  02:50  6.0.3790.2524  663,040  Wininet.dll         SP1
   07-Sep-2005  00:29  5.2.3790.2524   32,256  Arpidfix.exe        SP1

Instruções de instalação do hotfix

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Depois de aplicar esse hotfix, ativar o hotfix, adicionando duas entradas de registro no registro. Para adicionar essas entradas do Registro, execute estas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Para ativar este hotfix em uma base por usuário, clique em uma das seguintes subchaves do Registro:
    • HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_CURRENT_USER\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Observação Você só precisará adicionar as entradas do Registro a uma das seguintes subchaves do Registro.

    Para ativar esse hotfix em uma base por máquina, clique em uma das seguintes subchaves do Registro:
    • HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_LOCAL_MACHINE\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Observação Você só precisará adicionar as entradas do Registro a uma das seguintes subchaves do Registro.
  3. No menu Editar , aponte para novo e, em seguida, clique em chave .
  4. Digite
    FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    e, em seguida, pressione ENTER.
  5. Clique em FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409 .
  6. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  7. Digite iexplore.exe para nomear o novo valor DWORD e pressione ENTER.
  8. Clique duas vezes em iexplore.exe , digite 1 na caixa dados do valor e, em seguida, clique em OK para habilitar o hotfix.

    Observação Para desativar o hotfix, digite 0 na caixa dados do valor .
  9. Para adicionar a entrada de registro do Explorer.exe, repita as etapas 3 a 5. Na etapa 4, digite Explorer.exe em vez de iexplore.exe .
  10. Feche o Editor do Registro.

Como Contornar

Para contornar esse problema, configure o servidor Web para oferecer suporte à autenticação NTLM. Para obter mais informações sobre como configurar o servidor Web para executar a autenticação NTLM, contate o fornecedor do servidor Web.

Para obter informações sobre o fabricante do hardware, visite o seguinte site:
http://support.microsoft.com/gp/vendors/en-us

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.

Mais Informações

Para obter mais informações sobre a terminologia usada neste artigo, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 902409 - Última revisão: quinta-feira, 15 de novembro de 2007 - Revisão: 4.6
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 SP1 nas seguintes plataformas
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbwinserv2003sp1fix kbwinserv2003presp1fix kbwinxpsp2fix kbwinxppresp2fix kbqfe kbie600sp2fix kbie600presp2fix kbfix kbbug kbpubtypekc kbhotfixserver KB902409 KbMtpt
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