How to use the Microsoft Money Standard File Repair utility

Article translations Article translations
Article ID: 902466 - View products that this article applies to.
Notice
If you've been managing your finances with the help of Microsoft Money, you should be aware that Microsoft discontinued all online services and assisted support for all versions of Money on January 31, 2011. (Microsoft discontinued sales of Money on June 20, 2009.) If you're looking for an alternative program, Microsoft has made the Money Plus Sunset versions available as a replacement for the following expired programs: Microsoft Money Essentials, Microsoft Money Deluxe, Microsoft Money Premium, Microsoft Money Home, and Microsoft Money Business. For more information about Money Plus Sunset, refer to this article in the Microsoft Knowledge base: What Is Microsoft Money Plus Sunset?
Expand all | Collapse all

On This Page

INTRODUCTION

This article describes how to use the Standard File Repair utility to repair a Microsoft Money data file.

Occasionally, a data file contains some inconsistencies that can cause errors in Money. If this problem occurs, you can use the built-in repair tool to repair a damaged data file.

The Standard File Repair utility performs a low-level check for file integrity. The Standard File Repair utility examines the format and the stability of your Money data file.

Note The Standard File Repair utility does not examine the accuracy of the data that you enter into the Money data file. Additionally, the Standard File Repair utility cannot repair all the damaged data files.

MORE INFORMATION

The Standard File Repair utility contains the following repair options:
  • Level 1 (Quick Repair)

    The Quick Repair option performs the minimum corrective actions to your existing file. This includes resetting customized reports.
  • Level 2 (Standard)

    The Standard option examines the integrity of all stored data to perform a complete repair operation.
Use the Quick Repair option if your data file contains incorrect values in the custom data and does not contain any damage in the database. If Money cannot convert your data file from an earlier version of Money but finishes the first part of the conversion, the Quick Repair option may fix your data file.

How to use the Standard File Repair utility

Before you run the Standard File Repair utility on the Money data file, we recommended that you first use the Quick File Repair utility.

If the Quick File Repair utility does not resolve the Money data file issue, run the Standard File Repair utility. To do this, follow these steps for your version of Money.

Run the Standard File Repair utility in Microsoft Money 2004 and later versions

  1. Start Money.
  2. On the File menu, point to Repair Money File, and then click Standard File Repair.
  3. Next to the Repair File box, click Browse.
  4. In the Look in box, locate and then click the data file that you want to repair.
  5. Click Open.
  6. Next to the Save as box, click Browse.
  7. In the Save in box, click the location where you want to save the repaired data file.
  8. In the File name box, enter a new name for the repaired data file, and then click Save.
  9. Click Next.

    Note Make sure that you use a unique name to save the repaired data file. For example, if your data file name is MyMoney.mny, save the repaired data file as MyMoney1.mny or as Repair1.mny.
  10. Verify that Level 2 (Standard) appears in the Level box, and then click Next.
  11. Click Begin Repair to repair the data file.
  12. When you receive the message that states that the file is successfully repaired, click OK.
  13. Click View Log to view details about any damaged information that the Standard File Repair utility may have experienced, and then click Exit.

    Note To view the log file, you must have Notepad.exe in your executable path.
  14. Test the repaired file to see whether the issue is resolved.

    Note After you run the Standard File Repair utility, we always recommend that you run the Quick File Repair utility as mentioned earlier. When you run the Quick File Repair utility, make sure that the file that you select to repair is the most recently created file.

Run the Standard File Repair utility in Microsoft Money 2000, in Microsoft Money 2001, in Microsoft Money 2002, or in Microsoft Money 2003

  1. Create a folder to which you can extract the downloaded files. Right-click the desktop, point to New, and then click Folder. For example, create a folder that is named "Money Standard File Repair Tool."
  2. Download and then run the following file from the Microsoft Download Center. This file is a self-extracting file that extracts itself automatically. We suggest that you download this file into a folder this is named appropriately. For example, download this file into a folder that is named C:/\Money Repair Download Money Repair now.
  3. The following file is available for download from the Microsoft Download Center:
    Collapse this imageExpand this image
    Download
    Download the M06-Repair.exe package now. Release Date: November 4, 2005

    For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
    119591 How to obtain Microsoft support files from online services
    Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

    Note This version of the repair tool is based on Microsoft Money 2006. It will repair earlier Money data files but may have dependencies on later system files than the files that were installed by your version of Money. If you receive an error message about missing files (for example msvcr71.dll) after you run the Repair tool, see the "Missing system files" section.
  4. Locate and then click the folder that you downloaded the file into in step 2. Double-click the Salv.exe file to run the Money Repair utility.
  5. Next to the Repair File box, click Browse.
  6. In the Look in box, locate and then click the data file that you want to repair.
  7. Click Open.
  8. Next to the Save as box, click Browse.
  9. In the Save in box, click the location where you want to save the repaired data file.
  10. In the File name box, enter a new name for the repaired data file, and then click Save.

    Note Make sure that you use a unique name to save the repaired data file. For example, if your data file name is MyMoney.mny, save the repaired data file as MyMoney1.mny or as Repair1.mny.
  11. Click Next.
  12. Verify that Level 2 (Standard) appears in the Level box, and then click Next.
  13. Click Begin Repair to repair the data file.
  14. When you receive the message that states that the file is successfully repaired, click OK.
  15. Click View Log to view details about any damaged information that the Standard File Repair utility may have experienced, and then click Exit.

    Note To view the log file, You must have Notepad.exe in your executable path.
  16. Test the repaired file to see whether the issue is resolved.
If the issue is not resolved, we recommend that you repeat steps 1 through 11. This time, select Level 1 repair instead of Level 2 repair in step 11. Make sure that you select the new file that you created in step 9 when you specify the file to repair in step 6. For example, if the new data file that you created is Repair1.mny, you must specify Repair1.mny as the data file in step 6. You can then specify the new name for the repaired data file as Repair2.mny in step 9.

If the issue is still not resolved, the file may be damaged beyond repair. In this situation, you have the following options:
  • You can restore a backup file that does not have the damage.
  • You can create a new data file, and then export your existing account information to the new file.
For more information about how to restore a backup file, click the following article number to view the article in the Microsoft Knowledge Base:
178850 How to restore a backup file in Microsoft Money
For more information about how to create a new data file and how to export your existing account information to the new file, click the following article number to view the article in the Microsoft Knowledge Base:
178830 How to export and import account information in Microsoft Money

Missing system files workarounds

If you receive an error message that states that some file is missing when you run the salv.exe Repair tool, you can use one of the following workarounds to enable the tool to work.

Method 1: Find a copy of the missing file on the computer

Many other programs use and install the same system files. Therefore, this file may be available on the computer but not in the search path that the Repair tool is using. To find the file, follow these steps.
Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

On a computer that is running Windows Vista
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , and then click Search.
  2. Click Advanced Search.
  3. Click to select the Include non-indexed, hidden, and system files check box.
  4. In the Search box, type the file name of the file that is mentioned in the error message.
  5. Click Search.
  6. If the file is found, right-click the file, and then click Copy.
  7. Locate and then open the folder in which Salv.exe is located.
  8. Right-click in the folder, and then click Paste.
On a computer that is running Windows XP or an earlier version of Windows
  1. Click Start, and then click Search.
  2. Click All files and folders.
  3. Click More advanced options.
  4. Verify that the following check boxes are selected:
    • Search system folders
    • Search hidden files and folders
    • Search subfolders
  5. In the All or part of the file name box, type the file name of the file that is mentioned in the error message.
  6. Click Search.
  7. If the file is found, right-click the file, and then click Copy.
  8. Locate and then open the folder in which Salv.exe is located.
  9. On the Edit menu, click Paste.

Method 2: Download the free 90-day trial of the latest version of Money

To obtain the trial version of Money, visit the following Microsoft Web site:
http://www.microsoft.com/money
You can install this version of Money in a separate folder so that it does not replace the existing version of Money that you have. The required system files will then be available. Feel free to compare and explore the features in this version of Money. Be aware that Money will automatically try to upgrade the last Money data file that you used and create a copy of the original file. You can enable this to occur, or you can click New File on the File menu to start with a new file. If you decide that you do not want to upgrade to this version of Money, you can remove it, and then reinstall the version of Money that you want to use.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
178465 How to return to using an earlier version of Money after you convert your data file to Money 2000 or a later version

Properties

Article ID: 902466 - Last Review: February 11, 2011 - Revision: 5.0
APPLIES TO
  • Microsoft Money Plus Deluxe
  • Microsoft Money Plus Home & Business
  • Microsoft Money Plus Premium
  • Microsoft Money 2007 Deluxe
  • Microsoft Money 2007 Home & Business
  • Microsoft Money 2007 Premium
  • Microsoft Money 2006 Deluxe
  • Microsoft Money 2006 Premium
  • Microsoft Money 2006 Small Business
  • Microsoft Money 2006 Standard
  • Microsoft Money 2005 Deluxe Edition
  • Microsoft Money 2005 Premium Edition
  • Microsoft Money 2005 Small Business Edition
  • Microsoft Money 2005 Standard Edition
  • Microsoft Money 2004 Standard Edition
  • Microsoft Money 2003 Deluxe Edition
  • Microsoft Money 2003 Deluxe and Business Edition
  • Microsoft Money 2003 Standard Edition
  • Microsoft Money 2002 Deluxe Edition
  • Microsoft Money 2002 Standard Edition
  • Microsoft Money 2001 Standard Edition
Keywords: 
kbrepair kbsavefile kbopenfile kbnewfile kbhowto KB902466

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com