Artigo: 902932 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Ao abrir uma nova janela no Internet Explorer 6 ou no Internet Explorer 7 da Microsoft, a nova janela apresenta uma página em branco. Este sintoma também se verifica caso uma página HTML abra uma nova janela no Internet Explorer. Além disso, é apresentada a seguinte mensagem de erro ao tentar efectuar uma pesquisa na página utilizando o comando Localizar (na página actual):
Ocorreu um erro nesta caixa de diálogo.
Erro 49: Interface não registada

Este artigo ajuda-o a corrigir o problema.

Para nos solicitar a correcção deste problema, consulte a secção ?Corrigir por mim?. Se preferir corrigir o problema sozinho, consulte a secção ?Deixar-me corrigir o problema?.

Corrigir por mim

Para corrigir este problema automaticamente, clique na hiperligação Corrigir este problema. Em seguida, clique em Executar na caixa de diálogo Transferência de Ficheiros e siga os passos indicados neste assistente.

Corrigir este problema
Correcção de problemas da Microsoft 50191

Nota: este assistente pode estar apenas em inglês; contudo, a correcção automática também funciona em versões do Windows noutros idiomas.

Nota: se não estiver a trabalhar no computador que tem o problema, pode guardar a correcção automática numa unidade Flash ou num CD e, em seguida, executá-la no computador com o problema.

Agora, avance para a secção "O problema está corrigido?".

Deixar-me corrigir o problema

Para resolver este problema, volte a registar os ficheiros DLL relacionados com o Internet Explorer. Para o fazer, siga estes passos:
  1. Clique em Iniciar e, em seguida, clique em Executar.
  2. Escreva regsvr32 urlmon.dll na caixa Abrir e clique em OK.
  3. Clique em OK quando receber a seguinte mensagem:
    DllRegisterServer em urlmon.dll teve êxito
  4. Repita os passos 1 a 3 para os restantes ficheiros DLL, substituindo o comando regsvr32 urlmon.dll na caixa Abrir pelos seguintes comandos:
    • regsvr32 actxprxy.dll
    • regsvr32 shdocvw.dll
    • regsvr32 mshtml.dll
    • regsvr32 browseui.dll
    • regsvr32 jscript.dll
    • regsvr32 vbscript.dll
    • regsvr32 oleaut32.dll
Agora, avance para a secção "O problema está corrigido?".

O problema está corrigido?

Verifique se o problema foi corrigido. Se o problema estiver corrigido, o processo termina aqui. Se o problema não estiver corrigido, pode contactar o suporte.

Causa

Este problema ocorre se os ficheiros DLL relacionados com o Internet Explorer não estiverem correctamente registados.

Propriedades

Artigo: 902932 - Última revisão: 26 de setembro de 2011 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • Microsoft Windows XP Home Edition
  • Windows Vista Home Basic
  • Windows Vista Home Premium
Palavras-chave: 
kbmsifixme kbfixme kbtshoot kberrmsg kbprb KB902932

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com