Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Support for Internet Explorer ended on June 15, 2022

Internet Explorer 11 has been permanently disabled through a Microsoft Edge update on certain versions of Windows 10. If any site you visit needs Internet Explorer 11, you can reload it with Internet Explorer mode in Microsoft Edge. We recommend you use Microsoft Edge  for a faster, more secure and more modern web browsing experience.

Get started with Microsoft Edge

Symptoms

If you open a new window in Microsoft Internet Explorer 6 or in Internet Explorer 7, the new window displays a blank white page. This symptom also occurs if an HTML page opens a new window in Internet Explorer. Additionally, you receive the following error message if you try to perform a search on the page by using the Find (on This Page) command:

An error has occurred in this dialog.
Error 49: Interface not registered


This article helps you fix the problem.

To have us fix this problem for you, go to the “Fix it for me” section. If you would rather fix this problem yourself, go to the “Let me fix it myself” section.

 

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.


 


Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

Now go to the "Did this fix the problem?" section.

Let me fix it myself

To resolve this issue, re-register the DLL files that are related to Internet Explorer. To do this, follow these steps:

  1. Click Start, and then click Run

  2. Type regsvr32 urlmon.dll in the Open box, and then click
    OK.

  3. Click OK when you receive the following message:

    DllRegisterServer in urlmon.dll succeeded

  4. Repeat steps 1 through 3 for the rest of the DLL files by replacing the regsvr32 urlmon.dll command in the Open box with the following commands:

    • regsvr32 actxprxy.dll

    • regsvr32 shdocvw.dll

    • regsvr32 mshtml.dll

    • regsvr32 browseui.dll

    • regsvr32 jscript.dll

    • regsvr32 vbscript.dll

    • regsvr32 oleaut32.dll

Now go to the "Did this fix the problem?" section.

Did this fix the problem?

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the problem is not fixed, you can contact support.

Cause

This issue occurs if the dynamic link library (DLL) files that are related to Internet Explorer are not correctly registered.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×