โปรแกรมประยุกต์ที่ใช้.NET Framework ที่ใช้คลาส XMLSerializer หยุดการตอบสนองเมื่อโปรแกรมประยุกต์ที่ทำงานบน Windows XP รุ่นภาษาเอเชีย

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 903204 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
สิ่งสำคัญบทความนี้ประกอบด้วยข้อมูลเกี่ยวกับวิธีการแก้ไขรีจิสทรี ควรตรวจสอบว่าได้สำรองรีจิสทรีก่อนที่จะปรับเปลี่ยน โปรดทำความเข้าใจกับวิธีการคืนค่ารีจิสทรีในกรณีที่เกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีสำรองข้อมูล คืนค่า และปรับเปลี่ยนรีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base::
256986คำอธิบายสำหรับ Microsoft Windows Registry
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อ Microsoft โปรแกรมประยุกต์ที่ใช้.NET Framework พยายามที่จะสร้างอินสแตนซ์ของการXMLSerializerคลา แอพลิเคชันหยุดการตอบสนอง อาการนี้เกิดขึ้นหากคุณพยายามเรียกใช้โปรแกรมประยุกต์บนคอมพิวเตอร์ที่กำลังเรียกใช้ Microsoft Windows XP รุ่นภาษาเอเชีย

หมายเหตุ:บทความนี้ที่เกี่ยวข้องกับสถานการณ์เฉพาะที่อาการนี้เกิดขึ้น มีสถานการณ์อื่น ๆ ซึ่งอาการนี้อาจเกิดขึ้น ตัวอย่างเช่น อาการนี้อาจเกิดขึ้นได้เมื่อกระบวนการหนึ่งเริ่มต้นกระบวนการอื่นในไม่ใช่-รุ่น Windows XP เอเชีย

สาเหตุ

กระบวนการXMLSerializerดำเนินการคลาสการคอมไพล์ dynamical. ในระหว่างการคอมไพล์ dynamical กระบวนการ Csc.exe ถูกเริ่ม ในกลับ Csc.exe กระบวนการเริ่มต้นกระบวนการ Conime.exe ใน Windows XP รุ่นภาษาเอเชีย

ปัญหาที่อธิบายไว้ในส่วน "อาการ" เกิดขึ้นเนื่องจากเงื่อนไข deadlock ระหว่าง Csc.exe โดยเฉพาะอย่างยิ่ง เธรดที่หนึ่ง (เธรด A) acquires ล็อกที่จำเป็น โดยเธรดอื่น (เธรด B) ดังนั้น เธรด B พยายามเริ่มการทำงานของกระบวนการ Conime.exe โดยค่าเริ่มต้น กระบวนการ Conime.exe ถูกโหลดเมื่อใดก็ ตามที่พร้อมท์รับคำสั่งเริ่มการทำงานบน Windows XP รุ่นภาษาเอเชีย เธรด waits B 10 นาทีในขณะที่พยายามล็อกที่ร้องขอ หลังจาก 10 นาที เธรดนี้หมดเวลา

หมายเหตุ:สำหรับข้อมูลเพิ่มเติม โปรดเยี่ยมชมเว็บไซต์ต่อไปนี้ของ MSDN::
http://msdn2.microsoft.com/en-us/library/ms971336.aspx

การแก้ไข

คำเตือนปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง โดยใช้ตัวแก้ไขรีจิสทรี หรือ โดยใช้วิธีอื่น คุณอาจต้องติดตั้งระบบปฏิบัติการใหม่เพื่อแก้ไขปัญหาเหล่านี้ Microsoft ไม่รับประกันว่าจะสามารถแก้ไขปัญหาได้ คุณต้องยอมรับความเสี่ยงด้วยตนเองในการปรับเปลี่ยนรีจิสทรี
ตรวจสอบการแก้ไขปัญหานี้ ให้แน่ใจว่า Conime.exe กระบวนการเริ่มต้นเมื่อเริ่มต้นระบบ โดยให้ทำตามขั้นตอนต่อไปนี้::
  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:regeditในการOPENกล่อง แล้วคลิกตกลง.
  2. ค้นหา และคลิกที่คีย์ต่อไปนี้ในรีจิสตรี::
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
  3. ในบานหน้าต่างด้านขวา คลิกขวาบนพื้นที่ว่าง และคลิกใหม่. คลิกค่าสายอักขระประเภท:conimeชื่อ แล้วกด ENTER
  4. คลิกขวาconimeแล้ว คลิกปรับเปลี่ยน.
  5. ในการแก้ไขสายอักขระกล่องโต้ตอบ ชนิด%windir%\system32\conime.exeภายใต้ข้อมูลค่า:แล้ว คลิกตกลง.
  6. ออกจากโปรแกรม Registry Editor

ข้อมูลเพิ่มเติม

ตัวแก้ไขวิธีการป้อนข้อมูล (IMEs) เป็นแฟ้ม DLL ที่ช่วยให้ผู้ใช้พิมพ์อักขระอักษรภาพที่ซับซ้อน ด้วยการใช้แป้นพิมพ์มาตรฐาน IMEs พร้อมใช้งานใน Windows รุ่นภาษาเอเชีย IMEs ทำให้กระบวนการที่ผู้ใช้ป้อนข้อความที่ประกอบด้วยอักขระจาก Unicode และการตั้งค่าอักขระไบต์คู่รูปแบบ (DBCS) IMEs ตรวจสอบการกดแป้นพิมพ์ของผู้ใช้ anticipate อักขระผู้ใช้อาจต้อง และแสดงรายการของตัวเลือกของอักขระที่เลือก

ปัญหาที่อธิบายไว้ใน "อาการ" ส่วนไม่รู้จักเกิดขึ้นในโปรแกรมของบริษัทอื่นต่อไปนี้:
  • ชุดข้อมูล Inventor Autodesk 10
  • Professional Inventor Autodesk 10
ผลิตภัณฑ์ของบุคคลที่สามที่กล่าวถึงในบทความนี้ ผลิตขึ้นโดยบริษัทที่ไม่ขึ้นอยู่กับ Microsoft Microsoft ไม่มีการรับประกันใดๆ ไม่ว่าโดยนัยหรือรูปแบบอื่นใด เกี่ยวกับประสิทธิภาพหรือความเชื่อถือได้ของผลิตภัณฑ์เหล่านี้

คุณสมบัติ

หมายเลขบทความ (Article ID): 903204 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kb3rdparty kbtshoot kbprb kbmt KB903204 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:903204

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com