ID do artigo: 903219 - Última revisão: segunda-feira, 13 de agosto de 2007 - Revisão: 1.4

Você receber uma mensagem de erro "Acesso negado" após a atualização para o Windows XP Service Pack 2

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Expandir tudo | Recolher tudo

Sintomas

Após a atualização para o Microsoft Windows XP Service Pack 2 (SP2), você receber a seguinte mensagem de erro no Microsoft Internet Explorer:
Acesso negado
Esse problema ocorre se uma das seguintes condições for verdadeira:
  • Um quadro em um conjunto de quadros contém um controle ActiveX. O controle ActiveX abre uma página da Web em um outro quadro do conjunto de quadros. O controle abre a página usando um caminho relativo.
  • Uma página de aplicativo DHTML do Microsoft Visual Basic usa o método BaseWindow.Navigate para abrir uma página da Web usando um caminho relativo.

Causa

Esse problema ocorre porque o Windows XP SP2 introduziu blocos de elevação de zona do Microsoft Internet Explorer para ajudar a proteger seu computador.

Resolução

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows


Para resolver esse problema, recomendamos que você use um dos seguintes métodos:
  • Usar uma URL totalmente qualificada no código de controle ActiveX ou no aplicativo do Visual Basic DHTML que chama o método BaseWindow.Navigate .
  • Use o método location.href em vez de usar o método Navigate .
Além disso, embora não é recomendável que você desative blocos de elevação de zona, você pode fazer isso, alterando a seguinte entrada do Registro para 0 (zero):
HKEY_LOCAL_MACHINE\Software\Microsoft \Internet Explorer\Main\FeatureControl\FEATURE_ZONE_ELEVATION\iexplorer.exe
Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave:
    HKEY_LOCAL_MACHINE\Software\Microsoft \Internet Explorer\Main\FeatureControl\FEATURE_ZONE_ELEVATION
  3. Clique com o botão direito do mouse iexplorer.exe e, em seguida, clique em Modificar .
  4. Na caixa dados do valor , digite 0 e, em seguida, clique em OK .
  5. No menu arquivo , clique em Sair.

Mais Informações

Para obter mais informações sobre elevação de zona blocos, visite o seguinte site da Microsoft:
http://technet.microsoft.com/en-us/library/bb457150.aspx (http://technet.microsoft.com/en-us/library/bb457150.aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Service Pack 2
Palavras-chave: 
kbmt kbwebbrowser kbcontrol kbweb kbnofix kbtshoot kbprb KB903219 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 903219  (http://support.microsoft.com/kb/903219/en-us/ )