Počítač se systémem Windows 2000, systémem Windows Server 2003 nebo systémem Windows XP nastavené pomocí bitové kopie systému Windows 2000, Windows Server 2003 nebo Windows XP se nezobrazí v konzole služby WSUS

Překlady článku Překlady článku
ID článku: 903262 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Počítač se systémem Windows 2000, Windows Server 2003 nebo Windows XP se nezobrazí v konzole služby Windows Server Update Services (WSUS).

K tomuto problému dochází, pokud byla nastavena v počítači pomocí bitové kopie systému Windows 2000, bitové kopie systému Windows Server 2003 nebo bitové kopie systému Windows XP, ve kterém je naplněn hodnoty registru SusClientID před nasazením do klientských počítačů.

Při použití programu Sysprep k generalize obrazu pro virtuální počítač, nebo při vytváření obrazů pomocí unikátní technologii generování identifikátorů SID, hodnotu registru SusClientId je zrušeno, pokud je naplněn uvnitř obrazu před nasazení bitové kopie.

Poznámka: V WSUS 3.0 klient změní jeho SusClientID, při změně konfigurace hardwaru. Pro systém Windows Vista, Windows Server 2008 a novější verze Sysprep se změní SusClientID obnovit. Proto tento problém se týká pouze virtuální počítače, operačním systémem starším než Windows Vista, nebo které nebyly vytvořeny pomocí nástroje Sysprep.

Příčina

K tomuto problému dochází, protože klienti s obrázky mohou mít duplicitní hodnoty SusClientID v registru.

Řešení

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1: Změna registru

Důležité Tento oddíl, metoda nebo úkol obsahuje kroky, které informace o úpravě registru. Však mohou nastat závažné problémy při nesprávných úpravách registru. Proto se ujistěte, opatrně postupujte takto. Pro zvýšení ochrany před úpravami je nutné zálohujte registr. Můžete pak obnovení registru v případě, že dojde k potížím. Další informace o zálohování a obnovení registru získáte článku znalostní báze Microsoft Knowledge Base:
322756 Postup při zálohování a obnovení registru v systému Windows
  1. Klepněte na tlačítko Spustit, klepněte na tlačítko Spustit, Typ cmd v Otevřít pole a pak Klepněte na tlačítko OK.
  2. Na příkazovém řádku zadejte následující příkaz: net stop wuauserv, a pak stiskněte klávesu ENTER.
  3. Klepněte na tlačítko Spustit, klepněte na tlačítko Spustit, Typ regedit v Otevřít pole a pak Klepněte na tlačítko OK.
  4. Vyhledejte a klepněte na následující podklíč registru:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
  5. V podokně podrobností Editoru registru odstraňte následující položky registru:
    • PingID
    • AccountDomainSid
    • SusClientId
    • SusClientIDValidation
    Poznámka: Windows Update Agent 3.0 přidá hodnotu SusClientIDValidation. Tato hodnota byla vydána v květnu 2007. Ostatní položky registru existují v obou Windows Update Agent 2.0 a v systému Windows Update Agent 3.0.
  6. Ukončete Editor registru.
  7. Na příkazovém řádku zadejte následující příkaz: net start wuauserv, a pak stiskněte klávesu ENTER.
  8. Na příkazovém řádku zadejte následující příkaz: wuauclt.exe /resetauthorization/detectnow, a pak stiskněte klávesu ENTER.
  9. Počkejte 10 minut cyklu zjišťování dokončit.
  10. Spuštění konzoly služby WSUS a ujistěte se, že se klienti v konzole služby WSUS.

Metoda 2: Použití souboru Sysprep.inf

Pokud jste již soubor s názvem souboru Sysprep.inf ve stejné složce jako soubor Sysprep.exe, postupujte takto.

Poznámka: Chcete-li tento problém vyřešit, musí být takto použity před generalize obrazu.
  1. Poklepejte na soubor Sysprep.inf, otevřete soubor v programu Poznámkový blok.
  2. Přejděte na položku Hledat Oddíl [GuiRunOnce] sekce.

    Poznámka: Pokud Oddíl [GuiRunOnce] oddíl neexistuje, vytvořte jej zadáním na konci souboru Sysprep.inf.
  3. Underneath Oddíl [GuiRunOnce], zadejte následující text.

    Poznámka: Tyto nové příkazy, které jsou uvedeny jako "Command0" až "command3". Tato označení jsou správné pouze tehdy, pokud Oddíl [GuiRunOnce] oddíl obsahuje aktuálně žádné příkazy. Pokud jsou již příkazy pod Oddíl [GuiRunOnce], změnit příkaz"x"položky v nové příkazy tak, aby se další pořadové číslo. Například oddíl již obsahuje pět příkazů, které jsou uvedeny jako "Command0" až "command4", číslovat nové příkazy jako "Command5" až "command8".
    • Command0="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f"
    • Command1="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f"
    • Command2="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f"
    • Command3="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f"
  4. V Soubor nabídky, klepněte na tlačítko Uložit.
  5. V Soubor nabídky, klepněte na tlačítko Konec.

Metoda 3: Vytvořte soubor Sysprep.inf, pokud nemáte soubor

Pokud jste soubor s názvem souboru Sysprep.inf ve stejné složce jako soubor Sysprep.exe, postupujte při vytvoření souboru.

Poznámka: Chcete-li tento problém vyřešit, musí být takto použity před generalize obrazu.
  1. Klepněte na tlačítko Spustit, přejděte na příkaz Všechny programy, klepněte na tlačítko Příslušenstvía klepněte na tlačítko Poznámkový blok.
  2. Zadejte následující text:
    Oddíl [GuiRunOnce]

    Command0="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f"

    Command1="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f"

    Command2="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f"

    Command3="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f"
  3. V Soubor nabídky, klepněte na tlačítko Uložit.
  4. Vyhledejte adresář, ve kterém je umístěn soubor Sysprep.exe.
  5. Typ Soubor Sysprep.inf v Název souboru pole.
  6. Vybrat Všechny soubory v Uložit jako typ pole.
  7. Klepněte na tlačítko Uložit.
  8. V Soubor nabídky, klepněte na tlačítko Konec.

Další informace

První počítač se systémem Windows 2000, počítač se systémem Windows Server 2003 nebo počítače se systémem Windows XP, který byl nastaven pomocí bitové kopie systému Windows 2000, bitové kopie systému Windows Server 2003 nebo bitové kopie systému Windows XP se zobrazí v konzole služby WSUS. Dalším systémem Windows 2000, systémem Windows Server 2003 nebo systémem Windows XP počítačů, které jsou nastaveny pomocí stejného obrazu se však nezobrazí. K tomuto problému dochází, protože první počítač, který byl nastaven pomocí jedné z těchto obrázků používá stejnou hodnotu SusClientID.

Po provedení kroků popsaných v části "Řešení", je vytvořena nová hodnota SusClientID. Počítače se systémem Windows Server 2003, další počítače se systémem Windows 2000 nebo počítačů se systémem Windows XP, které jsou nastaveny pomocí stejného obrazu, navíc zobrazí v konzole služby WSUS.

Automatická funkce jsme přidali do Agent webu Windows Update nainstalovanou v počítačích klienta služby WSUS. Tato funkce může pomoci tento problém řeší duplicitní SusClientID. Funkce poskytuje řešení, která je přidána na straně klienta Agent webu Windows Update, počínaje verzí 7.0.6000.374. (Tato verze je verze klienta, který byl součástí WSUS 3.0).

Toto řešení využívá ověřovací rutiny hardware k určení, zda aktuální hardware klienta byl změněn na hodnotu SUSClientID byl vytvořen. (Tento hardware zahrnuje síťové adaptéry a pevné disky).

Rutinní ověření hardwaru je uložena jako binární velkého objektu v klíči registru Susclientidvalidation ve stejném umístění jako hodnotu registru Susclientid. Pokud rutina ověření hardwaru označuje, že došlo ke změně veškerého hardwaru, klient vytváří novou hodnotu SusClientID.

Poznámka: Rutinní ověření hardwaru vyžaduje, aby klient připojit k serveru se systémem Windows Software Update Services 3.0 nebo novější verzi WSUS a nikoli na serveru se systémem Windows Software Update Services 2.0.

Vlastnosti

ID článku: 903262 - Poslední aktualizace: 22. května 2011 - Revize: 8.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows Server 2003 Service Pack 1 na těchto platformách
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
Klíčová slova: 
kbdeployment kbtshoot kbprb kbmt KB903262 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:903262

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com