Windows 2000、Windows Server 2003、または Windows XP のイメージを使用してセットアップされた Windows 2000 ベース、Windows Server 2003 ベース、または Windows XP ベースのコンピューターが WSUS コンソールに表示されない

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文書番号: 903262
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目次

現象

Windows 2000、Windows Server 2003、または Windows XP を搭載しているコンピューターが WSUS コンソールに表示されません。

この問題は、Windows 2000 イメージ、Windows Server 2003 イメージ、または Windows XP イメージを使用してコンピューターをセットアップした場合に発生します。この場合、クライアント コンピューターに展開される前に SusClientID レジストリ値が作成されます。

Sysprep を使用して仮想マシンのイメージを一般化したり、一意の SID 生成技術を使用してイメージを作成するときに、イメージが展開される前にイメージ内で SusClientId レジストリ値が作成された場合、このレジストリ値は消去されません。

: WSUS 3.0 では、ハードウェア構成が変わった場合、クライアントはその SusClientID を変更します。Windows Vista、Windows Server 2008、およびそれ以降のバージョンの場合、Sysprep が変更され、SusClientID がリセットされます。したがって、この問題は Windows Vista よりも前のオペレーティング システムを搭載している仮想マシンや Sysprep を使用して作成されていない仮想マシンのみで発生します。

原因

この問題は、イメージを使用してセットアップされた複数のクライアントがレジストリに同じ SusClientID 値を保持していることが原因で発生します。

解決方法

この問題を解決するには、以下のいずれかの方法を使用します。

方法 1: レジストリを変更する

重要: このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。バックアップおよび復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに「cmd」と入力し、[OK] をクリックします。
  2. コマンド プロンプトで、「net stop wuauserv」と入力し、Enter キーを押します。
  3. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、[名前] ボックスに「regedit」と入力し、[OK] をクリックします。
  4. 次のレジストリ サブキーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
  5. レジストリ エディターの詳細ウィンドウで、次のレジストリ エントリを削除します。
    • PingID
    • AccountDomainSid
    • SusClientId
    • SusClientIDValidation
    : Windows Update Agent 3.0 は SusClientIDValidation 値を追加します。この値は 2007 年 5 月にリリースされました。その他のレジストリ エントリは Windows Update Agent 2.0 と Windows Update Agent 3.0 の両方に存在します。
  6. レジストリ エディターを終了します。
  7. コマンド プロンプトで、「net start wuauserv」と入力し、Enter キーを押します。
  8. コマンド プロンプトで、「wuauclt.exe /resetauthorization /detectnow」と入力し、Enter キーを押します。
  9. 検出サイクルが終了するまで、10 分間待機します。
  10. WSUS コンソールを起動して、クライアントが WSUS コンソールに表示されることを確認します。

方法 2: Sysprep.inf ファイルを使用する

Sysprep.exe と同じフォルダーに Sysprep.inf ファイルが既に存在する場合は、次の手順を実行します。

: この問題を解決するには、イメージを一般化する前に以下の手順を適用する必要があります。
  1. Sysprep.inf をダブルクリックして、メモ帳で開きます。
  2. 下にスクロールして [GuiRunOnce] セクションを見つけます。

    : [GuiRunOnce] セクションが存在しない場合は、Sysprep.inf ファイルの最後に入力して作成します。
  3. [GuiRunOnce] の下に以下のテキストを入力します。

    : これらの新しいコマンドは "Command0" から "Command3" として示されています。これらの指定は、[GuiRunOnce] セクションにコマンドが現在含まれていない場合のみ適切です。[GuiRunOnce] の下に既にコマンドがある場合は、連続する次の番号で始まるように新しいコマンドの "Commandx" エントリを置き換えます。たとえば、セクションに "Command0" から "Command4" と示されている 5 つのコマンドが既に含まれている場合、これらの新しいコマンドに "Command5" から "Command8" のように番号を付けます。
    • Command0=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f”
    • Command1=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f”
    • Command2=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f”
    • Command3=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f”
  4. [ファイル] メニューの [上書き保存] をクリックし、[はい] をクリックします。
  5. [ファイル] メニューの [レジストリ エディターの終了] をクリックします。

方法 3: Sysprep.inf ファイルがない場合にファイルを作成する

Sysprep.exe と同じフォルダーに Sysprep.inf ファイルが存在しない場合は、次の手順に従ってファイルを作成します。

: この問題を解決するには、イメージを一般化する前に以下の手順を適用する必要があります。
  1. [スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ] を順にポイントし、[メモ帳] をクリックします。
  2. 次のテキストを入力します。
    [GuiRunOnce]

    Command0=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f”

    Command1=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f”

    Command2=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f”

    Command3=”reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f”
  3. [ファイル] メニューの [上書き保存] をクリックし、[はい] をクリックします。
  4. Sysprep.exe ファイルが存在するディレクトリに移動します。
  5. [ファイル名] ボックスに、「Sysprep.inf」と入力します。
  6. [ファイルの種類] ボックスの [すべてのファイル] をクリックします。
  7. [上書き保存] をクリックします。
  8. [ファイル] メニューの [レジストリ エディターの終了] をクリックします。

詳細

Windows 2000、Windows Server 2003、または Windows XP のイメージを使用してセットアップされた最初の Windows 2000 ベース、Windows Server 2003 ベース、または Windows XP ベースのコンピューターが WSUS コンソールに表示されます。ただし、同じイメージを使用してセットアップされた次の Windows 2000 ベース、Windows Server 2003 ベース、または Windows XP ベースのコンピューターが表示されません。この問題は、これらのいずれかのイメージを使用してセットアップされた最初のコンピューターが同じ SusClientID 値を使用していることが原因で発生します。

「解決方法」セクションで説明している手順に従った後、新しい SusClientID 値が作成されます。また、同じイメージを使用してセットアップされた次の Windows 2000 ベース、Windows Server 2003 ベース、または Windows XP ベースのコンピューターが WSUS コンソールに表示されます。

WSUS クライアント コンピューターにインストールされる Windows Update Agent に自動機能が追加されました。この機能は、この重複する SusClientID の問題に対応するときに役立ちます。この機能は、Version 7.0.6000.374 で始まるクライアント側 Windows Update Agent に追加される解決方法を提供します。(このバージョンは WSUS 3.0 に含まれるクライアント バージョンです)。

この解決方法は、ハードウェア検証ルーチンを使用して、SUSClientID の作成以降に現在のクライアント ハードウェアが変更されたかどうかを判定します。(このハードウェアには、ネットワーク アダプターやハード ディスクが含まれます)。

このハードウェア検証ルーチンは、Susclientid レジストリ値と同じ場所にある Susclientidvalidation レジストリ キーにバイナリ ラージ オブジェクトとして格納されます。ハードウェア検証ルーチンですべてのハードウェアが変更されたことが示された場合、クライアントにより新しい SusClientID 値が生成されます。

: このハードウェア検証ルーチンでは、Windows Software Update Services 2.0 を実行しているサーバーではなく、Windows Software Update Services 3.0 以降のバージョンの WSUS を実行しているサーバーにクライアントが接続する必要があります。

プロパティ

文書番号: 903262 - 最終更新日: 2011年9月25日 - リビジョン: 2.0
キーワード:?
kbtshoot kbprb kbdeployment KB903262
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