Код статьи: 903267 - Последнее изменение :: 16 января 2006 г. - Редакция: 1.0

Не удается просмотреть компьютеры другой рабочей группы сети с компьютера под управлением Windows XP

Внимание! Статья содержит сведения о внесении изменений в системный реестр. Перед внесением изменений рекомендуется создать резервную копию системного реестра и изучить процедуру его восстановления. Дополнительные сведения о создании резервной копии, восстановлении и изменении реестра см. в следующей статье базы знаний Майкрософт:
256986  (http://support.microsoft.com/kb/256986/ ) Описание реестра Microsoft Windows
Развернуть все | Свернуть все

Проблема

Предположим, вы работаете на компьютере под управлением Microsoft Windows XP и выполняются следующие условия.
  • Компьютер входит в сетевое окружение.
  • Компьютер является членом рабочей группы.
  • Возможно, на компьютере не активирован либо не установлен брандмауэр.
  • Компьютеру удается выполнить обмен пакетами с другими компьютерами одной и той же рабочей группы. Кроме того, другие компьютеры этой же рабочей группы способны выполнить обмен пакетами с этим компьютером.
  • Активирован протокол NetBIOS через TCP/IP.
Предположим, вам не удается просмотреть компьютеры другой рабочей группы в сети.

Причина

Эта проблема может возникнуть, если компьютер настроен на использование метода р-узла для разрешения имен. Чтобы установить, настроен ли компьютер на использование метода р-узла, выполните следующие действия:
  1. Выберите в меню Пуск пункт Выполнить, введите команду cmd и нажмите кнопку ОК.
  2. В командной строке введите ipconfig /all и нажмите клавишу ВВОД.
Просмотрите раздел Тип узла перед началом вывода. Если на экране отображается значение Одноранговый, компьютер работает в режиме p-узла.

В режиме p-узла компьютер использует только запросы имен типа «точка-точка» к серверу имен Windows Internet Name Service (WINS). Однако сервер WINS недоступен для разрешения имен NetBIOS в одноранговой сети.

Решение

Предупреждение. Неправильное изменение параметров системного реестра с помощью редактора реестра или любым иным путем может привести к возникновению серьезных неполадок, требующих переустановки операционной системы. Корпорация Майкрософт не гарантирует устранения этих неполадок. Ответственность за результаты произведенных действий несет пользователь.

Для решения проблемы выполните следующие действия:
  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите в командную строку regedit и нажмите кнопку ОК.
  2. Найдите и выделите следующий раздел реестра:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetBt\Parameters
  3. На правой панели редактора реестра удалите следующие значения, если они имеются.
    • NodeType
    • DhcpNodeType
    Примечание. Если значение NodeType присутствует, оно переопределяет значение DhcpNodeType. Если раздел отсутствует и не обнаружены серверы WINS, настроенные для работы с клиентом, компьютер использует режим b-узла. Если по крайней мере один сервер WINS настроен, компьютер использует режим h-узла.
  4. Закройте редактор реестра.
  5. Перезагрузите компьютер.
  6. Попробуйте еще раз просмотреть компьютеры в сети.

Дополнительная информация

Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:
160177  (http://support.microsoft.com/kb/160177/ ) Тип узла по умолчанию для клиентов Майкрософт (эта ссылка может указывать на содержимое полностью или частично на английском языке.)
314053  (http://support.microsoft.com/kb/314053/ ) Параметры конфигурации TCP/IP и NBT для Windows XP

Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
Ключевые слова: 
kbtshoot kbprb KB903267
 

Переводы статьи

 

Related Support Centers