Fehlermeldung "Fehler 80070643" beim Versuch, Office 2003 mit Software Update Services zu aktualisieren

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 903772 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
903772 You receive an "Error 80070643" error message when you try to update Office 2003 by using Software Update Services
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Beim Versuch, Microsoft Office 2003 mit Microsoft Software Update Services (SUS) zu aktualisieren, wird folgende Fehlermeldung angezeigt:
Fehler 80070643
Darüber hinaus kann die Datei "WindowsUpdate.log" Fehlermeldungen enthalten, die den folgenden Meldungen ähneln:
2005-07-11 10:44:01 1056 250 Handler : MSI transaction completed. MSI: 0x80070643, Handler: 0x8024200b, Source: No, Reboot: 0

2005-07-11 10:44:01 1056 250 Handler : WARNING: First failure for update {EF358F39-A507-45A8-9E84-D626D099E8BD}, transaction error = 0x8024200b, MSI result = 0x80070643, MSI action = StartCache

Ursache

In der Regel tritt dieses Problem auf, wenn eine der folgenden Bedingungen zutrifft:
  • Die Microsoft Office Source Engine (Ose.exe) ist deaktiviert.
  • Die Datei "Ose.exe" ist beschädigt.

Lösung

Führen Sie die folgenden Schritte in der angegebenen Reihenfolge aus, um dieses Problem zu beheben.

Methode 1: Ermitteln des Status des Office Source Engine-Dienstes

Gehen Sie folgendermaßen vor, um den Status des Office Source Engine-Dienstes zu ermitteln:
  1. Klicken Sie auf Start und anschließend auf Ausführen. Geben Sie services.msc ein, und klicken Sie auf OK.
  2. Doppelklicken Sie in der Liste der Dienste auf Office Source Engine.
  3. Sehen Sie sich die Liste Starttyp an.
  4. Wenn der Starttyp auf Deaktiviert eingestellt ist, ändern Sie ihn auf Manuell. Klicken Sie hierzu in der Liste Starttyp auf Manuell und anschließend auf OK.
  5. Versuchen Sie nochmals, das Office-Update zu installieren.

Methode 2: Reparieren der Datei "Ose.exe"

Kopieren Sie die Datei "Ose.exe" von der Office 2003-CD, um sie zu reparieren. Gehen Sie hierzu folgendermaßen vor:
  1. Suchen Sie die Datei "Ose.exe". Standardmäßig befindet sich die Datei "Ose.exe" im folgenden Verzeichnis:
    Pfad:\Programme\Gemeinsame Dateien\Microsoft Shared\Source Engine\
  2. Legen Sie die Office 2003-CD in das CD-Laufwerk ein.
  3. Klicken Sie mit der rechten Maustaste auf Start, und klicken Sie anschließend auf Explorer.
  4. Suchen Sie mit Microsoft Windows Explorer den folgenden Ordner auf der Office 2003-CD:
    Pfad:\Files\Setup
  5. Klicken Sie mit der rechten Maustaste auf die Datei "Ose.exe, und klicken Sie anschließend auf Kopieren.
  6. Suchen Sie den Ordner, in dem sich die Datei "Ose.exe" auf dem Computer befindet, und markieren Sie ihn. Suchen und markieren Sie z. B. den folgenden Ordner:
    Pfad:\Programme\Gemeinsame Dateien\Microsoft Shared\Source Engine
  7. Klicken Sie mit der rechten Maustaste auf den Ordner "Source Engine", und klicken Sie anschließend auf Einfügen.
  8. Klicken Sie auf Ja, wenn Sie gefragt werden, ob die vorhandene Datei ersetzt werden soll.

Methode 3: Entfernen und Neuinstallieren von Office 2003

Gehen Sie folgendermaßen vor, um Office 2003 zu entfernen und anschließend neu zu installieren:

Hinweis: Da es verschiedene Windows-Versionen gibt, können die folgenden Schritte auf Ihrem Computer anders aussehen. Lesen Sie in diesem Fall in Ihrer Produktdokumentation nach, wie diese Schritte auszuführen sind.
  1. Legen Sie die Office 2003-CD in das CD-Laufwerk ein.
  2. Klicken Sie auf Start und anschließend auf Systemsteuerung.
  3. Klicken Sie auf Software.
  4. Klicken Sie in der Liste Zurzeit installierte Programme auf die installierte Version von Office 2003 und anschließend auf Entfernen.
  5. Klicken Sie auf Ja, wenn Sie aufgefordert werden zu bestätigen, dass Office 2003 entfernt werden soll.
  6. Nachdem Office 2003 vom Computer entfernt wurde, klicken Sie auf Neue Programme hinzufügen.
  7. Klicken Sie auf CD oder Diskette.
  8. Vergewissern Sie sich im Dialogfeld Programm von Diskette oder CD installieren, dass sich die Office 2003-CD im CD-Laufwerk befindet. Klicken Sie anschließend auf Weiter.
  9. Klicken Sie auf Fertig stellen. Folgen Sie dann den Anweisungen, um die Installation von Office 2003 abzuschließen.
  10. Klicken Sie auf OK, wenn die Installation von Office 2003 abgeschlossen ist.
  11. Entfernen Sie die Office 2003-CD aus dem CD-Laufwerk.

Weitere Informationen

Wenn Sie Office 2003 von der Office 2003-CD oder von einem Image der Office 2003-CD installieren, installiert das Setup-Programm den Systemdienst "Ose.exe" (Office Source Engine), um die benötigten Installationsdateien auf den lokalen Computer zu kopieren. Wenn das Programm "Setup.exe" die Datei mit den Setup-Einstellungen gelesen hat, führt es die folgenden Aktionen durch:
  • Es ermittelt das Laufwerk, das den meisten freien Platz auf dem lokalen Computer hat.
  • Es überprüft, ob der Benutzer über Administratorrechte verfügt.
  • Es installiert die Office Source Engine.
Weitere Informationen zur Office Source Engine finden Sie in einer der folgenden Informationsquellen des Microsoft Office 2003 Editions Resource Kit:
  • In der Druckversion des Office 2003 Editions Resource Kit fin den Sie Informationen auf Seite 23.
  • Die Onlineversion des Office 2003 Editions Resource Kit finden Sie auf der folgenden Microsoft-Website:
    http://office.microsoft.com/en-us/ork2003/HA011402031033.aspx

Eigenschaften

Artikel-ID: 903772 - Geändert am: Mittwoch, 13. Dezember 2006 - Version: 4.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Students and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Software Update Services 1.0
Keywords: 
kbtshoot kbprb KB903772
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com