当您尝试通过使用软件更新服务更新 Office 2003 时,您会收到"错误 80070643"错误消息

文章翻译 文章翻译
文章编号: 903772 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

当您使用 Microsoft 软件更新服务 (SUS) 来更新 Microsoft Office 2003年时,您会收到以下错误消息:
错误 80070643
此外,WindowsUpdate.log 文件可能包含与以下类似的错误:
2005 年 07 月 11 日 10: 44: 01 1056年 250 处理程序: MSI 事务已完成。MSI: 0x80070643,处理程序: 0x8024200b,源: 否,重新启动: 0

2005 年 07 月 11 日 10: 44: 01 1056年 250 处理程序: 警告: 第一次失败的更新 {EF358F39-A507-45A8-9E84-D626D099E8BD},事务处理错误 = 0x8024200b,MSI 结果 = 0x80070643,MSI 操作 = StartCache

原因

通常情况下,如果满足下列条件之一为真时,发生此问题:
  • Microsoft Office 源引擎 (Ose.exe) 将被禁用。
  • Ose.exe 文件已损坏。

解决方案

若要解决此问题,请按出现的顺序使用下列方法。

方法 1: 确定 Office 源引擎服务的状态

要确定 Office 源引擎服务的状态,请执行以下步骤:
  1. 单击 开始单击 运行键入 services.msc然后单击 确定.
  2. 在服务列表中,双击 Office 源引擎.
  3. 视图 启动类型 列表。
  4. 如果启动类型设置为 已禁用将启动类型更改为 手册.若要执行此操作,请单击 手册 在中 启动类型 列表,然后再单击 确定.
  5. 尝试重新安装 Office 更新。

方法 2: 修复 Ose.exe 文件

要修复的 Ose.exe 文件,请将 Ose.exe 文件复制 Office 2003 安装光盘。若要执行此操作,请执行以下步骤:
  1. 确定 Ose.exe 文件所在的位置。默认情况下的 Ose.exe 文件位于以下位置:
    路径:\Program Files\Common 是 Shared\Source Engine\
  2. 将 Office 2003 安装光盘插入 CD 驱动器中。
  3. 用鼠标右键单击 开始然后单击 探索.
  4. 使用 Microsoft Windows 资源管理器来查找 Office 2003 安装光盘上的以下文件夹:
    路径:\Files\Setup
  5. Ose.exe 文件中,用鼠标右键单击,然后单击 副本.
  6. 找到并单击要选择的 Ose.exe 文件位于计算机的文件夹。例如,找到并单击要选择的以下文件夹:
    路径:\Program Files\Common 是 Shared\Source 引擎
  7. 源引擎文件夹中,用鼠标右键单击,然后单击 粘贴.
  8. 如果系统提示您替换现有文件,单击 .

方法 3: 删除并重新安装 Office 2003

若要删除并重新安装 Office 2003,请按照下列步骤。

注意 因为有多个版本的 Microsoft Windows,下面的步骤可能不同于您的计算机。如果是这样,请参阅产品文档来完成这些步骤。
  1. 将 Office 2003 安装光盘插入 CD 驱动器中。
  2. 单击 开始然后单击 控制面板.
  3. 单击 添加或删除程序.
  4. 在中 当前安装的程序 列表中,单击该版本的 Office 2003 的安装,然后单击 删除.
  5. 单击 当提示您确认要删除 Office 2003。
  6. 从计算机中删除 Office 2003 后,单击 添加新程序.
  7. 单击 CD 或软盘.
  8. 在中 从软盘或光盘安装程序 对话框框中,请确保 Office 2003 安装光盘在光驱中。然后,单击 下一步.
  9. 单击 完成.然后,按照提示完成 Office 2003 的安装。
  10. 单击 确定 当 Office 2003 安装程序已完成。
  11. 从 CD 驱动器中删除 Office 2003 安装光盘。

更多信息

在从 Office 2003 安装光盘或从图像的 Office 2003 安装光盘安装 Office 2003 时,安装程序将安装 Office 源引擎 (Ose.exe) 系统服务将必需的安装文件复制到本地计算机。Setup.exe 安装程序设置文件中读取后,Setup.exe 将执行下列操作:
  • 确定已在本地计算机上的最多可用空间的驱动器
  • 验证用户具有管理权限
  • 设置 Office 源引擎
有关 Office 源引擎的详细信息,请参阅下面的 Microsoft Office 2003年版资源工具包资源之一:
  • 在 Office 2003 版资源工具包中包含的打印版本中,请参见 23 页。
  • 在 Office 2003 版资源工具包中包含的联机版本,请访问下面的 Microsoft 网站:
    http://office.microsoft.com/en-us/ork2003/HA011402031033.aspx

属性

文章编号: 903772 - 最后修改: 2013年1月27日 - 修订: 9.0
这篇文章中的信息适用于:
  • Microsoft Office 专业版 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Software Update Services
关键字:?
kbtshoot kbprb kbmt KB903772 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 903772
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com