Si vous désactivez le fichier Ose.exe, les mises à jour Microsoft Office ne sont pas installées lorsque vous utilisez Microsoft WSUS ou le site Web Microsoft Update pour déployer des mises à jour et des correctifs

Traductions disponibles Traductions disponibles
Numéro d'article: 903774 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Avis

Cet article est destiné aux utilisateurs expérimentés. Si vous ne maîtrisez pas le dépannage avancé, vous pouvez demander à un utilisateur plus expérimenté de vous aider ou vous pouvez contacter le support technique. Pour plus d'informations sur la procédure à suivre, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus

Symptômes

Lorsque vous déployez des mises à jour et des correctifs logiciels sur des ordinateurs de votre organisation à l'aide des services Microsoft Windows Server Update Services (WSUS) ou du site Web Microsoft Update, certaines mises à jour Microsoft Office ne sont pas installées correctement sur certains ordinateurs clients. Dans cette situation, l'utilisateur de l'ordinateur client peut recevoir le message suivant dans la boîte de dialogue Mises à jour automatiques :
Impossible d'installer les mises à jour correctement
Si vous affichez le fichier journal C:\Windows\WindowsUpdate sur l'ordinateur client concerné, vous pouvez observer une entrée de journal semblable à la suivante :
<date>    <heure>    3124   c54   Handler   : WARNING: First failure for update {GUID}, transaction error = 0x8024200b, MSI result = 0x80070643, MSI action = StartCache
Si vous affichez l'onglet État de la zone Propriétés de l'ordinateur ? Dialogue de page Web pour l'ordinateur affecté sur le site Web d'administration des services WSUS, vous voyez l'entrée suivante :
Réduire ce tableauAgrandir ce tableau
Titre de la mise à jourApprobationÉtat
Nom de la mise à jour et numéro d'article de la Base de connaissancesInstallationÉchec
Si vous cliquez sur Échec dans ce tableau, les informations suivantes apparaissent :
Réduire ce tableauAgrandir ce tableau
DateDétailsCode de résultat
Date et heureÉchec de l'installation : installer la mise à jour suivante en précisant l'erreur 0x80070643 : Nom de la mise à jour et numéro d'article de la Base de connaissances0x80070643
Date et heureTéléchargement réussi.0x00000000

Cause

Ce problème peut se produire si le type de démarrage du service Office Source Engine (Ose.exe) est défini avec la valeur Désactivé. Par défaut, le type de démarrage du service Office Source Engine est défini avec la valeur Manuel. Microsoft Windows Installer utilise une action personnalisée pour démarrer le service Office Source Engine. Toutefois, Windows Installer ne peut pas démarrer le service Office Source Engine si ce service est désactivé.

Résolution

Pour résoudre ce problème, procédez comme suit :
  1. Déterminez l'état du service Office Source Engine. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, sur Exécuter, tapez services.msc, puis cliquez sur OK.
    2. Dans la liste des services, double-cliquez sur Office Source Engine.
    3. Affichez l'option qui apparaît dans la liste Type de démarrage.
  2. Si le type de démarrage est défini avec la valeur Désactivé, modifiez-le en Manuel. Pour cela, dans la liste Type de démarrage, cliquez sur Manuel, puis sur OK.
  3. Essayez à nouveau d'installer les packages de mise à jour Office.

Propriétés

Numéro d'article: 903774 - Dernière mise à jour: jeudi 10 avril 2008 - Version: 4.5
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Édition Professionnelle 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Students and Teachers Edition 2003
  • Microsoft Office Édition PME 2003
  • Microsoft Office Édition Basique 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Access 2003
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Word 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2007 with Business Contact Manager
  • Microsoft Office OneNote 2007
  • Microsoft Office Excel 2007
Mots-clés : 
kbresolve kbtshoot kbprb KB903774
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com