หากคุณปิดใช้งานแฟ้ม Ose.exe การปรับปรุงของ Microsoft Office จะไม่ติดตั้งเมื่อคุณใช้ Microsoft Windows Server Update Services หรือเว็บไซต์ Microsoft Update เพื่อปรับใช้การปรับปรุงซอฟต์แวร์และโปรแกรมแก้ไขด่วนกับคอมพิวเตอร์ในองค์กร

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 903774 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อคุณปรับใช้การปรับปรุงซอฟต์แวร์และโปรแกรมแก้ไขด่วนกับคอมพิวเตอร์ในองค์กรของคุณด้วยการใช้ Microsoft Windows Server Update Services (WSUS) หรือด้วยการใช้เว็บไซต์ Microsoft Update การปรับปรุงของ Microsoft Office บางอย่างอาจติดตั้งไม่สำเร็จบนคอมพิวเตอร์ไคลเอ็นต์บางเครื่อง ในสถานการณ์นี้ ผู้ใช้คอมพิวเตอร์ไคลเอ็นต์เครื่องดังกล่าวอาจได้รับข้อความต่อไปนี้ในกล่องโต้ตอบ ปรับปรุงอัตโนมัติ
ติดตั้งการปรับปรุงไม่สำเร็จ
หากคุณดูแฟ้มบันทึก C:\Windows\WindowsUpdate บนคอมพิวเตอร์ไคลเอ็นต์ที่ได้รับผลกระทบ คุณอาจสังเกตเห็นรายการแฟ้มบันทึกที่เหมือนกับข้อมูลต่อไปนี้:
<วันที่>    <เวลา>   3124   c54   ตัวจัดการ   : คำเตือน: การปรับปรุงล้มเหลวครั้งแรก {GUID}, ทรานแซคชันเกิดข้อผิดพลาด = 0x8024200b, ผลลัพธ์ของ MSI = 0x80070643, การดำเนินการ MSI = StartCache
หากคุณต้องการดูแท็บ สถานะ ของ คุณสมบัติคอมพิวเตอร์ -- กล่องโต้ตอบเว็บเพจ สำหรับคอมพิวเตอร์ที่ได้รับผลกระทบบนเว็บไซต์การดูแล Windows Server Update Services คุณจะสังเกตเห็นรายการข้อมูลต่อไปนี้
ยุบตารางนี้ขยายตารางนี้
ชื่อการปรับปรุงการอนุมัติสถานะ
ชื่อการปรับปรุงและหมายเลข KBติดตั้งล้มเหลว
หากคุณคลิก ล้มเหลว ในตารางนี้ จะปรากฏข้อมูลดังต่อไปนี้
ยุบตารางนี้ขยายตารางนี้
วันที่รายละเอียดโค้ดผลลัพธ์
วันที่และเวลาความล้มเหลวในการติดตั้ง: Windows ไม่สามารถติดตั้งการปรับปรุงต่อไปนี้พร้อมกับข้อผิดพลาด 0x80070643 ชื่อการปรับปรุงและหมายเลข KB0x80070643
วันที่และเวลาดาวน์โหลดเสร็จเรียบร้อย0x00000000

สาเหตุ

ปัญหานี้อาจเกิดขึ้นหากชนิดการเริ่มต้นของบริการ Office Source Engine (Ose.exe) มีการตั้งค่าเป็น ปิดใช้งาน โดยค่าเริ่มต้น ชนิดการเริ่มต้นของบริการ Office Source Engine มีการตั้งค่าเป็น ด้วยตนเอง Microsoft Windows Installer ใช้การดำเนินการแบบกำหนดเองเพื่อเริ่มต้นบริการ Office Source Engine อย่างไรก็ตาม Windows Installer ไม่สามารถเริ่มต้นบริการ Office Source Engine ได้หากบริการ Office Source Engine มีการปิดใช้งาน

การแก้ไข

เมื่อต้องการแก้ปัญหานี้ ให้ทำตามขั้นตอนต่อไปนี้
  1. ระบุสถานะของบริการ Office Source Engine โดยทำตามขั้นตอนต่อไปนี้
    1. คลิกที่ เริ่ม คลิก เรียกใช้ พิมพ์ services.msc แล้วคลิก ตกลง
    2. ในรายการบริการต่างๆ คลิกสองครั้งที่ Office Source Engine
    3. ดูตัวเลือกที่ปรากฏในรายการ ชนิดการเริ่มต้น
  2. หากชนิดการเริ่มต้นมีการตั้งค่าเป็น ปิดใช้งาน ให้เปลี่ยนชนิดการเริ่มต้นเป็น ด้วยตนเอง เมื่อต้องการทำสิ่งนี้ ให้คลิก ด้วยตนเอง ในรายการ ชนิดการเริ่มต้น แล้วคลิก ตกลง
  3. ลองติดตั้งแพคเกจ Office Update อีกครั้ง

คุณสมบัติ

หมายเลขบทความ (Article ID): 903774 - รีวิวครั้งสุดท้าย: 20 เมษายน 2550 - Revision: 3.3
ใช้กับ
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Students and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Access 2003
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Word 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2007 with Business Contact Manager
  • Microsoft Office OneNote 2007
  • Microsoft Office Excel 2007
Keywords: 
kbtshoot kbprb KB903774

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com